Jump to content

Sign in to follow this  
netshadoe

Heads up on new AI separation utilities for P3Dv4

Recommended Posts

Posted (edited)

I tested Smart Retain 25  at 'EHAM'

 

It deleted all sleeping and there were 17 enroute.

Initially, I had 136 AI plane, started the 'A3' rule, ended up with only 17 enroute, 1 taxi-out and 0 sleeping. I guess I would have expected 24 sleeping and 1 taxi-out

Testing at CYUL was a better mix of sleeping, There were less AI there 

 

FYI, I switch location, from CYUL to EHAM to test and got a crash:

Log Name:      Application
Source:        Application Error
Date:          5/27/2020 2:08:53 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      Gaming
Description:
Faulting application name: AICull.exe, version: 1.0.0.1, time stamp: 0x5ece6ec2
Faulting module name: AICull.exe, version: 1.0.0.1, time stamp: 0x5ece6ec2
Exception code: 0xc0000005
Fault offset: 0x000000000001221e
Faulting process id: 0x4254
Faulting application start time: 0x01d63450d0874951
Faulting application path: C:\Users\vince\Documents\Prepar3D v5 Add-ons\AICull\AICull.exe
Faulting module path: C:\Users\vince\Documents\Prepar3D v5 Add-ons\AICull\AICull.exe
Report Id: 3787b296-da45-4d87-898e-2a1d85e09067
Faulting package full name: 
Faulting package-relative application ID: 
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Version>0</Version>
    <Level>2</Level>
    <Task>100</Task>
    <Opcode>0</Opcode>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2020-05-27T18:08:53.7017487Z" />
    <EventRecordID>7967</EventRecordID>
    <Correlation />
    <Execution ProcessID="0" ThreadID="0" />
    <Channel>Application</Channel>
    <Computer>Gaming</Computer>
    <Security />
  </System>
  <EventData>
    <Data>AICull.exe</Data>
    <Data>1.0.0.1</Data>
    <Data>5ece6ec2</Data>
    <Data>AICull.exe</Data>
    <Data>1.0.0.1</Data>
    <Data>5ece6ec2</Data>
    <Data>c0000005</Data>
    <Data>000000000001221e</Data>
    <Data>4254</Data>
    <Data>01d63450d0874951</Data>
    <Data>C:\Users\vince\Documents\Prepar3D v5 Add-ons\AICull\AICull.exe</Data>
    <Data>C:\Users\vince\Documents\Prepar3D v5 Add-ons\AICull\AICull.exe</Data>
    <Data>3787b296-da45-4d87-898e-2a1d85e09067</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

Edited by vincentrouleau

Vincent Rouleau

Intel Core i7 8700K @ 5.1GHz / 16.0GB G.SKILL TridentZ DDR4 3000 / Gigabyte  GeForce® RTX 2080 / / Samsung C49RG9 49' /ASUS  PB287QQ ‑ 27" UHD / Samsung 970 PRO 1TB /  PNY SSD 1TB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post

Never mind, Its just the '25' is too aggressive. It the logic is ok.

I still have 1 problem. I've set the aicull.exe to run as administrator and it works when I start it manually. But when started via 'add-ons.xml' It will not work. I will use "SimstarterNG" to start it , but does anybody know how to fix that?


Vincent Rouleau

Intel Core i7 8700K @ 5.1GHz / 16.0GB G.SKILL TridentZ DDR4 3000 / Gigabyte  GeForce® RTX 2080 / / Samsung C49RG9 49' /ASUS  PB287QQ ‑ 27" UHD / Samsung 970 PRO 1TB /  PNY SSD 1TB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post

I've installed these utilities, but I believe they're not working if I observe traffic from the P3Dv4.5 Control Tower view, which is a bit of a shame as that's my favourite viewpoint for watching traffic flow at an airport, particularly for traffic files and airports I've designed myself. The dialogue for AIGround is showing "User Aircraft Airborne, AIGround Will Start When Aircraft Lands", while AIFlow is not applying the separation and speed criteria for the approach that I've specified (yes, I've deleted the comment '//' and saved the .ini file, which I believe is what is needed to activate those preferences. Is there a way of allowing for this veiwpoint?

Share this post


Link to post

I am curious to know why a viewpoint would have any effect on the functioning of these apps.


Cheers

Steve Hall

Share this post


Link to post
Posted (edited)
7 hours ago, TimC340 said:

I've installed these utilities, but I believe they're not working if I observe traffic from the P3Dv4.5 Control Tower view, which is a bit of a shame as that's my favourite viewpoint for watching traffic flow at an airport, particularly for traffic files and airports I've designed myself. The dialogue for AIGround is showing "User Aircraft Airborne, AIGround Will Start When Aircraft Lands", while AIFlow is not applying the separation and speed criteria for the approach that I've specified (yes, I've deleted the comment '//' and saved the .ini file, which I believe is what is needed to activate those preferences. Is there a way of allowing for this veiwpoint?

You must be doing something wrong, Save your ini files and delete both ground and air programs, grab the latest from a few pages back, Unzip both folders in your v4 add-on documents folder, let the xml exe start the program, when the sim loads make a dummy flighplan, jump in the tower view and watch. they work for me 100%, Both v4 and 5. Make sure you have simmconnect installed.

Edited by RW1

Banner_FS2Crew_Supporter.jpg

 

Rick Wilson

 

 

Share this post


Link to post

RW1, both AIGround and AIFlow (both HF4) are working fine if I use a surface viewpoint such as Orbx 'Bob', JF's 'Spotty' or P3D's various avatars - or even an aeroplane. But if I use the P3D tower view (which is derived from Orbx's tower) when I create a flight or move to another airport, they interpret the elevated position as meaning you're in flight (and report as such in the command-line dialogue), and thus there are different routines in play.

Share this post


Link to post

Hi All

 

All 'ini's' are active but AICuL does not seem to 'cul' any AI, just 'attempts to delete '

ai1.png

 

What have I missed?

 

Thanks


Clive Joy


beta.gif

Posted Image

Share this post


Link to post

I need to run it ‘run as administrator’ for it to work. I dont know why would aiflow and aiground would work ok without it. Bummer ,as starting it via addons.xml does work because of that


Vincent Rouleau

Intel Core i7 8700K @ 5.1GHz / 16.0GB G.SKILL TridentZ DDR4 3000 / Gigabyte  GeForce® RTX 2080 / / Samsung C49RG9 49' /ASUS  PB287QQ ‑ 27" UHD / Samsung 970 PRO 1TB /  PNY SSD 1TB / Windows 10 Pro 64-bit / Gigabyte Z370 AORUS Gaming 5 Motherboard

Share this post


Link to post

Vicent,

Just set the EXE to run as ADMIN. [Right Click exe] > Properties > Compatibility  Tick 'Run this program as an Administrator'. Click 'Apply' 


Clive Joy


beta.gif

Posted Image

Share this post


Link to post
Posted (edited)
On 5/27/2020 at 2:11 PM, vincentrouleau said:

FYI, I switch location, from CYUL to EHAM to test and got a crash:

 

Vincent, thanks for the report.  I'll look into this in terms of error-handling, but I wouldn't run AICull while directly jumping to new locations. For operational modes that require detection of the current airport (e.g., Current ICAO and Smart Retain X), AICull prevents the closet airport from immediately switching to some random nearby airport as the user aircraft departs in order to maintain consistent AI traffic liming.  However because of this, if the user “jumps” to another another airport (e.g., Navigation\Go to Airport”), the user should “STOP and RESET," jump, then EXEC again (see readme for more details).

Edited by Clipper Ocean Spray

Share this post


Link to post
22 hours ago, TimC340 said:

RW1, both AIGround and AIFlow (both HF4) are working fine if I use a surface viewpoint such as Orbx 'Bob', JF's 'Spotty' or P3D's various avatars - or even an aeroplane. But if I use the P3D tower view (which is derived from Orbx's tower) when I create a flight or move to another airport, they interpret the elevated position as meaning you're in flight (and report as such in the command-line dialogue), and thus there are different routines in play.

Weird, I don't see that when I use the P3D control tower, but it is super-easy for me to add an AI observation mode only for plane spotting that makes sure there won't be a problem even if the user is determined to be airborne, so I'll go ahead and do that.

  • Like 2

Share this post


Link to post
4 hours ago, alpha117 said:

Hi All

 

All 'ini's' are active but AICuL does not seem to 'cul' any AI, just 'attempts to delete '

ai1.png

 

What have I missed?

 

Thanks

Clive, are you using a simconnect-based traffic injector like Ultimate Traffic?  They will re-inject culled traffic (they have their own traffic limiters).

Share this post


Link to post
39 minutes ago, alpha117 said:

Vicent,

Just set the EXE to run as ADMIN. [Right Click exe] > Properties > Compatibility  Tick 'Run this program as an Administrator'. Click 'Apply' 

Yep, same here with on my kid's PC (they don't have an admin account).  There are other utilities that require me to run P3D in admin mode (in an non-admin account) as well.

Share this post


Link to post

Hi Roland,

 

I'm using AIG AI


Clive Joy


beta.gif

Posted Image

Share this post


Link to post

Hi Roland,

Firstly many thanks for developing such a great series of AI apps. Very much appreciated.

I know that this has been mentioned before but it would be great if you could reconsider amalgamating all 3 programs into 1.
Even though I have them all set to open and close via FSUIPC I end up having so many apps/programs running now that it is becoming an issue.
For example a session for me requires Ai ground, Ai Flow, Ai Cull, ASPD4, Chaseplane, Navigraph charts, MSI afterburner and RTSS, Simserver (for remote CDU). Then there is the VATSIM client etc if flying online. Tidy desktop management.is becoming an issue!

I have started noticing that the AI are now conducting some very hard landings. Could certain settings in Ai Flow or Ground  be causing this behaviour? I'm using the ORBX AI NZ/AUS pakage
Also is anyone else having an issue when closing AI Cull with the FSUIPC CLOSE entry in the Run N command line? I get Ai Cull did not close properly blah blah blah.
 

 

  • Like 1

Cheers

Steve Hall

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    22%
    $5,550.00 of $25,000.00 Donate Now
×
×
  • Create New...