Jump to content
Sign in to follow this  
Ray Proudfoot

[Resolved] P3D v5.4 random lockups driving me mad

Recommended Posts

@simfan1983, thanks. Quite a list but I can’t see anything related to my problem.


Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

I had this reply from Chillblast today…

Thanks for sending those over! The Overall CPU temperature doesn't look to be going over 80 which for that CPU is really good. If you have managed to resolve the issue without adjusting power settings etc. then there is no need to set any of these settings and in general they are best to avoid. If the sim is working as you expect with no crashing or instability then I would certainly leave it as it is.

The thermal protection will kick in should it need to, but that will use a different sensor than your are looking at which is likely why it is not kicking in, as the system does not  think it is needed yet.”

The reason the temps look good to them is because I limit fps to 30 with a 30Hz monitor and VSync. Imagine what they would be without it. Trying to maintain 60 means it running flat out with all the problems that would bring.

So no issues with temps. 👍


Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Ray,

Have you TOTALLY UNINSTALLED AIG before upgrading to 5.4?  My suggestion is just that.  Uninstall all of AIG, fire up 5.4, and then REINSTALL AIG.  If you've done that, then this suggestion is moot!

 

Share this post


Link to post
21 minutes ago, spilok said:

Ray,

Have you TOTALLY UNINSTALLED AIG before upgrading to 5.4?  My suggestion is just that.  Uninstall all of AIG, fire up 5.4, and then REINSTALL AIG.  If you've done that, then this suggestion is moot!

 

No. I installed the base program on the new computer and then copied the subfolders over from my old computer and edited the paths to P3D.

 With over 1300 BGLs I was never going to start afresh.

The problems only started when I updated to 5.4. Why would it be necessary to uninstall and reinstall AIG for a point update?


Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Posted (edited)
On 1/4/2024 at 1:18 AM, spilok said:

 If I had a choice between 5.4 and AIG, I would dump AIG in the blink of an eye

And go without AI aircraft?

Edited by IanHarrison

Intel i7 6700K @4.3. 32gb Gskill 3200 RAM. Z170x Gigabyte m/b. 28" LG HD monitor. Win 10 Home. 500g Samsung 960 as Windows home. 1 Gb Mushkin SSD for P3D. GTX 1080 8gb.

Share this post


Link to post
18 hours ago, Ray Proudfoot said:

But when you have over 1300 BGLs how do you identify the ones causing the problem?

Ray, I didn't realize you had that many BGLs.. I thought it was 150 but now I see that it was someone else who posted that number. Anyway, I'm glad you have a good working sim with 5.3 as you have been working a long time to get into the 64 bit Concorde.

Ted

  • Like 1

3770k@4.5 ghz, Noctua C12P CPU air cooler, Asus Z77, 2 x 4gb DDR3 Corsair 2200 mhz cl 9, EVGA 1080ti, Sony 55" 900E TV 3840 x 2160, Windows 7-64, FSX, P3dv3, P3dv4

Share this post


Link to post
Posted (edited)
5 hours ago, IanHarrison said:

And go without AI aircraft?

I have plenty with UT Live!  It works beautifully in 5.4 using the Version 4 UT Live connector in my addons folder. Really, though...what's important in flying a realistic simulator?  I prefer the updated scenery, environment, and stability in the latest version of P3d over seeing thousands of AI aircraft all over the place. UT Live gives me a sufficient number of planes (although not as many as in AIG) to make me very satisfied that I'm not ALONE flying into empty airports or seeing aircraft in the skies as I fly.

To each his own!

Stan 

Edited by spilok
  • Like 2

Share this post


Link to post

I'm going to mark this as resolved. I'm on my 16th flight since 7 Jan and all have been problem-free. Not a single freeze / lockup.

I can only put it down to a strange combo of a few AIG BGL files not being fully compatible with the changes LM made to 5.4.

It's so nice to be able to fly on a great computer and not have any problems. It took a while and much gnashing of teeth but nirvana has finally arrived. :smile:

  • Like 3
  • Upvote 1

Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Great news Ray!!! Are you on 5.4 or 5.3 HF3? And the FSLabs Concorde? Does it Run smoothly?

Edited by jcomm

Main Simulation Rig:

Ryzen 5600x, 32GB RAM, Nvidia RTX 3060 Ti, 1 TB & 500 GB M.2 nvme drives, Win11.

Preferred Simulator: X-Plane (and seriously considering AEROFLY FS 4 too)

Preferred Airbus simulation platform: P3dv5 + FSLabs Airbus family

I also use MSFS 2020... Cute, and superb overall functionality, although "flying" feels rather "plastic" ...

Share this post


Link to post
30 minutes ago, jcomm said:

Great news Ray!!! Are you on 5.4 or 5.3 HF3? And the FSLabs Concorde? Does it Run smoothly?

It’s 5.3 HF2. The problems started with 5.4 but I see nothing compelling in the release notes for that to make it worthwhile.

Believe it or not I can still get Concorde to bring my frame rates below 30 at airports like Heathrow. But without Ai it would probably be okay. 100+Ai takes its toll.

But my system definitely runs hotter with Concorde so those wanting higher fps better have good cooling. Concorde performance is fine with those caveats.

  • Like 1

Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
2 minutes ago, Ray Proudfoot said:

It’s 5.3 HF2. The problems started with 5.4 but I see nothing compelling in the release notes for that to make it worthwhile.

Believe it or not I can still get Concorde to bring my frame rates below 30 at airports like Heathrow. But without Ai it would probably be okay. 100+Ai takes its toll.

But my system definitely runs hotter with Concorde so those wanting higher fps better have good cooling. Concorde performance is fine with those caveats.

I've noticed better overall performance improvement going from P3Dv5.3 to v5.4.  The sim seems to run more smooth than before and my frame rates seem slightly higher.  They did note some optimization improvements in the log that I read.  But if your going to lose your Concorde over it, you're probably better sticking with what you have.

Share this post


Link to post

@Kalnon, I limit fps to 30 using a 30Hz monitor with VSync enabled. That means because I’m not trying to get the maximum possible fps I’m unlikely to see any performance improvement.

But stability is my number one priority and 5.3HF2 has given me that. I tweaked the cfg to move the MainThread to core 6 rather than 0. That was following LM advice on the subject.

I wouldn’t lose Concorde moving to 5.4 but it would mean the freezes / lockups returning.

  • Like 2

Ray (Cheshire, England).
System: P3D v5.3HF2, Intel i9-13900K, MSI 4090 GAMING X TRIO 24G, Crucial T700 4Tb M.2 SSD, Asus ROG Maximus Z790 Hero, 32Gb Corsair Vengeance DDR5 6000Mhz RAM, Win 11 Pro 64-bit, BenQ PD3200U 32” UHD monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...