Archived

This topic is now archived and is closed to further replies.

AdvancedFollower

Crackling sound

Recommended Posts

I've been having this weird issue with FSX and sound for as long as I can remember, but never really bothered before because FSX ran like sh*t on my previous systems anyway. Now that it finally runs at flyable framerates, it's starting to bother me.Basically the sound will crackle and pop sometimes.. it's like the sound is cutting out for a few ms at a time, and it does this several times a second.-I first blamed my soundcard, the M-Audio Delta, which is actually a pro audio card and not a gaming card. I removed it, uninstalled the drivers and activated onboard sound, but it has exactly the same problem.-It's not related to a low framerate. If anything, it gets worse at a higher framerate.-It seems to get worse over forests for some reason. As soon as there are a lot of trees on-screen, the stuttering sound gets worse. It doesn't matter what I've set the framerate lock to. Over water or even cities (where the framerate is much lower than over forests), the crackling is not nearly as bad or even non-existent. I guess I could just reduce the tree density, but I shouldn't have to do that because my system can clearly handle that number of trees - the framerate is very good over forests.-This *only* happens in FSX. X-Plane. Fallout3, Oblivion, Bioshock, GTA IV, Mass Effect, X3 and pretty much every game I own and play works fine whether I'm using onboard sound or the Delta card. Audio apps like Reason and Ableton Live also work without problems or sound quality issues.-From my experience with audio apps, I'd say increasing the audio buffer length that FSX uses might solve the problem.. unfortunately I've not found a way to do this from within FSX and no global settings seem to have any effect.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I'm not familiar with your sound card, but you might try checking the audio card output sample rate and speaker playback sample rate. I think you probably already checked that, but thought I'd suggest it anyway. Vista really stinks at audio adding delays at its own whim.

Share this post


Link to post
Share on other sites

I've been dealing with the same issue. The denser the forrest the worse it is. The problem got worse when I upgraded from a 8800GTS to a GTX 260. I can get rid of the problem by cutting back on AutoGen but why would I want to do that. Tried moving sound card...no joy, tried changing memory speeds and settings...no joy, new drivers...nope, nothing seems to make a differnce. Vista /64Q9450 @ 3.4Asus P5E4 gigs PC8500 /ADATA @ 1020X-Fi FatalityEVGA GTX260

Share this post


Link to post
Share on other sites

That's really strange..why would forests affect the sound but not busy airports and complex city scenery? Also your system is completely different from mine... Intel instead of AMD, Nvidia instead of ATI and a different soundcard. Both of us are running Vista x64 and quad-core CPUs, though.It seems to come in bursts..the sound might be acceptable for a minute, then suddenly the crackling becomes unbearable, then it gets better.. It seems to be related to how busy the scenery engine is maybe. I've tried changing both fiber fraction and bandwidth mult without effect. Tried both very high and very low numbers.I've triple-checked all audio settings. Nothing I can think of appears to be wrong.

Share this post


Link to post
Share on other sites
Doesn't seem to be an issue using DX10 however!
I've posted about this same issue in the hardware forums and on Simforums. The reason you are getting the sound crackling is high DPC Latency. I also noted that this behavior did not occur under DX10. I'm beginning to see a theme with people that are experiencing this phenomenon that being an ASUS motherboard and Vista X64. What I have found to resolve the issue under DX9 in my particular case is to use the Bufferpool tweak with the poolsize set to 512MB . Doing this the DPC Latency always remains acceptable. I have tried every poolsize and I always have High DPC Latency at any poolsize below 512MB. I'm not sure if there is a cure for video cards with less than 1GB of memory.Anyhow, here is a link to the tool to check your DPC Latency. http://www.thesycon.de/deu/latency_check.shtmlMake sure you are checking the Latency with FSX running. You will notice Latency is high under DX9 and very low under DX10. You will also notice that the amount of autogen will directly effect the DPC Latency under DX9. I'm glad I found a workable solution because the graphic quality of DX10 is horrid.

Share this post


Link to post
Share on other sites

Hi Jimmi and everyone.Try to change the Sound settings / Options in MSFS, from whatever it is now to another / lesser value setting. You can also try the same thing in DxDiag Sound acceleration and see if it helps. TV

Share this post


Link to post
Share on other sites

Tried changing the Buffer Pools but it didn't help. Lowering the amount of TREES in FSX.cfg helped but the issue is still there. Is there a replacement tree texture that might fix the problem? Avcomware, there is no option for adjusting sound acceleration in Vista, but thanks anyway.

Share this post


Link to post
Share on other sites

I stand corrected...I left out a 0 in the Buffer Pools. I corrected it and that fixed the problem. TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=1500 line has been deleted in cfg and all is good. You the man, Sarge. Thank You.

Share this post


Link to post
Share on other sites

I know how you feel JimmiG. I had a new system build in April consisting of the stuff in my sig. At first I had no sound problem with the crackling and popping, but in Oct I did a mild overclock and started noticing the popping and crackling. The thing that is funny on my system is that I get great performance, no blurries, run most sliders maxed out, but I still get some popping/crackling in certain areas. Mostly this occures in very dense hubs and with the Level D 767 and RealAir SF260. Sometimes with default planes too. I thought it had to do with my overclock so I reset everything back to the stock settings but it still persisted. I have checked with NickN, people in other forums, etc., but still no solution. It wasn't until recently that I did more google searching that I found some posts mentioning that a lot of people are having HD sound issues after upgrading to Windows SP3. It was then that I realized that it was around the same time that I did my overclock that I had also upgraded to SP3. I have not fixed it yet, but I have been reading some links that concern Win XP SP3 and the HD audio problems. If I try something that fixes it I will post back.Edit: I started this reply before any others and didn't realize that you were on Vista so the stuff I posted probably is valid. Sorry

Share this post


Link to post
Share on other sites

I had the same issue. What fixed it for me was to go into the DXDIAG and change the hardware sound acceleration to full acceleration. It worked for me maybe it will help you.

Share this post


Link to post
Share on other sites

It is an old Flight Simulator problem. I noticed it with FS 2002. Turning down hardware acceleration did help. There were then many posts about this solution on the Avsim forum. With FSX I was surprised to have the problem back but the solutions of 2003 did not help. Like in 2002 it only occured with certain aircraft, so I stopped flying the small Cessna. Another sound card did not help. Because in the mean time Creative had come up with a new driver I tried the old sound card again and fortunately had normal sound back again. On my new Vista computer I was lucky enough not to have it back. It is on my wishlist for FS 11 that it does not have crackling sound anymore.

Share this post


Link to post
Share on other sites

Actually I'm getting it in DX10 mode as well. Maybe switching to DX10 as a solution only works on Nvidia cards?Going to try the BufferPools tweak...however 512MB is a very large number. Most tweak guides I've seen recommend not setting this to more than 10-15MB. But it's worth a try I guess.

Share this post


Link to post
Share on other sites
Actually I'm getting it in DX10 mode as well. Maybe switching to DX10 as a solution only works on Nvidia cards?Going to try the BufferPools tweak...however 512MB is a very large number. Most tweak guides I've seen recommend not setting this to more than 10-15MB. But it's worth a try I guess.
If your having crackling in DX10 as well, you have other issues. Visit the website I listed above, read the methodolgy for tracking down the hardware or driver that is causing the high latency, use the DPC Latency checker tool and do a little troubleshooting. I need NO bufferpool tweak to run under DX10. It is only needed for DX9. Also as I stated above, setting the poolsize to 512MB on a video card with less than 1GB of memory may cause one to have other issues with FSX. I have not tried the tweak with video cards that have less than 1GB of memory.

Share this post


Link to post
Share on other sites
I've been flying all morning and haven't noticed any issues with it set to 512....and no crackling/popping :(
Do you have it set as 512000000? What VC do you have? I tried setting mine to 512000000 and when I do all the aircraft are all messed up looking. My card has 896 mb.

Share this post


Link to post
Share on other sites
Do you have it set as 512000000? What VC do you have? I tried setting mine to 512000000 and when I do all the aircraft are all messed up looking. My card has 896 mb.
Yes, and I have the same video card as you.

Share this post


Link to post
Share on other sites
jwenahm,Just curious are you using Vista x64 as well??
I am using XP 32bit with the USERVA switch.

Share this post


Link to post
Share on other sites
If your having crackling in DX10 as well, you have other issues.
It's easy to just say something is wrong with the system, but out of the 20 or so games I've played recently, plus about five pro audio applications I use, FSX is the only one to exhibit these problems at all. If 25 apps works perfectly fine and one doesn't, doesn't it make more sense to blame the app that doesn't work as expected, rather than the system itself?

Share this post


Link to post
Share on other sites
It's easy to just say something is wrong with the system, but out of the 20 or so games I've played recently, plus about five pro audio applications I use, FSX is the only one to exhibit these problems at all. If 25 apps works perfectly fine and one doesn't, doesn't it make more sense to blame the app that doesn't work as expected, rather than the system itself?
JimmiG,I apologize for not phrasing that correctly, I should have said "may have other issues". Pro Audio Applications are not going to saturate the PCI-E bus like FSX does so I would not expect that one would see this issue with such a program (however I guess that it could be possible depending on how many channels are simultaneously being procesed). It can also be a driver or piece of hardware not playing well with FSX. If FSX was purely the one at fault everyone and their brother would be experiencing this sound issue but that is not the case. So that would tend to make it a system issue wether it be motherboard chipset, bios, driver etc...

Share this post


Link to post
Share on other sites
I am using XP 32bit with the USERVA switch.
jwenham,XP 32bit manages memory in a completely different manner than Vista x64. That being said, I am not suprised that the "tweak" did not work in your case.

Share this post


Link to post
Share on other sites
If FSX was purely the one at fault everyone and their brother would be experiencing this sound issue but that is not the case
A number of users *are* experiencing this problem to some degree with FSX however, and with FSX only. So this suggests that even if sound isn't plain "broken" in FSX, the sim itself is "problematic" with regards to sound. More so than any other existing game or sim.I still haven't found a solution. The DPC Latency Checker does a great job of telling me what I already know: Sound doesn't work as it should in FSX. It stays in the green always at the desktop and when running other games, but the bars shoot into the red like a rocket as soon as I start a flight with FSX. All the drivers are up to date etc., so there's nothing more I can do at the "user end" short of decompiling the drivers and try to improve them myself....which I can't.What FSX does differently from other games is the way it loads scenery. Oblivion and Fallout3 also feature large-scale scenery, but the scenery is divided into "zones". As soon as you cross the border into a new zone, the scenery is shifted. Even X-Plane loads scenery in this way by periodically "shifting" the scenery at specific points or intervals. I imagine some systems might experience crackling sound during these "shifts", but not otherwise. On my system, sound never breaks up in those games.FSX on the other hand continuously streams new scenery from the disk and rebuilds near, mid and far distant scenery all the time as you fly. Maybe this constant thrashing of the harddrive and textures being sent across the PCI-E bus is too much for some PCs that handle all other games and apps just fine. That doesn't explain why the problem gets worse over forests and nearly disappears over cities however. :(

Share this post


Link to post
Share on other sites
jwenham,XP 32bit manages memory in a completely different manner than Vista x64. That being said, I am not suprised that the "tweak" did not work in your case.
It was resolved.. I helped him tune USERVA to the correct level for his system (2560 does not work for everyone) and he can use bufferpools now
A number of users *are* experiencing this problem to some degree with FSX however, and with FSX only. So this suggests that even if sound isn't plain "broken" in FSX, the sim itself is "problematic" with regards to sound. More so than any other existing game or sim.I still haven't found a solution. The DPC Latency Checker does a great job of telling me what I already know: Sound doesn't work as it should in FSX. It stays in the green always at the desktop and when running other games, but the bars shoot into the red like a rocket as soon as I start a flight with FSX. All the drivers are up to date etc., so there's nothing more I can do at the "user end" short of decompiling the drivers and try to improve them myself....which I can't.What FSX does differently from other games is the way it loads scenery. Oblivion and Fallout3 also feature large-scale scenery, but the scenery is divided into "zones". As soon as you cross the border into a new zone, the scenery is shifted. Even X-Plane loads scenery in this way by periodically "shifting" the scenery at specific points or intervals. I imagine some systems might experience crackling sound during these "shifts", but not otherwise. On my system, sound never breaks up in those games.FSX on the other hand continuously streams new scenery from the disk and rebuilds near, mid and far distant scenery all the time as you fly. Maybe this constant thrashing of the harddrive and textures being sent across the PCI-E bus is too much for some PCs that handle all other games and apps just fine. That doesn't explain why the problem gets worse over forests and nearly disappears over cities however. :(
It nearly saturates the reserved PCIe buss.. well known about trees and noted by Phil Taylorhttp://blogs.msdn.com/ptaylor/archive/2008...e-envelope.aspxA fix can be drivers and how they may change how ACPI works with resources on the motherboard between sound and video. Gigabyte issued a BIOS fix and later changed the board design however that was not specifc to FSX as it seems to be an issue noted with newer motherboards and is hit and miss in sound problems. To date I have never had a board which displayed the issue so I have not had anything to work with here in checking the problem out

Share this post


Link to post
Share on other sites

Sorry to chime in late to this thread guys but I just resolved this exact issue with my fresh FSX installation. Thankfully I had a copy of my previous FSX installation .cfg to compare which never had a problem.My fsx.cfg WITH sound crackling[sOUND]AmbientUIMusicVolume=-6.000000SOUND=1SOUND_QUALITY=2SOUND_LOD=0UISound=1AmbientUI=0PrimaryDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}VoiceDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}SOUND_FADER1=0.500000SOUND_FADER2=0.500000SOUND_FADER3=0.500000SOUND_FADER4=0.500000AmbientUIMusic=FSX01My FIXED fsx.cfg WITHOUT sound crackling[sOUND]AmbientUIMusicVolume=-6.000000SOUND=1SOUND_QUALITY=2SOUND_LOD=0UISound=1AmbientUI=0PrimaryDevice={00000000-0000-0000-0000-000000000000}VoiceDevice={00000000-0000-0000-0000-000000000000}So I just replaced this part of my .cfg file and it worked!

Share this post


Link to post
Share on other sites