Jump to content

Sign in to follow this  
jd

713 and unregistered dll's

Recommended Posts

Glad you sorted out, Jack

I'm using it with multicrew experience and enjoying it so much more

 

Happy flying

 

John


John Cramer

Share this post


Link to post
Share on other sites

I would also like to thank the Ronzie/737-800 team for their help, step by step, and problem solved.

For ronzie's link download the. dll zip file and not the .dll fixer.

Funny, not a peep from the developers, hello anyone home?

These 2 posts should be at the top of the thread.

 

Pete.

Share this post


Link to post
Share on other sites

The developer coder jd monitors the regular forum topics. There is also a volunteer team like myself that also functions as beta testers and support when needed.

 

At the time RC43 was developed Microsoft included all of the .dlls and .ocx files in Windows releases up to XP.  Any security problems with these modules would be taken care of by Windows updates. If RC included this, then it would not be updated with service packs.

 

These .dlls are not exclusive to RC but also some apps developed in other Microsoft software languages.

Share this post


Link to post
Share on other sites

I am also getting the 713 error each time I try to load a flight plan. I just got RC4 this evening. I have Windows 7 and I tried the steps but I guess the file RC4 needs is not on my computer. Is there an updated place where I can DL it from or something?

Share this post


Link to post
Share on other sites

I DL'd the file the program said it needed and I put it in the right windows folder. RC4 still won't work and I get the same error. What else can I try? Is there another part to getting this to work besides just putting the file in the Windows system file or did I not even put it in the right place?

Share this post


Link to post
Share on other sites

You know, the folks that "finally got it fixed, case closed" or "finally managed to fix it" could perform a service by sharing exactly how they did it. What I take away from this section is, yeah, there's a problem, and download this, and do that, and a lot of the time it doesn't work, but sometimes people can get it to work. 

 

???


gdHG4k.jpg PC: Falcon i9 10900K @ 5.3GHz | 32GB DDR4 3200 | 10GB RTX 3080 | 32” Asus TUF VG32VQ Curved Monitor | Samsung 2TB SSD HD | Win 10 Pro 64 - Flight Sim P3Dv5.1 HF1 & a little MSFS. Peace. Love. Airplanes.

Share this post


Link to post
Share on other sites

I got it to work. Here are the things I did wrong. In a nutshell, if you follow the directions EXACTLY, it should work. I got the missing dll as advised: MSSTDFMT.DLL and put it in SysWOW64 (since I have a 64-bit Windows 7 OS).

 

I didn't know how to use the command prompt properly. I did use it as administrator, but found I needed to put in the whole directory to get to SysWOW64 , i.e. cd\windows\syswow64 

 

My biggest mistake was in not putting in regsvr32 before MSSTDFMT.DLL after everything. I got wrapped up in the other stuff, and had left the FAQ, and just forgot that step.

 

Hopefully, some frustrated person might recognize the same error. Now RCV4 works fine. I'm glad to have more realistic flights now.

  • Upvote 1

gdHG4k.jpg PC: Falcon i9 10900K @ 5.3GHz | 32GB DDR4 3200 | 10GB RTX 3080 | 32” Asus TUF VG32VQ Curved Monitor | Samsung 2TB SSD HD | Win 10 Pro 64 - Flight Sim P3Dv5.1 HF1 & a little MSFS. Peace. Love. Airplanes.

Share this post


Link to post
Share on other sites

Purchased RC 4.3 this morning and keen to have a play but am receiving the 713 error message. Like most, I am running Win7 64 bit. I thought I was on my way when I finally received the message

 

"DllUnregisterServer in msstdfmt.dll succeeded."

 

Did a re-boot, cranked up Radar Contact, put in a plan and BANG.......

 

"Run-time error 713:

Class not registered. You need the following file to be installed on your machine. MSSTDFMT.DLL"

 

To say I'm frustrated with this would be an understatement. Any assistance greatly appreciated


P3Dv4 - PMDG 747 QOTS II, PMDG 737 NGX, Reboot, MT 6, MJC Q400, ORBX. FlyTampa, FS2Crew voice, Aivlasoft EFB + FSX Steam

 

 

Share this post


Link to post
Share on other sites

Derian's instructions one page back worked for me. I dowloaded the dll from here.

 

 

 

What you wanna do is: Before anything, go to the site that ronzie posted and download the .dll and place it in your sys32 and syswow64 folders. 1. Press Start on the bottom left of your screen2. Type in cmd in the search bar, wait for it to pop up, right click it, and select run as admin.3. Now, type Cd \windows\syswow64 and press the enter key on your keyboard.4. Now, the prompt will change to C:\WINDOWS/syswow64>5. Now, RIGHT after the > with no spaces, type regsvr32 /u msstdfmt.dll and press the enter key on your keyboard. (IGNORE WHAT IT SAYS ABOUT ENTER MISSING NAME HERE).6. Now, after you've pressed enter, you'll get a little pop-up in a blue box saying that unregister was successful. Now you want to register it so you type regsvr32 msstdfmt.dll and press the enter key on your keyboard. (IGNORE WHAT IT SAYS ABOUT ENTER MISSING NAME HERE).7. Now, you should get a pop-up in a blue box saying that the register was successful. Enjoy! 

 

That should work for you as well  :smile:

  • Like 1
  • Upvote 1

KInd regards

Jean-Paul

I7 8700K / Fractal Design Celsius S24 watercooling / ASRock Z370 Extreme4 motherboard / Corsair 32GB 3200mhz DDR4 / INNO3D iChiLL GeForce GTX 1080 Ti X3 / Samsung SSD 960 EVO M.2 PCIe NVMe 500GB / Seasonic-SSR-850FX power supply / Fractal Design Define R5 Black case / AOC Q3279VWF 32″ 2560x1440 monitor / Benq GL2450 24″ 1920x1080 monitor / Track-IR 4

Share this post


Link to post
Share on other sites

Thanks Jean-Paul, that did the trick. I missed the last string of text (I only got as far the "/u" string - old eyes!! & missed the next step).

 

Cheers

 

Steve


P3Dv4 - PMDG 747 QOTS II, PMDG 737 NGX, Reboot, MT 6, MJC Q400, ORBX. FlyTampa, FS2Crew voice, Aivlasoft EFB + FSX Steam

 

 

Share this post


Link to post
Share on other sites

I was assisting a RC4 user yesterday and we only managed to get the dll registered once I'd followed Tim's post 4 up from this one. Thank you for that Tim.


Ray (Cheshire, England).
System: P3D v5.2 & v3.4, Intel i7-8086K o/c to 5.2Ghz, Nvidia GTX 1080 Ti 11Gb, Samsung 970 EVO M.2 SSD, 1Tb Samsung 860 EVO SSD, Asus Prime Z370-A mobo, 32Gb G.Skill DDR4 3000Mhz RAM, Win 10 Pro 64-bit, BenQ PD3200U 32” monitor, Fulcrum One yoke.
Cheadle Hulme Weather

Share this post


Link to post
Share on other sites

:mad:


you are all lucky I paid for this 3 days ago and they never sent me the activation key!! emailed the numerous times with still no response!!

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,670.00 of $25,000.00 Donate Now
×
×
  • Create New...