Archived

This topic is now archived and is closed to further replies.

sonaljay7

Improving FSX smoothness and getting rid of stutters

Recommended Posts

Hi guys, so this is like my 3rd post on this topic but any help you guys can give would be really apreciated. I have quite a high end system, specs below, I have fsx sp2 installed but the mian problem I seem to be having is a lack of smoothness. FSX is not just smooth, it stutters over areas of autogen, and has a mechanical feel to it. Any advice on how to solve my problems? The only fsx.cfg tweaks I use are from the fsx.cfg tweaking website.Specs:Intel Core i5 2500k (default speed)Asus P8-P67 M Mobo4*2GB Kingston 1333mhz RAM500 GB Samsung SATA HDD620W Seasonic PSUEVGA GTX 570 SC Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Try following this guide first to get a good base install: http://www.simforums.com/forums/setting-up-fsx-and-how-to-tune-it_topic29041.htmlAfter doing that, test FSX and see how it runs.If further adjustment is needed try this tool: http://www.venetubo.com/fsx.htmlThe combination of both Nicks setup guide and the FSX cfg tool that ******* has put together in the last link have proven effective for most FSX users.

Share this post


Link to post
Share on other sites

Try limiting frames per second in FSX to a low value, eg 20 fps. If that gets rid of the stutters, increase fps until you find the highest setting that will run smoothly (this will vary depending on what addon scenery you have loaded).Some users get better result by setting fps in FSX to unlimited and using an external FPS limiter.

Share this post


Link to post
Share on other sites

You'll not get a smooth FSX at 3.3 gig. Push it up to 4 or 4.2.

Share this post


Link to post
Share on other sites

Add a BP=30000 to your cfg. Limit fps to 30 in FSX or use external limiter.Hope it helps.Jose

Share this post


Link to post
Share on other sites
Add a BP=30000 to your cfg. Limit fps to 30 in FSX or use external limiter.Hope it helps.Jose
Jose, you mean 3000, correct? :(

Share this post


Link to post
Share on other sites

Could this be an issue: "500 GB Samsung SATA HDD" How is FSX installed, do you defrag it, what kind of Samsung, slow, fast..?

Share this post


Link to post
Share on other sites
Jose, you mean 3000, correct? :(
Yes sir. Thanks.

Share this post


Link to post
Share on other sites

Try autogen at dense with the 2500k near stock speeds. I have a similar system and when I run stock dense autogen is about the most I can hold at 30 fps without stutters.Also don't try the tweaked cfg just yet. All you need is the highmemfix=1 and just use the sliders to adjust things. Eventually you'll want to look into an overclock but don't start until things are running decent.

Share this post


Link to post
Share on other sites
Also don't try the tweaked cfg just yet. All you need is the highmemfix=1 and just use the sliders to adjust things. Eventually you'll want to look into an overclock but don't start until things are running decent.
I guess I wasted my time. :(

Share this post


Link to post
Share on other sites

Try thishttp://forum.avsim.net/topic/333332-fsx-tips-and-tricks-by-tom-rogers/Tom

Share this post


Link to post
Share on other sites
You'll not get a smooth FSX at 3.3 gig. Push it up to 4 or 4.2.
Or even better, 4.8 - 5.0 GHz!Big%20Grin.gif

Share this post


Link to post
Share on other sites

I tried something the other night and so far the results are amazing. I dont know yet if there are any side effects. I changed the pre rendered frame in the nvidia cp to 7. It's so smooth and no cfg tweaks except highmemfix and am 14.

Share this post


Link to post
Share on other sites
I tried something the other night and so far the results are amazing. I dont know yet if there are any side effects. I changed the pre rendered frame in the nvidia cp to 7. It's so smooth and no cfg tweaks except highmemfix and am 14.
Thats strange as a setting of 7 would most likely induse more stutters. I fly with a setting of 1 and use the Affinity mask 14 with a bufferpool=0 in my config. The thing with tweeks is that just because it works on one system doesnt mean it will on another with the same result. The setting of 1 in the Pre-Render as I understand will make the frames your CPU produce be more in line with what your video card is drawing but is one of those YMMV tweeks.Jim

Share this post


Link to post
Share on other sites

I really dont understand it myself. I found a guide somewhere that talked about the pre render settings. It said the higher the number, you would get smoother performance but at a cost of lower framrates. I am still getting 25 to 30 in dense areas sometimes a quick drop to 18 but it sure is smooth. I am still playing with it. I would love to know if others are getting similar results.I am not using any bp in cfg either.

Thats strange as a setting of 7 would most likely induse more stutters. I fly with a setting of 1 and use the Affinity mask 14 with a bufferpool=0 in my config. The thing with tweeks is that just because it works on one system doesnt mean it will on another with the same result. The setting of 1 in the Pre-Render as I understand will make the frames your CPU produce be more in line with what your video card is drawing but is one of those YMMV tweeks.Jim

Share this post


Link to post
Share on other sites