Jump to content

Archived

This topic is now archived and is closed to further replies.

Cfoley

FSX Do not have permission

Recommended Posts

I have been having an airport add on issue with FSX.  I purchased Tropicalsim TIST airport and it won't install because I "Do not have permission" to add to my computer (which never happened before).  The airport is in my FSX scenery file, but does not show up when I select it but instead shows the FSX default scenery instead.  I contacted Tropicalsim thinking it could be their product. They replied and gave me a link to AVSIM regarding this exact issue sameone else had.  The solution appeared to have worked for that individual.  It was to install "Take Ownership" which I did but still does not let me add on to FSX.  I turned off my User Account Settings, rebooted my computer, but still to no avail.  This problem recently started and have no clue what activated the "Do not have permission" setting.  I have Windows 7 and have been able to add on airports before without any problems whatsoever. I have seen the posts about adding airports but that is without the permission problem.   Is there anything I missed?  As I mentioned before, this problem just started.  I purchased other airport add-ons this month without any installation problems.  I cannot figure out why it is now happening.

Share this post


Link to post
Share on other sites

I followed the instructions when I downloaded the add on and it stated it installed successfully, but I still get that "Do not have permission" screen.  There were two airports I purchased from two different software companies.  Even though it is in the scenery library in FSX,  the default airports are there.  

Share this post


Link to post
Share on other sites

Google "turn off UAC windows 7" Should solve your problem. Cpt out.

Share this post


Link to post
Share on other sites

I did try that, but still does not work.  Am I to reboot after turning off UAC?    I always had UAC turned on at the medium without any installation issues (except for adding aircraft liveries from AVISM for which I still cannot do).  But for purchases of add-on airports, they always installed without problems, until now whether UAC is turned on or not.  It must be something else causing it.

Share this post


Link to post
Share on other sites

Even with UAC off some installs require you to right click and select "Run as Admin', did you try that?

Share this post


Link to post
Share on other sites

By any chance does your FSX folder or FSX install drive have a padlock symbol on it? Sounds like an overall permissions issue.

Share this post


Link to post
Share on other sites

No padlock


I am puzzled why suddenly I don't have permission to add to FSX.  I have had the same computer with Windows 7 now for over 2 years and have been using FSX for about the same amount of time, never had troubles installing add ons (except for AVISM liveries) and then one day as of Sunday,  I no longer have permission....just like that! 

Share this post


Link to post
Share on other sites

Log in like administrator, allways use right click and "run as administrator", disable UAC(set at minimum), exclude FSX folder from Antivirus scan and give full permision to FSX folder or entire HDD/partition.

 

Just check your settings.

 

Also, Installing FSX in default location on C is not a good idea becouse of some default system protections

Share this post


Link to post
Share on other sites

Did all that as I posted earlier. Turned off UAC but FSX does not have an "Run as Administrator" option, at least not on my system.  When I purchase add-ons I do have Run as Administrator options, but when I click FSX, no option on the column bar.  This is a sudden problem.  Not like I just bought a new computer with WIndows 7 and having install issues.  I have had FSX now for 2 years without this problem.

Share this post


Link to post
Share on other sites

The FSX folder is NOT the folder that is likely the problem. You need to check the permissions of the location of the scenery configuration file, which should be C:\ProgramData\Microsoft\FSX Note that 'ProgramData' is a hidden directory by default, so you'll either need to type in the path, or turn on the display of hidden files and folders in Explorer.

 

Edit:

 

Also, check you have any free space on drive C:, running out of it can cause permission errors too, although I doubt this is the cause as running out of free space on C: normally presents more... confusing.. issues with FSX (such as it starting as if you had never used it before, and resetting all settings)

Share this post


Link to post
Share on other sites

This is a permission/sharing problem.  You need to go to the C:\Program Data\Microsoft\FSX folder and right click on FSX and select share with all users.  You might also do that to the Main FSX folder too making sure you apply to all sub-folders.  All users on your computer are not allowed access to everything and you need to make sure everyone is allowed access.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Agree that the problem is probably permissions on C:\ProgramData\Microsoft\FSX.  The way I have mine set up is when I open the folder properties for this folder and go to the "security" tab, in the upper "users" box I have an entry for "Everyone" and when I highlight it, the lower "permissions" box has "full control" checked in the allow column.  If you don't have an entry for "Everyone" you will have to use the "edit" then "add" button to add it.

 

I suppose setting permissions for "everyone" is overkill, but in my environment I don't see any problem with this. 

 

scott s.

.

Share this post


Link to post
Share on other sites

Jim,

THANK YOU!   I did exactly what you posted and it worked!   Simple and straight to the point!  I cannot figure out what happened to begin with since I did not change anything in FSX or Windows 7. It is like Windows 7 has a mind of its own and one day decided to deny permission.   If now I can only figure out how to add AVSIM airline liveries.  That is one issue I have not been able resolve.  But what is important I can add airports again.  Thanks again!

 

Cray

Share this post


Link to post
Share on other sites

Glad it worked for you Cray.  Windows seems to be getting more and more complicated.  Sometimes hard to stay up on all the changes.  As far as adding aircraft liveries, here's an excellent tutorial (I think one of the best) - http://www.flightsim.com/vbfs/content.php?2064-How-ToInstall-FSX-Aircraft-Liveries

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Installing FSX on a seperate drive, or folder, will solve most UAC issues.

 

Check your User Account logon. Under the name you should see "Administrator". If not, you won't get permission for some actions.

 

Dave

Share this post


Link to post
Share on other sites

×
×
  • Create New...