Archived

This topic is now archived and is closed to further replies.

DimhwyGweithredol

Auto Throttle Disconnects During Takeoff Roll - New Behavior

Recommended Posts

Hola PMDG Afficiandos!

I have strange problem that just began two weeks ago - I have Saitek X52 joystick and throttle, and the NGX A/T is 'disconnecting' after 3-5 seconds into my takeoff roll. And  it just started doing this a couple of weeks ago - for 1 year+ I've had the NGX it had not been problem.

 

I searched and serched the forums, and I found a few posts with similar issue. But, many times the poster had a very complicated joystick/throttle/yoke setup (2 throttles, etc.), so I don't know if the suggested solutions would even work. I tried anyway, but they did not work for me.

 

Here is what I have tried so far:

1) reinstalling device driver for Saitek X52. No joy.

2) carefully trying ALL the different choices (permutations?) on the NGX setup pages as to AP, A/T, etc.. No joy.

3) read tutorial again and flew it EXACTLY as written - same issue crops up, no joy.

4) rebuilt fsx.cfg from scratch. No joy.

 

Now, one solution often mentioned on these threads is to "calibrate joystick/throttle from WITHIN FSX." Ok. I go to that setup page within FSX, click on Controls, hit 'calibrate'...and it takes me immediately to the Saitek driver calibrate box. So I don't really know what I am supposed to do on the FSX Control/Joystick/Calibrate page. Many settings on that page I do not understand, such as "Null zones", "Axes", etc. But again, for over a year, I've had no issue with the throttle and A/T behavior, so I've never had to mess with that before.

 

Do any of you kind amigis have a solution to this maddening problem? It's been a couple of weeks and it is driving me loco!

 

Gracias!

Jose Enrique Gaviota

 

My system: OC'd i7-920 (3.8 Ghz), 6GB Ram, GeForce GTX250 1MB video card, Win 7 64 Ultimate.

 

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

If you have a registered version of FSUIPC, I would recommend calibrating your axis through FSUIPC.

The only other thing I can think of, is there's a setting to turn off disconnecting the AP and AT through movement of the axis. But I believe that's what you were trying to achieve with your #2 option above.

 

If you don't understand null zones and axes, you might need to play with your software a bit until you get the big picture because increasing your null zones might help.

If you don't understand axes, I'm not sure you'll be successful with FSUIPC calibration.

 

Run the NGX with no throttle and see if it happens so you can at least isolate it to your joystick.

Share this post


Link to post
Share on other sites

You may have inadvertantly set another keystroke or setting that turns the AT off.  Try using the VC and NGX throttles and without touching anything else see if the same thing happens.  What is your airspeed set at?

 

Rob

Share this post


Link to post
Share on other sites

Out of interest...are you pressing the TO/GA switch? From my experience arming the A/T before takeoff, and pressing the TO/GA switch to start take-off-roll, the A/T will automatically turn off until you are climbing, then it will turn back on again...

Share this post


Link to post
Share on other sites

Had this problem for a while too. Not sure how I fixed it but it works ok now. I have my AT mapped to a joystick button. I did do a clabration recently and it's fixed now. Not sure if that was the issue. Haven't done anything else.

Share this post


Link to post
Share on other sites

I had this problem once, it went away randomly though. Are you accidentally hitting 3 on the keypad to activate lower thrust which deactivates the throttle? That is if you are using keyboard rudder.

Share this post


Link to post
Share on other sites

One thing I also did recently was a complete Windows and FSX reinstall. That might have done the trick. No one likes to hear that though. :mellow: 

Share this post


Link to post
Share on other sites

Check your settings in the FMC - sounds like you have your hardware throttle set to override ALWAYS, or even only in ARM/etc.  Change it to never and it'll probably fix the issue.

Share this post


Link to post
Share on other sites

Great ideas folks and much appreciated. I'd hate to think its a random thing too, but as I had just started getting this behavior after years of no problems, it could be.

 

I'll start from the top:

Bob mentioned FSUIPC to me, and I have seen that as a solution on a few posts. Would the free version have the same capabiltites I would need as the one that costs 28Euro?

 

Rob then mentioined an interesting idea (and to be fair, Bob mentioned it also!) and that is to take the joystick and throttle out of the loop and see if the same gthing still happens. I will certainly try this and report back. Oh, and Rob - it cuts out before reaching v1, always.

 

Now Ciarán's commnet is intriguing as tha'ts what happens to me: the A/T cuts out on takeoff roll, i'll put the throttle (Saitek throttle) to the fireall to get airborne, engine overtemp all the way, and once in the air the A/T works fine all the way through autoland flare and rollout. No weird behavior from it in the air even if I move the Saitek throttle.

 

Alex, no, Im not touching anything on the keyboard except releasing the brakes.

 

Max, I did do a claibration, but I am not sure I am doing it correctly. I start out in FSX, hit the calibrate button and that opens the Saiteck driver's calibratiion page. Hasn't changed anything. Is there anything I should be changing on the FSX controller page? Those "null" things, etc.?

 

Max - yes! I can't count the re-installs I've performed over the years. I hope it doesnt come to that. Particulalry if it doesnt fix the problem.

 

Kyle - Yes, one of the first places i went, I tired every combination of settings on that page - still have the problem.

 

Let me try a few of the ideas here and get back to you.

 

Please keep the ideas flowing in the event anyone thinks of something else!

 

Muchas gracias!

Share this post


Link to post
Share on other sites

 

 


Kyle - Yes, one of the first places i went, I tired every combination of settings on that page - still have the problem.

 

Gotcha - I noticed similar recently, but it turns out that my throttles were spiking after it kicked over into ARM mode.  Since I'd just placed the hardware throttle on the wall (it's worked well enough up until now), the spike caused it to jump up to max, showing similar results as you.  Figured it was worth a shot.  For what it's worth, I use the option to show my hardware position when moving, and just manually follow where TOGA sets the throttle.  That way, even if it spikes, the difference is minor.  A/T will pick the throttle back up shortly after departing, so even if it's slightly off, it won't affect it for too long.

Share this post


Link to post
Share on other sites

Ciaran,

 

Out of interest...are you pressing the TO/GA switch? From my experience arming the A/T before takeoff, and pressing the TO/GA switch to start take-off-roll, the A/T will automatically turn off until you are climbing, then it will turn back on again...

Are you sure your A/T Switch physically moved to the OFF position?...or are you describing normal 'NG' A/T behaviour after lift–off where the A/T remains in THR HLD until 800 feet RA, the A/T annunciation then changes from 'THR HLD' to 'ARM' and reduction to climb thrust can be made by pushing the N1 switch or it occurs later upon reaching the thrust reduction altitude which was selected on the FMC CDU TAKEOFF REF page 2/2 during pre-flight, or when the airplane levels off in ALT HOLD or VNAV PTH.

 

If it is physically disconnecting (A/T Switch) then I would imagine that as others have described you have some sort of key press or button conflict.

Share this post


Link to post
Share on other sites

Ciaran,

 

 

Are you sure your A/T Switch physically moved to the OFF position?...or are you describing normal 'NG' A/T behaviour after lift–off where the A/T remains in THR HLD until 800 feet RA, the A/T annunciation then changes from 'THR HLD' to 'ARM' and reduction to climb thrust can be made by pushing the N1 switch or it occurs later upon reaching the thrust reduction altitude which was selected on the FMC CDU TAKEOFF REF page 2/2 during pre-flight, or when the airplane levels off in ALT HOLD or VNAV PTH.

 

If it is physically disconnecting (A/T Switch) then I would imagine that as others have described you have some sort of key press or button conflict.

I'm sorry, I completely mistaken the A/T switch for the VNAV button. Silly me  :rolleyes:

Share this post


Link to post
Share on other sites

I know this sounds weird but check you overhead settings.  I can't remember which switch affetcs the A/T but one does.  It happened to me once.  I presume your recall switch shows nothing when you check it prior to takeoff?

 

Rob

Share this post


Link to post
Share on other sites

Amigos,

Ah - maybe we're on to something here. What I have when I begin the takeoff roll are the following:

1) Everything programmed in the FMC, i.e., I have v1, vR, v2 speeds on the airspeed tape.

2) both FD's "armed"

3) A/T "Armed"

4) LNAV & VNAV & COMs "OFF"

I trip the brakes, bring the Saitek throttle to 70%-ish, let it stablizes a second or two and then click the TOGA spot on the glareshield and off I go! Until 3 seconds or so down the roll and the throttles back off to the physical position on the Saitek throttle (that's got to mean something).

It's a setting sopmewhere, as this behavior has only been evident the past couple of weeks.

Thought this might clear-up what my setup was.

Thanks - and I welcome (seriously) all the ideas!!

Gracias!

Share this post


Link to post
Share on other sites

Haha - nope. It means that you found that the NGX is behaving as its supposed to.

 

At around that time, the commanded AT mode is called ARM. In the real plane, the plane is essentially allowing the throttles to be manually adjusted (or closed) as necessary, while still remaining on AT. It will pick back up after taking off and take control of the throttles again. This is the real behavior.

 

In your situation, it's hitting ARM mode and - just as in the real plane - allowing you to take over fine tuning the throttles (or giving you a chance to close them if anything happens.) the difference is that in the real plane, the throttles are servo-controlled, so before dumping to ARM, the throttles are in the exact spot the AT last set them. Since your hardware does not have servos, however, it immediately drops to wherever you left it.

 

This is why there is an option in the FMC menus to allow you to tell it to ignore your hardware at any time your AT is on. I mentioned this before, and based on your reports, I do not believe you are operating in be proper mode. If you want it to behave like all other ATs you're used to, you should set it to always override your hardware (I can't remember if the setting in the menus is NEVER OVERRIDE THE AT, or ALWAYS OVERRIDE THE HARDWARE, but you essentially want it to ignore the hardware at all times while on AT.)

Share this post


Link to post
Share on other sites