Jump to content

Archived

This topic is now archived and is closed to further replies.

Alec

MAGICAL SOLUTION : How to avoid OOM in any simulator! Including P3D V2!

Recommended Posts

Step 1 : Reduce your Maximum Texture Resolution from 4096 to 1024

 

Step 2: Enjoy your OOM free simulator

 

There's not much than this really, before complaining, try this and see if you still get OOM. If you do, ONLY then you get the right to come into this forum asking for help! Running 4096 in a 32Bit simulator is like walking barefoot on the street, eventually you're going to get hurt!

Share this post


Link to post

Hello

 

There are so many 32 bits games that cope with high resolution textures without OOMs.

For me the problem is the architecture of these particulary(fsx, prepar3d) aplications relatively to memory and resources  management.

I have a stone age pc, Intel quad core 8600 OC to 3.3 ghz, GTX 470 and 4 gb of memory running under W7 64bits and never have a OOM in FSX or Prepar3d 1.4, in Prepar3d V2 i can´t say becuase i don´t have it running 100%(all my favorite addons) yet.

 

Regards.

 

Manuel Freitas

Share this post


Link to post

I had CTD error that plagued me for over a year, every few days my PC would crash.  I thought that it could have been numerous things that was causing my CTD's as I have quite a few addons, use shader mods etc.  I found and removed the KB mentioned below and I haven't had a CTD in months.  I thought that my PC had a few issues which caused CTD's, Surprisingly when I removed the KB my issue was fixed.

 

D3d11.dll CTD  Remove KB2670838. (a Windows Update).

 

 

How to remove update:

 

Open up an Elevated Command Prompt. Click on orb.png in 2nqbqes.png type CMD . Right click onCMD under Programs (1) choose mawket.jpg. On the User Access Control window click on the Yes button . Command Prompt opens up to C:\Windows\System32>_

then type 

 

wusa /uninstall /kb:2670838 and press <ENTER>

 

Source:  http://www.sevenforums.com/windows-updates-activation/294651-unable-uninstall-windows-update-kb2670838-error-0x80073701.html#post2441184

Share this post


Link to post

Heeeere we gooo

CTD threads for P3D.

I guess nothing has changed.

I will wait for v2.5.

Share this post


Link to post

Autogen is the problem. Clouds are the problem. The world Flight Simulators have to render is far greater than a Crysis 3 game, no comparison. Much more things to use your VRAM. And a game has a controlled scene, where developers know the maximum they can get to detail while being lower than the threshold for 32bits, while in FS you can't control what the end user will try to render with it's card.

 

You don't have to restrict the user of using one of other opinion,. If you're flying out of an Orbx scenery with your C172 for a 30 minutes flight, then go ahead and try 4096. If it works, good for you! If it doesn't you know exactly what you have to do to make it not happen again. The point of this topic is to let people know what they're doing that's causing this, and to have an immediate fix to this issue.

Share this post


Link to post

Its not 100% but close.  I can assure you that flying ConcordeX in FSX between EGLL and KJFK with addon scenery is very likely to end up on OOM upon landing, even with these settings.

Share this post


Link to post

Heeeere we gooo

CTD threads for P3D.

I guess nothing has changed.

I will wait for v2.5.

Haha, no doubt.  Doesn't matter how stable you think your system is your sim ends up showing you who's the boss.  Turning down settings may help as the OP wrote but what you are really doing is reducing the load on the PC and its components which is only half the battle.

Share this post


Link to post

Actually the OP is right.   I've never been one for high resolution textures. I actually feel they reduce smoothness and fluidity and I always limit textures to 1024, and (despite not having super powerful system), I never ever get OOMs.

Share this post


Link to post

My long fix is to use FUIPC to save a flight named retrosave every 5 minutes. So only one autosaved flight is in my situation folder. A restart from that as the default will load up less than when it got  CTD

 

but reducing max to 1024 may be a better idea

 

allen

Share this post


Link to post

Thanks to the OP for bringing this up, but this is certainly no revelation. LM has made it easy now to adjust items further than MS ever intended, and for good reason. In FSX I maintain TML=1024 and LOD=4.5 and looks fine and never get OOM errors.

Share this post


Link to post

Never had any OOM in more than two years (crossing the fingers) on my modest laptop with sliiders in mid-upper right end, Accusim or RealAir aircraft, flying OrbX sceneries with Opus weather on 1.5 hour average flights.

 

What I read from all the posts, is that they mostly come on long flights with PMDG or similar aircraft.

Share this post


Link to post
×
×
  • Create New...