Sign in to follow this  
OmniAtlas

Grainy textures after last Nvidia driver update

Recommended Posts

Anyone have any idea why my aircraft have a grainy type appearance? This only happened after I updated to the latest nvidia drivers.

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hi Omni,

 

Please revert back to nividia drive 332.21, all issue will resolve.

 

B/Regards...Alex Ooi

Share this post


Link to post

I'm not installing the new nvidia driver as it causes several problems, go back to the last driver and you should be ok !

Share this post


Link to post

Nope - 334 runs beautifully. Remember, if you change drivers you need to 1) rebuild your shaders and 2) reconfigure Nvidia Inspector if you use it.

 

Vic

Share this post


Link to post

Latest WHQL driver is running great here.

 

Cheers

jja

Share this post


Link to post

Nope - 334 runs beautifully. Remember, if you change drivers you need to 1) rebuild your shaders and 2) reconfigure Nvidia Inspector if you use it.

 

Vic

 

Thanks, I've rebuild the shaders but I still get grainer textures --

 

2014_2_23_16_32_58_146.jpg

 

The textures - flicker. Nvidia inspector problem? 

 

I have the following settings 

 

Antiaaliasing compatibility - (bioshock, bioshock 2) 

Antialiasing mode - override any application setting

AA setting - AA_mode_method_supervcaa_64x_4v12

AA transparency SS - 4x supersampling

 

 

This method has allowed me to have AA within P3D 2.1.

Edited by OmniAtlas

Share this post


Link to post

So is everyone having this problem as well? 

The latest driver 334.89 is pretty good here.

Spirit

.....

2) reconfigure Nvidia Inspector if you use it.

Or export before installing and import after the installation.

Spirit

Share this post


Link to post

Very strange, I have reconfigured nvidia inspector, deleted and regenerated the shaders directory...it is still grainy. 

 

Seems like it only affects aircrafts and the shdows...I tried fine tuning the shadow setting, but it is still present. 

 

I've also changed to 4x supergrid suplersampling but the grainy picture and 'shimmering' is still there. 

Share this post


Link to post

Very strange, I have reconfigured nvidia inspector, deleted and regenerated the shaders directory...it is still grainy. 

 

Seems like it only affects aircrafts and the shdows...I tried fine tuning the shadow setting, but it is still present. 

 

I've also changed to 4x supergrid suplersampling but the grainy picture and 'shimmering' is still there. 

Don't worry Omni, it's not you, it's the driver.

I have the same problem. Especially shadows in virtual cockpit are "grainy confetti" and disturb the whole Instruments when moving over them.

And yes, i did a cleanup and a clean install...

I also use 4*SGSAA activated by NI (from my experience the only way to get it) and that's what the new driver can't handle.

Maybe on some cards it can or some people simply don't use SGSAA...

If you disable it, you should get rid of the anomalies, but the instruments and readings are shimmering and pixeling without it.

I use the older driver and everything is fine. Couldn't see any usefull changes in the new driver anyway.

By the way: this setting: AA setting - AA_mode_method_supervcaa_64x_4v12

was a nice feature in fsx-DX9, but should be totally of no effect in p3d (and fsx with steve's DX10 shader fix too). You can set it back to appcontrolled or leave it - it doesn't matter. In DX10/11 it's not possible to force normal AA by the driver, it MUST be done by the app (in this case in p3d AA=on)..... nvidia, have no experience with amd.

Edited by tiberiusrr

Share this post


Link to post

Thanks will give it a go.

 

As for the settings I just followed the thread here On How to get aa working with p3d.

Share this post


Link to post

Nivdia 334.89 work fine With my 770gtx

 

 

Envoyé de mon iPad à l'aide de Tapatalk

Share this post


Link to post

I also have a 770 GTX but have similar issues with the new driver. 332.21 better on my system. Go figure.

 

Todd

Share this post


Link to post

 

Maybe on some cards it can or some people simply don't use SGSAA...

If you disable it, you should get rid of the anomalies, but the instruments and readings are shimmering and pixeling without it.

I use the older driver and everything is fine. Couldn't see any usefull changes in the new driver anyway.

 

 

To 'roll back' onto the older driver should I just reinstall it, or should I uninstall the current drivers first? 

 

Don't understand how new optimize drivers can make P3D worst...

Share this post


Link to post

 

 


Don't understand how new optimize drivers can make P3D worst...

 

Because they don't have any optimisations for P3Dv2x... maybe nV will look at it at some point, and then you might see some improvements and the elimination of some of the bugs that have cropped up in the latest builds.

Share this post


Link to post

One issue that I see here is the the Original Poster needed to come up with a specific test using default planes and scenery so that others can carefully test before saying all is OK - or not. In this case, the OP later on posted a photo of the problem - not with a default plane though - and the rest of us could see what he meant by "grainier textures". I am using 334.89 and didn't notice any issues but I don't have the Airbus in the photo.

Share this post


Link to post

To 'roll back' onto the older driver should I just reinstall it, or should I uninstall the current drivers first? 

 

Don't understand how new optimize drivers can make P3D worst...

As Todd said, just reinstall the old driver.

But attention! In the installation options you have to choose "advanced custom installation" not "express" and later on in the custom install options "perform clean install"!

(sorry, im on a german software, don't know the exact english phrases the installation routine uses ...)

Doing it this way the installation routine uninstalls the existing driver prior to installing the new one.

 

According to "optimization" .... there is none for p3d mentioned in the driverreadme...

 

and: a nvidia-chip is not a nvidia-chip is not a......  ;-)

Share this post


Link to post

One issue that I see here is the the Original Poster needed to come up with a specific test using default planes and scenery so that others can carefully test before saying all is OK - or not. In this case, the OP later on posted a photo of the problem - not with a default plane though - and the rest of us could see what he meant by "grainier textures". I am using 334.89 and didn't notice any issues but I don't have the Airbus in the photo.

After further testing it seems to be determined (the grainy textures) by the way shadows fall onto any aircraft (not just the airbus). If you disable shadows in the latest nvidia graphics drivers the problem is gone.

Edited by OmniAtlas

Share this post


Link to post

Where is the shadows option in the new nvidia drivers CP?

 

Thanks

jja

Share this post


Link to post

Where is the shadows option in the new nvidia drivers CP?

 

Thanks

jja

 

Shadows within P3D 2.x, not the nvidia CP. 

Share this post


Link to post

Does Lockhead even know about this problem? Is it being addressed? I don't see anyone complaining about it on their forum. 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this