Jump to content

Archived

This topic is now archived and is closed to further replies.

pcubine

Full Screen to Windowed Mode

Recommended Posts

I start my flights in the full screen mode and fly in the full screen mode. Yesterday from the full screen mode FSX dropped  to the taskbar and the desktop appeared. Click on the FSX icon on the taskbar and it will come back in the full screen mode. Press Alt+Enter and it will come back in the windowed mode. The only way I can prevent FSX from going to the taskbar is to run in the windowed mode. In full screen FSX drops to the taskbar on an average of once every five minutes. Any ideas on what may be causing this issue

 

Thank you

Michael Cubine


Michael Cubine
xVxT6x.jpg

Share this post


Link to post
Share on other sites

who knows... maybe you have some application / program that was trying to do something at that time. I remember a few Years ago a lot of people had this problem becouse of adobe automatic updater. It could be something similar


Zeljko Budovic

Share this post


Link to post
Share on other sites

Possibly the starup of another program, possibly an anti-virus program downloading updates or even starting a scan of your system.  First thing I would try is to see if the anti-virus program can be put into "Silent Mode" while you fly.

 

This has happened to me a few times.


Charlie Aron

Awaiting the new Microsoft Flight Sim and the purchase of a new system.  Running a Chromebook for now! :cool:

                                     

 

Share this post


Link to post
Share on other sites

Thanks for the answers.

 

Maybe I gave the wrong impression that this was a one time occurrence but it is a continuing issue that started yesterday morning and has spanned 6 flights with three different PMDG planes. The 737NGX, MD-11, and 777.

 

I control when Adobe updates run. I use MSE for AV and it is set to run at midnight. I would not try to run either application when I am using FSX.

 

Michael Cubine


Michael Cubine
xVxT6x.jpg

Share this post


Link to post
Share on other sites

I would check what is running in backround first. If not application, antivirus or accidentally hitting some combination of keys, it's probably about settings. 

 

If you want, try this: 

 

- right click on fsx.exe, go to compatibility tab and click on "change settings for all users", and in "compatibility for all users" window - check only "disable visual themes" and "disable desktop composition". After that click on apply, ok, apply and ok untill you clear all windows

- go to the control Panel, "appearance and personalization" and select "Personalization". On the left hand side click on the "Change mouse pointers". In the "Pointers" tab, under "Scheme" select (None), under "customize" select "Normal Select" and press apply and ok

 

I'm not sure if this is relevant, but it's a good idea to set FSX like this, it's more stable


Zeljko Budovic

Share this post


Link to post
Share on other sites

Believe B247NG is on the right track.  I did a Google search for full screen mode crashes to taskbar most are saying this happens a lot with games in Windows 8 if you have the Taskbar auto hide function turned on.  Do not know if you have Windows 8 Michael but this could be a solution. I certainly believe it has something to do with your desktop setup.

 

Best regards,


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post
Share on other sites

I'm not sure if this is relevant, but it's a good idea to set FSX like this, it's more stable

I will try this later tonight and report back tomorrow.

 

Thanks

Michael Cubine


Michael Cubine
xVxT6x.jpg

Share this post


Link to post
Share on other sites

Believe B247NG is on the right track.  I did a Google search for full screen mode crashes to taskbar most are saying this happens a lot with games in Windows 8 if you have the Taskbar auto hide function turned on.  Do not know if you have Windows 8 Michael but this could be a solution. I certainly believe it has something to do with your desktop setup.

 

Best regards,

I run Windows 7 and the Taskbar auto hide is not enabled. Thanks anyway.

 

Michael Cubine

I'm not sure if this is relevant, but it's a good idea to set FSX like this, it's more stable

I made the changes on fsx.exe which you recommended. The mouse was already set up the way you suggested. Full screen mode is still dropping to the Taskbar. So I guess I will have to fly windowed until I do something screwy again. Maybe I will smash my palm on the top of the mouse. Hit the left and right click and scroll button all at the same time.

 

Thanks

Michael Cubine


Michael Cubine
xVxT6x.jpg

Share this post


Link to post
Share on other sites

Try running fullcreen script with a hot key, you can find it  In the library. 

Share this post


Link to post
Share on other sites

Try running fullcreen script with a hot key, you can find it  In the library.

Thanks.

 

Where does the file fullscreen.ahk go. The readme.txt says to see autohotkey.com for instructions but is says nothing about location of files.

 

Thank you

Michael Cubine


Michael Cubine
xVxT6x.jpg

Share this post


Link to post
Share on other sites

Any application that pops up messages will do this. The term is "focus stealing."

For instance the bubble that appears when u get a new email in Outlook will do it. Kill all background tasks. I have an App killer I run b4 starting FSX.

Share this post


Link to post
Share on other sites

I seem to recall having similar issues a long time ago so I always start in Windowed mode, load the aircraft I want to fly and then switch to Full Screen mode. Don't have this problem any more. Now it just seems the natural way to do it.


Asus Maximus Hero XI , i7-8086, 16 Gb RAM, nVidia GTX 1080 ti

Share this post


Link to post
Share on other sites
Guest

I had this happening and tracked it down to "Google Now".  If you are running Google Chrome it loads a tray icon for Google Now.  Every time you get a notification, your FSX will minimize.  If you clear the notifications and put it into "Do not Disturb"  it will not bother your FSX session.

Share this post


Link to post
Share on other sites
Guest

Followup - Thought I had this licked.  Not so fast, it started doing it again and I have no other ideas why this happens.  Just started a few weeks ago.  Sorry.

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,660.00 of $25,000.00 Donate Now
×
×
  • Create New...