Jump to content

Archived

This topic is now archived and is closed to further replies.

schmo

Strange Problem with buttons and switches in VC

Recommended Posts

Hi there,

since a few days, I have a strange problem with the NGX, which I never had before in any plane in FSX.
After using the 737 for a couple of years without any problems, some days ago most of the buttons and swichtes in the VC stopped working. They are ignoring basically my mouse clicks. The coursor changes to the hand symbol, but nothing happens if I click or scroll with the mousewheel. To make it a bit more complicatet, thats the case with a lot of switches, but not with all. On the EFIS for instance, all pushbuttons like terrain, data or also the traffic and standard pressure knobs are working fine, but the scroll knobs can´t be used. On the MCP not a single switch or butten can be used. All capped swichtes on the overhead are unusable, but rotary switches like the autobrake are working completely fine.

But it gets even more strange. And at this point, I have absolutely no idea how this could be possible.
I have found one single repaint (wich is the Angle of Attack repaint for the 738WL) where everything and every switch is working normal. Only if I install this repaint and only if I choose this repaint in FSX, all switches and knobs in the VC are useable.

If I load another repaint (even the standard PMDG repaint) or if I switch to another repaint after loading the NGX with the Angle of Attack repaint first, the same problem occurs again.

This hole thing is the case with all models from 600 to 900, with the exception that the AOA Repaint only fixes the problem on the 800WL (They have also repaints for the 600 and 700, but if I use those, the switches still don´t work on these models.)

If use the NGX at its lates version on WIN7 64 bit.

Does anybody have an idea, what could be going on here?

Thanks and best regards,

Schmo



 

Share this post


Link to post
Share on other sites

Hi Schmo,

 

My guess is, that you have re-positioned yourself too far back while sitting in the captains seat.

 

I think its ctrl+enter to move forward in the seat and ctrl+backspace to move backward in the seat.

Shift+enter is to move up in the seat and shift+backspace is to move down in the seat.

 

Try moving forward a bit and that should resolve your problem.

 

Best regards,

Rene

Share this post


Link to post
Share on other sites

Change your eye point. Maybe move it forward a little and see what happens. Just a guess.


Gary, CIMEL, retired FAA Controller & all around good guy!
Faa.gif

Share this post


Link to post
Share on other sites

Thanks for your quick answers.

I have already tried to zoom in and out, even to go really close to the switches by useing the + and - keys, but also by changing my position with the arrow keys
I´m using an EZDOK profile, witch should mean that I have the same viewpoint and camerasettings in every repaint. In the AOA repaint it works, in all others it doesn´t.
Is it possible that there are seperate viewpoints set for the different repaints beside of the EZDOK settings?

(I can´t try it out now since I´m not at home for the next 7 hours)

Share this post


Link to post
Share on other sites

I use EZDOK too and its not the zoom...it is literally the position where you are "sitting". You need to move forward just a bit and it will resolve your issue...guaranteed. So press 2 on your numpad, move forward with the arrow key just a tad bit, hit 2 again and that should have resolved it. If not, check your zoom setting and put it back to 80 or something and then re-position again with numpad 2 and arrow keys.

 

I had my EZDOK setup as well for the based pack 800-900 NGX (including AOA repaint). Then I got the 600+700 package, loaded the same EZDOK profile and had the same problem as you...the 600+700 are smaller/shorter and so your current sitting position is further back based on the 800-900 profile, meaning that the seat is in the way.

Share this post


Link to post
Share on other sites

Thanks, I will try that once I´m at home today an let you know if this does the job.

It makes sense that there are differences between the models, but for me at the moment it does´t even work in the same model. AOA 737-800WL repaint --> all is OK. Any other 737-800WL repaint --> most switches don´t work. Thats still confusing, because at least the 800 cockpits should be identical.
But this afternoon I will see what will happen.

Share this post


Link to post
Share on other sites

Bad news. It did not help.

I´ve moved my position forward by changing my EZDOK pilotes view using the 2 key to overwrite it to be (a lot) more near to the windshield. I´ve also disabled EZDOK and moved the position with the standard fsx key commands to do so. Both had no effect. Everything is still the same. The AOA repaint works perfect, but as soon as I use any other repaint lots and lots of switches are simply dont reacting to my mouse anymore.

I´ve also done a complete reinstall not only of the NGX but also for all other PMDG planes I have. It´s absolutely strange, since basicaly the plane seems to be working. I have realy no idea how a repaint could influence the VC in such a way.

Share this post


Link to post
Share on other sites

Something you said earlier made me wonder... How do you normally load a flight? Do you go to the free flight menu, select the NGX, then jump in the game? Or are you using the method PMDG advises against (as in loading the NGX on top of another plane or another livery)?


Cristi Neagu

Share this post


Link to post
Share on other sites

I´ve also done a complete reinstall not only of the NGX but also for all other PMDG planes I have. It´s absolutely strange, since basicaly the plane seems to be working. I have realy no idea how a repaint could influence the VC in such a way.

 

Next time you're in one of the planes that isn't working, put the plane in external view and have a look at the registration number.  Then hit ALT, and select Aircraft > Select Aircraft.  On that screen, check to make sure that the registration number for the livery you're using matches.  If it does not, that's likely the cause of the issue.

 

My bet is that a non-standard livery installer, or your own edits to the aircraft.cfg to add a non-PMDG livery (not sure how the AoA livery is delivered) ended up messing with the sim's understanding of the REG field, which is required for the plane to work properly.  Every livery's REG must match one of the .INI files in Flight Sim > PMDG > 737NGX folder (they're all contained in a folder within the 737NGX subfolder, but I can't recall the name of it at the moment).

 

Additionally, uninstall/reinstall often just creates more issues than it's attempting to solve.  As you can see here, it didn't work, so it's not the silver bullet that people pass it off to be.  It's best to exhaust all other options, first.  This is particularly true for this case, because the uninstaller may leave some of the liveries behind, which can interfere with re-installing the liveries, which could be making things more difficult here as well.


Kyle Rodgers

Share this post


Link to post
Share on other sites

@ Cristi_Neagu

I have tried both ways. Normaly I load the default cessna at an airport and then change to any complex aircraft I´m going to use. This also worked for the NGX all the time. (But I´m aware of it that the manual recommends to load the 737 directly in the menu and then start the flight.)

However either way of starting a NGX flight leads to the same result, which I described in my postings.

@ Kyle

The AOAl ivery comes as  PTP file wich does´nt make it necessary to edit the config manualy, as you shurely know. At the moment I have only installed the standard PMDG repaint. Since I have reinstalled the NGX completly, I din´t change anything in the cfg by hand so far.
But I will have a look at what the tail numbers are saying.
 

Share this post


Link to post
Share on other sites

By the way, after uninstalling I´ve manually deleted all remaining PMDG folders under simobjects as well as directly under the fsx root. After that I´ve cleaned my registry by using TuneUp Utilities. I think I probably had everthing from PMDG kicked of the disc before reinstalling, altough I can´t be absoltely shure about that.

Should the tailnumber match the little sign below the clock and left to the captains PFD? Because there is no tailnumber to see on the AOA repaint.

That´s the situation right now:
 

 

Installed repaints: PMDG standard from 600 to 900, AOA for the 800WL.

737-800 standard repaint (not working)
 - fsx menue: "N738PM"

 - below clock: "N738PM"
 - tail: "N738PM"

AOA repaint (working)
 - fsx menue: "NAOA01"

 - below clock: "N738PM"
 - tail: nothing to see

All necessary ini files are in the folder (N738PM.ini, NAOA01.ini)



These are the (only) two livery entrys in the 737-800WL cfg file:


[fltsim.0]
title=PMDG 737-800NGX PMDG House Winglets
sim=B737-800WL
model=
panel=
sound=
texture=pmdg
kb_checklists=Boeing737-800_check
kb_reference=Boeing737-800_ref
atc_airline=PMDG
atc_id=N738PM
atc_flight_number=738
atc_model=737-800
atc_parking_types=GATE,RAMP
atc_type=BOEING
ui_createdby=PMDG
ui_manufacturer=Boeing
ui_type=737-800NGX
ui_typerole=737-800
ui_variation=PMDG House Winglets
airline_name=PMDG Flight Test
description=Boeing 737-800 powered by CFM engines v 1.0\nPMDG Simulations\nwww.precisionmanuals.com \n\nProduced under license from Boeing Management Company.\n\nBoeing 737, 737-800 & Boeing are among the trademarks owned by Boeing.
visual_damage=0

[fltsim.1]
title=Boeing 737-8CTNGX Angle of Attack
sim=B737-800WL
model=
panel=
sound=
texture=AOA
kb_checklists=Boeing737-800_check
kb_reference=Boeing737-800_ref
atc_airline=PMDG
atc_id=N738PM1
atc_flight_number=738
atc_model=737-800
atc_parking_types=GATE,RAMP
atc_type=BOEING
ui_createdby=PMDG
ui_manufacturer=Boeing
ui_type=737-800NGX
ui_typerole=737-800
ui_variation=Angle of Attack
airline_name=Angle of Attack
description=Boeing 737-800 powered by CFM engines v 1.0\nPMDG Simulations\nwww.precisionmanuals.com \n\nProduced under license from Boeing Management Company.\n\nBoeing 737, 737-800, 737-900 & Boeing are among the trademarks owned by Boeing.
visual_damage=0

Share this post


Link to post
Share on other sites

 

 


Should the tailnumber match the little sign below the clock and left to the captains PFD? Because there is no tailnumber to see on the AOA repaint.

 

As long as the FSX Menu matches one of the .INI files, you should be fine.

 

Is it working again after the reinstall/cleanup?


Kyle Rodgers

Share this post


Link to post
Share on other sites

Nope Kyle, sadly even the reinstallation didn´t change anything. AOA repaint works like a dream, everyting else is unuseable.

In the unuseable planes, if I go with my mouse over the speed selector (for example) and start scrolling the mousewheel, the cursor changes to the hand symbol, but that´s all what´s happening. Don´t know if this clould be a usefull information.

Share this post


Link to post
Share on other sites

 

 


Nope Kyle, sadly even the reinstallation didn´t change anything. AOA repaint works like a dream, everyting else is unuseable.

 

Change the red line, below from:

atc_id=N738PM1

to

atc_id=NAOA01

 

...and report back.

 

[fltsim.1]
title=Boeing 737-8CTNGX Angle of Attack
sim=B737-800WL
model=
panel=
sound=
texture=AOA
kb_checklists=Boeing737-800_check
kb_reference=Boeing737-800_ref
atc_airline=PMDG
atc_id=N738PM1
atc_flight_number=738
atc_model=737-800
atc_parking_types=GATE,RAMP
atc_type=BOEING
ui_createdby=PMDG
ui_manufacturer=Boeing
ui_type=737-800NGX
ui_typerole=737-800
ui_variation=Angle of Attack
airline_name=Angle of Attack
description=Boeing 737-800 powered by CFM engines v 1.0\nPMDG Simulations\nwww.precisionmanuals.com \n\nProduced under license from Boeing Management Company.\n\nBoeing 737, 737-800, 737-900 & Boeing are among the trademarks owned by Boeing.
visual_damage=0

Kyle Rodgers

Share this post


Link to post
Share on other sites

That´s the only line that I was wondering about too. But to change it like you told me brought no success.

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    50%
    $12,660.00 of $25,000.00 Donate Now
×
×
  • Create New...