Sign in to follow this  
doublebubble

Six big stutters every 30sec's

Recommended Posts

Hi all, I've been trying for at least 12 months now to rid fsx of this big stutter that happens every 30sec's, without going into it in a long drawn out blog I've tried every thing as per the guides to the tee, running FTXG, DX10 FIXER, all the bufferpool settings, clean installs on it's own drive, numerous fsx.cfg set up's and the list goes on without any change what so ever, the only thing I haven't done is autting down process's and service' that are running in the back ground as I'm totally unsure as to what can be shut down, could some one point me in a direction as to where I can find a guide to do this as a last resort to see if that can slove the problem, win7 64bit, thankyou.

 

Cheers Rod.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I had the same annoying issue. What worked for me was to set the vsync in NI as controlled by the 3D application and turned the vsync on in fsx.cfg under graphics section. Initially I had 1/2 refresh rate enabled with the regular stutters as you mentioned.

Share this post


Link to post
Share on other sites

Seems to be a system service starting in the background. I used to get stutters a lot - but they just stopped as I disabled services I didnt need.

Share this post


Link to post
Share on other sites

Thanks guys, I will try the different vsync option and see how we go but I still think it may be a services running issue but unfortunately I'm really not sure what services to disable as I'm
not really that computer savy when it
comes to doing that, drago could you give me some idea as to where I might start? Thanks again for the input.

Cheers Rod.

P.S. sorry Drago I meant to point the service's question to 777.

Share this post


Link to post
Share on other sites

Thanks guys, I will try the different vsync option and see how we go but I still think it may be a services running issue but unfortunately I'm really not sure what services to disable as I'm

not really that computer savy when it

comes to doing that, drago could you give me some idea as to where I might start? Thanks again for the input.

 

Cheers Rod.

http://www.askvg.com/windows-7-services-that-can-be-safely-set-to-manual/

Share this post


Link to post
Share on other sites

Do you by any chance have auto-save turned on within FSUIPC? That could cause the stutters everytime it saves...

 

Cheers!

Share this post


Link to post
Share on other sites

Most likely a background process.

 

Turn of your anti-virus and see if that stops it - there may be several associated processes, which AV are you using?

 

Also a few anti malware progs have background processes by way of real time monitoring - try turning those off too (e.g. malwarebytes, spybot, adaware, etc. and any system tuneup utilities).

 

Other than that, you need to understand what each background process is doing.  Start the task manager and post screenshots of all the tasks running (or list them if you prefer).  Most of us here will have seen most of them and will be able to perhaps spot any likely culprits for you.

 

You could of course have a virus (hope not and that's the least likely scenario).

 

IAN

Share this post


Link to post
Share on other sites

Even better than turning off Antivirus protection is to see if it has a setting called "Silent Mode". 

 

Your computer will be protected but no scanning, updating, or other service will run while you

 

are using FSX.

Share this post


Link to post
Share on other sites

I was suggesting turning off the processes as a diagnostic exercise rather than keeping them all switched off for ever.

 

IAN

Share this post


Link to post
Share on other sites

It may be a background process, but I think the 30 secs frequency is significant. I noticed a while back that my CPU utilisation went sky high for 30 secs every minute, even when I was sitting on the tarmac cold and dark. That was eventually diagnosed as FSX refreshing its scenery, which (I'm told) it does at this frequency whatever else is going on. My rig/setup (tuned to Nick N's guide) seems to be able to cope with the extra load without stuttering, but it looks a close run thing. Then again, I don't fly demanding aircraft like NGX or into busy modern airports with lots of AI.  

Share this post


Link to post
Share on other sites

I had the same problem. I tried numerous re-installs, I tried installing on different drives, I tried different configurations, lefts some scenery uninstalled, did registry tweaks to stop the CPU parking and nothing helped.

 

I could not understand what was causing it as it had run fine for ages with no problem, now I was getting freezes. By chance I did an install and set everything up before I installed Microsoft Security Essentials and everything worked fine. When I installed MSE it started again.

 

I had always had MSE since it came out and had set it not to check my FSX folder or any folder that was associated with it, so it would not scan it, but for some reason it had started causing stutters. I can only assume that something in an update was causing the problem. I tried by turning the realtime protection off but this made no difference. When I uninstalled it completely then no stutters.

Share this post


Link to post
Share on other sites

Can you tell me how to set MSE to ignore the FSX folder?

I have used MSE for years with no problems. But to answer your question:

 

Open MSSE

 

Settings Tab

 

Exclude Files and Folders

 

Browse to your FSX folder

 

Highlight and Add

 

Save changes

 

 

Any of this just affects scans and not the Real Time Protection.

Share this post


Link to post
Share on other sites

If it is that regular, you should be able to see the process in Windows Task Manager.

 

Run FSX and Task Manager side by side in windowed mode with the Task Manager showing Processes, sorted by CPU usage.

Share this post


Link to post
Share on other sites

I thank you guy's for the suggestions and I am surely leaning towards a scenery refresh issue that I'm getting as I have been through the running process's and found that most of them are already set to manual and my AV has been set to game mode and also excludes everything FSX so as mentioned above,

which I have never had before, was to set ForceVSyncWindowMode=1 into the cfg.file and set 3D application controlled in NI instead of 1/2 refresh rate, then did a flight from AYPY to WADD in the NGX and I have to say it was 95% better, somebody may be able to explain why as I thought that tis would only be applicable for windowed mode and not full screen (I always fly full screen). I still need to do a few more flights with a bit more heavy scenery but it didn't seem to matter if the scenery was heavy or not.

 

Cheers Rod.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this