Sign in to follow this  
Colonel X

Going ALL IN on X-Plane

Recommended Posts

In the foreshadow of great X-Plane improvements (visibility, haze ect.) I decided to finally commit to the platform with a dedicated machine, after being unhappy with X-Plane performance with my late 2009 iMac 27" for four years.

 

Just ordered a 4.0 Ghz i7K which I am running with a Z87 chipset (easy overclocking possible). Along with a stock overclocked 6GB 780GTX (ASUS STRIX) and 16GB of 1600Mhz RAM, I really hope to make X-Plane, well, fly!

 

I will connect the system to my 55" Sony W905 LED TV and plan to hop in the F-16 on my couch using (yes, it's blasphemy, and I like it) a Playstation 4 controller (via Bluetooth) with 2 iPads running AirTrack as a glass cockpit.

 

Really excited to see how X-Plane will perform with this setup. Especially looking forward to push objects and LOD - but I am aware that it's only a matter of clouds and global shadows to bring this or any system to it's knees. Well I will see whats possible with locked 30FPS.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

In the foreshadow of great X-Plane improvements (visibility, haze ect.) I decided to finally commit to the platform with a dedicated machine, after being unhappy with X-Plane performance with my Late 2009 iMac 27" for four years.

 

Just ordered a 4.0 Ghz i7K which I am running with a Z87 (easy overclocking possible). Along with a stock overclocked 6GB 780GTX (ASUS STRIX) and 16GB of 1600Mhz RAM, I really hope to make X-Plane, well, fly!

 

I will connect the system to my 55" Sony W905 LED TV and plan to hop in the F-16 on my couch using (yes, it's blasphemy, and I like it) with a Playstation 4 controller (via Bluetooth).

 

Really exited to see how X-Plane will perform with this setup. Especially looking forward to push objects and LOD - but I am aware that it's only a matter of clouds and global shadows to bring this or any system to it's knees. Well I will see whats possible with locked 30FPS.

 

Nice! You won't be sorry with that setup I imagine.

Share this post


Link to post
Share on other sites

Looking forward to hearing your results. I run X-Plane on an old i5 750 with a GTX 770 and it seems to handle most things ok. SkyMaXX Pro clouds are way better performance wise than the built in ones but currently don't support shadows. However they have a v2 in beta that apparently does and is even better.

Share this post


Link to post
Share on other sites

Don't go into it thinking you can run everything on max.

 

 

Haha if you read my closing comments, I am not that naive!

Looking forward to hearing your results. I run X-Plane on an old i5 750 with a GTX 770 and it seems to handle most things ok. SkyMaXX Pro clouds are way better performance wise than the built in ones but currently don't support shadows. However they have a v2 in beta that apparently does and is even better.

 

 

When did cloud shadows become available anyway? It's not official is it? To me, the whole cloud issue is in a transforming state... we will see what happens in 10.35+, I am especially curious about better atmospheric scattering / haze and will experiment with the art control hacks for now. I agree that SkyMaxx improves perf. but I found it not to be the most reliable plugin. Do you know if they will charge for V2?

Share this post


Link to post
Share on other sites

Haha if you read my closing comments, I am not that naive!

 

 

When did cloud shadows become available anyway? It's not official is it? To me, the whole cloud issue is in a transforming state... we will see what happens in 10.35+, I am especially curious about better atmospheric scattering / haze and will experiment with the art control hacks for now. I agree that SkyMaxx improves perf. but I found it not to be the most reliable plugin. Do you know if they will charge for V2?

 

I've found I have to disable and then re-enable SkyMaxx on sim start, works fine then usually.

Share this post


Link to post
Share on other sites

I'm fully expecting SkyMaxx v2 to be a paid upgrade. I'm not 100% certain as I don't use them, but I thought that from the latest 10.30 betas when using the default clouds then shadows were enabled. I have a vague recollection of uninstalling SkyMaxx to see what all the fuss was about and although the default clouds are indeed significantly better and shadows were there, they still kill my poor old CPU.

Share this post


Link to post
Share on other sites

I'm fully expecting SkyMaxx v2 to be a paid upgrade. I'm not 100% certain as I don't use them, but I thought that from the latest 10.30 betas when using the default clouds then shadows were enabled. I have a vague recollection of uninstalling SkyMaxx to see what all the fuss was about and although the default clouds are indeed significantly better and shadows were there, they still kill my poor old CPU.

 

I think the clouds are completely GPU bound. Also there seems to be a performance issue with 10.30 beta clouds and it won't go final before the the clouds are as "fast" (they're slow either way) as in 10.25.  Anyway, I think by the end of this year, the whole sky/color/haze/cloud issue will have improved a lot.

Share this post


Link to post
Share on other sites

Never had any issues with SkyMaxx and you guys might want to post your issues over at X-Aviation as they are prompt to help troubleshoot issues.

Share this post


Link to post
Share on other sites

There is only one issue that i am aware of, SM will crash if the overcast layer is set to low and only on MAC.....We are driving towards a fix btw....

 

Reliability outside of that could be percieved or unfounded, yes if you are having issues please provide us crash logs on X-Pilot so we can address it.....

 

Ill be direct, when I see these claims I get frustrated by the lack of information usually attached to them. Its only two of us and we do drive hard to address issues that pop up with SM....But if I dont hear anything from the user base I cannot do my job....

Share this post


Link to post
Share on other sites

I don't have any problems with SkyMaxx. I was referring to the default X-Plane clouds :)

 

Rereading my posts and I can see that my wording makes it seem that way, but as far as SkyMaxx, I'm a happy camper and am really looking forward to the v2 version.

Share this post


Link to post
Share on other sites

Well when I read the title of this thread it reminded me of what I did in the last few days...

 

A week ago I had FSX, Prepar3D v2, and X-Plane 10.30b7 all on my PC.

After loading up FSX to play with the PMDG 777, I got an OOM not long after.

FSX was off my hard drive shortly after (life's really too short for this constant OOM crap).

 

2 days ago I took the AXE for a VA flight in Prepar3D v2 from KJFK to KBOS.

Taking off my FPS was down the toilet and it was stutter city.

Once I got to cruise FPS was backup to a locked 30.

So I got curious and quit out after a while, and loaded XP10 with the same flight using the Jar A320, and marvelled as my FPS stayed in the late 20s and was smoooooth.

From what I could tell there was as many if not more objects in XP displayed around NYC than in P3D.

At cruise I was touching the 60 FPS limit of my monitor.

 

Soooo I completed my flight in XP10 and 10 mins later was uninstalling P3D.

 

Time to turn the page then with the MS-based sims, say bye-bye to Orbx and move on (my wallet will certainly thank me)! :)

Share this post


Link to post
Share on other sites

Well when I read the title of this thread it reminded me of what I did in the last few days...

 

A week ago I had FSX, Prepar3D v2, and X-Plane 10.30b7 all on my PC.

After loading up FSX to play with the PMDG 777, I got an OOM not long after.

FSX was off my hard drive shortly after (life's really too short for this constant OOM crap).

 

2 days ago I took the AXE for a VA flight in Prepar3D v2 from KJFK to KBOS.

Taking off my FPS was down the toilet and it was stutter city.

Once I got to cruise FPS was backup to a locked 30.

So I got curious and quit out after a while, and loaded XP10 with the same flight using the Jar A320, and marvelled as my FPS stayed in the late 20s and was smoooooth.

From what I could tell there was as many if not more objects in XP displayed around NYC than in P3D.

At cruise I was touching the 60 FPS limit of my monitor.

 

Soooo I completed my flight in XP10 and 10 mins later was uninstalling P3D.

 

Time to turn the page then with the MS-based sims, say bye-bye to Orbx and move on (my wallet will certainly thank me)! :)

 

LOL, as they say! Welcome to the dark side, my transition ran roughly the same as yours and these days my simming is enjoyable and trouble free and my wallet has recovered :lol:

Share this post


Link to post
Share on other sites

There is only one issue that i am aware of, SM will crash if the overcast layer is set to low and only on MAC.....We are driving towards a fix btw....

 

Reliability outside of that could be percieved or unfounded, yes if you are having issues please provide us crash logs on X-Pilot so we can address it.....

 

Ill be direct, when I see these claims I get frustrated by the lack of information usually attached to them. Its only two of us and we do drive hard to address issues that pop up with SM....But if I dont hear anything from the user base I cannot do my job....

 

When I said "not the most reliable", I didn't exacly mean crashing. The issues I had was that clouds would dissapear hard and rebuild once wx changes (maybe that's an X-Plane error), that sometimes put me off. Other than that, I found the interface to lose it's settings once in a while. Also, the rays would sometimes not show until I went into the interface to turn them off and on again and tadaa - they were back. Minor things really. Really looking forward to V2, no question!

 

Also, when I unload the plugin, I seem to have no more X-Plane clouds at all :)

Share this post


Link to post
Share on other sites

I think the no clouds issue is because the SkyMaxx Pro installer makes the current cloud textures all transparent so they don't show. This may well be wrong, but I recall reading that somewhere.

Share this post


Link to post
Share on other sites

Yeah, you have to rerun the installer and reinstall over the cloads, if you want to see the default ones again.

Share this post


Link to post
Share on other sites

Real quick I dont want to hijack this thread....

 

Yes we do make clouds transparent.......run the updater and overwrite the default cloud files when prompted to get your defaults back....

 

Again I hope you bring support related issues up at x-pilot so we can better serve you....

 

The other issues above do have our attention btw....sorry I cant quote posts on my phone ;)

Share this post


Link to post
Share on other sites

Real quick I dont want to hijack this thread....

 

Yes we do make clouds transparent.......run the updater and overwrite the default cloud files when prompted to get your defaults back....

 

Again I hope you bring support related issues up at x-pilot so we can better serve you....

 

The other issues above do have our attention btw....sorry I cant quote posts on my phone ;)

 

Thanks for the clarification. Can you point me to the right place to stay updated about V2?

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this