Sign in to follow this  
SierraHotel

Program Pin Error In SP1d

Recommended Posts

Hi all, have had this twice now, since installing SP1d. never experienced it before now, although I searched and found ref to it happening in SP1c. I was making a vid when it occurred, so the steps I performed are before it happened are easy to follow. It now appears to be happening all the time at LEPA. Will try a different airport to see if it's AIRAC related. Please advise if I should enter a ticket.
 
Mike Collins
 
 
[sharedmedia=videos:videos:355]

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just got this same thing in the FMC like 5 minutes ago....I'm also using Pro Atc/X (airac 1503) . This happened after I created a flight plan from KAUS - KIAH in pro atc with the ILEXI1 sid (KAUS ILEXY1 ILEXY MSCOT3 KIAH) only to have Pro ATC/x change sids on me once getting clearance, to the AUS3 sid. I had already programmed the departure SID into the FMC and imported the Pro Atc/X flight plan into the FMC, and executed it before receiving clearance. I went back into the FMC to change the sid, and that's when the departures/arrival page crapped out on me.... P3D 2.5

 

Jonathan Lewis

Share this post


Link to post
Share on other sites

I had this last night also when entering a STAR. for PHOG, forgot name trans camps< something like that rwy 20

Share this post


Link to post
Share on other sites

I just got one of these too, while reloading a saved flight - In the left fms. The right one was fine and eventually the left came back on too and cleared the pin error.

Share this post


Link to post
Share on other sites

hi, yes i am using pro atc/x ... and have the same issue yesterday when try to put approach to FSIA on the dep/arrival page of fmc .... the Windows events shows that at the same moment there was an error on fsx. exe on the module gdipluss.dll  ...

 

i willl try installing sp1c ... and i did not see yet the pro atx/x fórum ... for check if someone report something similar ...

 

regards

 

Carlos

Share this post


Link to post
Share on other sites

I have just noticed something else that may also be relevant to the warning light problem. I got the program pin error after I had used the suggested work around i.e. Setup the cockpit from the PMDG default and save. I reset back to default, then to CLDDRK, this is when I noticed that after CLDDRK had started and I went to menu clicked and held for five seconds, but, instead of the menu's appearing, I got a warning notice saying 1 item had failed! But I had no failure's set up? What I did was to clear the failure and then save that setup as my new clddrk starting panel. I have not had the program pin problem since. By the way I have also put a ticket in to PMDG, but I have a sneaking suspicion that this is not just another bug, by reason of the fact that a "Program Pin Failure" is mentioned in the FCOM!

PS, I also use ProATC

Share this post


Link to post
Share on other sites

I´m not using Pro ATC/X but I had this error coming up several times, also before SP1d, however I found an easy fix that worked ever since I found it, at least on my setup.

 

When the error occurs, just press the "menu" key on the CDU and hold it for a couple of seconds (like one would do to "wake up" the FMC in cold & dark panel state).

 

In both cases the frozen FMC sprang back to life. Hope that´s not too obvious and hasn´t been posted before...

Share this post


Link to post
Share on other sites

I have similar problems and use PRO-ATC/X as well. When loading the flight plan to the FMC the PROGRAM FIX ERROR message appears when I try loading the SiD. Today, I took off without the SiD assigned and I could from the directions from PRO-ATC/X hear the problem is related to the FMC in the plane, not PRO-ATC/X. Navigraph is updated to the latest cycle for both PRO-ATC/X and PMDG. Same problem on approach for landing. I really hope that somebody will come ud with a fix for this...

Share this post


Link to post
Share on other sites

PROGRAM FIX ERROR message appears

Are you certain this is what the message said?

Share this post


Link to post
Share on other sites

No, sorry, not "Program Fix Error" but "Program pin error" - my mistake...

 

Anyway, I think I solved the problem (for me anyway) and here`s how in case other might have the same problem: Before,  I used to activate and excecute BEFORE entering DEP/ARR and assigning RWY and SiD.This was in aacordance with the checklist I use and this procedure worked for me.  

 

Now, I have to wait activating and excecuting until both the FPLAN, the RWY and SiD all are assigned. Apparently, I can avoid the program pin error this way.

 

I´m not sure why but come to think of it it I admit seems more logical....  

Share this post


Link to post
Share on other sites

And sorry once again: Problem not solved  :angry: . Tonight, I took off alright with the right RWY and SiD assigned as desribed above but on approach I got the program pin error message once again as soon as I tried to assign the RWY for approach in DEP/ARR. Any help is still much appreciated. I wonder if this can be connected with some kind of error in the latest Navigraph AIRAC cycle (1504)?

Share this post


Link to post
Share on other sites

I seem to have this issue as well.  I can duplicate it by selecting my FP, activating it, then try and choose a departure.  Instant program pin.

Share this post


Link to post
Share on other sites

Same here: Program Pin Error after trying to define the rwy at destination on FMC. After that, nothing could be entered there. This is the first time this happened and I've been flying all tis month until today in Navigraph AIRAC 1504, changing today morning to 1505. I use PRO-ATC/X in FSX.

 

Best

Share this post


Link to post
Share on other sites

Did you try the recommendation offered by "Simon30" does that provide a work-around to the problem?

 

The entire thread has PRO-ATC/X in common.  Can the PIN ERROR be generated without the ATC simulation?

 

A PIN ERROR message means the FMS program has encountered an exception internally and has halted running.  This should be rare, otherwise we'd still be in beta getting rid of it. It could be caused by a corrupt route file, it shouldn't but it's possible, but anything else means there might be a bug that needs tracked down.  Any help you guys can provide in isolating how to create this error is going to help.  If it is shown that PRO-ATC/X is causing the error then there's not much PMDG can do about that but understanding the problem is part of the solution.

 

Once a definitive method of causing the problem (step by step reproducible) then it should go on a trouble ticket at PMDG Product Support to ensure it gets snagged by the bug tracking system.

Share this post


Link to post
Share on other sites

I am getting these too, sporadically.  Simon's method works for departure, but does anyone have a workaround for preventing/resolving it during approach phase?  I do not alway know which STAR/landing runway I will be using.  Like many others, I am also using Pro-ATC.  So far this only seems to happen with the NGX.  Never had it happen on the 777, which I use more often.

 

Andrew Jones


I am getting these too, sporadically.  Simon's method works for departure, but does anyone have a workaround for preventing/resolving it during approach phase?  I do not alway know which STAR/landing runway I will be using.  Like many others, I am also using Pro-ATC.  The problem seemed to show up after installing FS2Crew REBOOT.  So far this only seems to happen with the NGX.  Never had it happen on the 777, which I use more often.

 

Andrew Jones

Share this post


Link to post
Share on other sites

The entire thread has PRO-ATC/X in common.  Can the PIN ERROR be generated without the ATC simulation?

 

...

 

Once a definitive method of causing the problem (step by step reproducible) then it should go on a trouble ticket at PMDG Product Support to ensure it gets snagged by the bug tracking system.

 

Since Mike reported the issue, other ProATC beta team members have tried to reproduce the issue (me including). But... the only time one of us (except Mike) got the PIN ERROR was, when he was not using ProATC with the NGX. When it happened, he was doing circuits at ESSA with nothing other than NGX running.

 

As far as I know, PMDG already has a few tickets on the subject.

 

As noted before, ProATC users started reporting this only after they had installed the latest version of the NGX. On the first page of this thread, you can also see mention of this happening without the use of ProATC.

 

I'm running old version of the NXG on FSX and haven't been able to get this error on my system.

Share this post


Link to post
Share on other sites

I was suffering from the same frustrating issue...frequent Program PIN errors in the PMDG 737 FMS after loading a CO ROUTE generated by ProATC/X, and then trying to select runways and/or SIDs/STARS on the FMS.

 

One thing that worked for me was to restore my latest AIRAC data using the Navigraph FMS Data Manager app (even though I had previously installed this AIRAC cycle in all my relevant add-ons - both ProATC/X and PMDG 737).   After restoring this data in all my add-ons and going through the recommended ProATC/X steps for a new AIRAC set, the Program PIN errors stopped.  At least for now.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this