Sign in to follow this  
Bunkers

Possible solution to stutters in P3D?

Recommended Posts

A suggestion I came across on a racing simulation forum (rfactor2) to eliminate stutters by enabling something called HPET:

 

http://isiforums.net/f/showthread.php/24751-HPET-Or-how-microstuttering-could-be-eliminated

 

I don't have stutters in rF2, but still have them significantly in P3D. I've tried pretty much every suggested fix I've come across with P3D, I'll probably try this one too.

 

Anyone got any input / experience with this "HPET" setting and whether it's relevant for P3D stutters?

 

 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Have you tried it at al? Intrigued to hear more about this.

Share this post


Link to post

A quick Interwebs search indicates that on newer systems it is better to have HPET off. It has been superseded by a better hardware clock called TSC (time stamp counter), particularly on new CPU and OS (Windows 7+).

Share this post


Link to post

A quick Interwebs search indicates that on newer systems it is better to have HPET off. It has been superseded by a better hardware clock called TSC (time stamp counter), particularly on new CPU and OS (Windows 7+).

I think testing in ones individual setup is a must.

Every single report I see indicates conflicting conclusions on what to do

Share this post


Link to post

Following the swap from FSX to P3D (2.4) in combination with the procurement of a new state of the art PC (4790K & GTX980), I also experienced stutters. Disabling all the automatic save functions of FSUIPC did solve it for me.

Best regards,

Dirk 

Share this post


Link to post

Have you tried it at al? Intrigued to hear more about this.

 

I've been away from flightsimming for several months due to my stuttering problems.

 

The first I did today was update to the latest nvidia drivers. This alone seems to (after a very short test flight) to have significantly improved the most serious stuttering issue on my part. At least the big ones (game breakers) seems to be gone. I'm still left with quite alot if micro-stutters, and for that I think I will try this HPET-setting promoted in the first post. If that fails, I'll look into the TSC settings as mentioned by Howellerman in this thread. 

 

Thx for all the comments posted in this thread, It's giving me alot to test and tweak again and a renewed hope I might get back to the butter-smooth P3D experience I remember from a looooong time ago.  B)

Share this post


Link to post

I have tried this and I am not sure it if improved things. Certainly not made things worse.

 

I already had the HPET option enabled in my BIOS.

 

Tom

Share this post


Link to post

Ok so I've now enabled HPET in my OS (Win7) and done another short test flight. Impressions so far are very good on my system. The new nvidia driver (352.86) seemed to kill the major stutters, but left me with very noticable micro-stutters. 

 

Now with HPET enabled in Windows & BIOS (this seems to be important that they are in sync) I could really not notice any stutters, major or micro. The testflights so far are very minor, but the difference in smoothness is very significant. Currently just running FTX Global as an addon, will start adding all the other layers and addons and do some more serious testing.

 

But the consensus seems to be that there is no harm done in at least trying these settings as they can't break anything and are easily reversible. So I encourage anyone with a stubborn stutter-issue to give it a go.

Share this post


Link to post

Great find!! Best one since OPTIMZE_PARTS=1, i'd say.

 

Major improvements here! Almost no stutters anymore!! :smile:

 

Thanks for sharing!

Share this post


Link to post

Glad it helped  B)

 

I really messed up though. I found out my P3D was not the latest version anymore, so I did a complete reinstall. And the stutters are back, way beyond what's playable. 

 

I did not back up my Prepar3D.cfg and I do not remember the countless tweaks I've had in the previous install, so now I'm back to square one. I had P3D running butter-smooth for about an hour though. First time in at least a year. But now I really don't have the passion and energy to go through every tweak there is and test them to try to rebuild the house of cards I had standing just a moment ago. It's gone now, and with that I think I leave this hobby behind for a good while.

 

Luckily I'm getting my fix in simracing nowadays, I'll probably try P3D again when some major new release is out, like 3.0 or something.

 

Hopefully this thread can help more simmers achieve a smooth experience. 

Share this post


Link to post

sad to hear, but possible you got an issue with the shader cache. If yet not done, delete the shader cache.

P3D v2.5 should run just fine on your rig with a default cfg.  Only important tweak: OPTIMIZE_PARTS=1. No other tweaks here. I get 60 fps and smooth as silk.

Settings: Unlimited frames, VSync and Tripple buffer enabled. FXAA off, MSAA 8x, TF 16x

Share this post


Link to post

Thx for the suggestions Joerg, just tried those but with no noticable improvements for me.

 

Just very gutted now that I had it and lost it so quickly. At least I've seen smoothness is possible again. I just don't have the patience I think to fight such a fragile software anymore. But I'm sure every once in a while I'll give it another spin and try a new version and another tweak, and maybe one day I'll get the immersion back and defeat the stutters.

 

At least the HPET setting seems to be helpful on many systems.

Share this post


Link to post

Thx for the suggestions Joerg, just tried those but with no noticable improvements for me.

 

bcdedit /set useplatformclock true

 

Typed this in as admin in cmd promt but says not a recognized command - typed it correctly and tried many other ways - its on in my bios - hmm

Share this post


Link to post

change directory to "C:\Windows\System32"

Share this post


Link to post

change directory to "C:\Windows\System32"

 

Hi Steve - I figured it was the wrong directory but when you run cmd as admin - thats the directory it opens up with - so it should have worked unless it is on all ready maybe ? just built this system a couple of weeks ago maybe it doesnt want me doing this - asus maximus VII formula

Share this post


Link to post

maybe unsetting works:

"bcdedit /set useplatformclock true"

"bcdedit /deletevalue useplatformclock"

Share this post


Link to post

maybe unsetting works:

"bcdedit /set useplatformclock true"

"bcdedit /deletevalue useplatformclock"

 

Yah I was thinking of unsetting but its on in bios so it should stay on - guess I could verify it by doing this - that said I will have to put it back again 

 

Nope that didnt work either - probably not meant to be Stevie

 

I'l shot a screenshot for your viewing pleasure :) hold on

Here you go - looks right to me -OOPS just noticed bcedit should be bcdedit - try again

 

 

Worked reboot now - oh boy - thanks Steve :)

Share this post


Link to post

System seems snappier and P3D loads a bit faster but had stutters so I am goig to revert back in OS to off

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this