Sign in to follow this  
kgriz

Prepar3D v2.5 Config Issue (Please Help)

Recommended Posts

Hello, this is my first time posting on any forum so I hope you can forgive any mistakes that I will make.

 

Getting started, keep in mind that this is a completely fresh install of P3D v2.5 and a newly generated Prepar3D.cfg with no changes made.

It is hard for me to describe what the actual problem is, other than the config looks very weird and much different than other people's P3D configs. Other peoples CFG's look much different and have more lines of code. They are also not pushed together like mine is. 

 

Below is my Prepar3D.cfg

 

 

I made sure that the paste did NOT alter the file in any way, this is the way it looks for me. 

If anyone knows what is going on here and how I can fix it, I would greatly appreciate a response.

Thanks

 

PC Specs: Intel Core i7-4790k @4.0Ghz
                 16GB of DDR3 Ram

                 AMD Radeon R9 290 (Yes I know it was a bad choice)

 

 

[Display]
ChangeTime=4.000000
TransitionTime=4.000000
TEXTURE_FILTERING=16
MSAA=8
SSAA=0
VSYNC=0
FXAA=1
TRIPLE_BUFFER=0
SKINNED_ANIMATIONS=1
TEXTURE_BANDWIDTH_MULT=30
UPPER_FRAMERATE_LIMIT=0
WideViewAspect=False
FullScreenExclusive=True
FullScreenAutoFill=True
ActiveWindowTitleTextColor=255,255,255
ActiveWindowTitleBackGroundColor=0,28,140,64
NonActiveWindowTitleTextColor=255,255,255
NonActiveWindowTitleBackGroundColor=24,33,87,64
InfoUpperRightTextColor=255,0,0
InfoUpperRightBackGroundColor=0,0,0,0
InfoLowerLeftTextColor=255,255,255
InfoLowerLeftBackGroundColor=255,0,0,128
InfoLowerRightTextColor=255,255,255
InfoLowerRightBackGroundColor=255,0,0,128
InfoBrakesEnable=True
InfoParkingBrakesEnable=True
InfoPauseEnable=True
InfoSlewEnable=True
InfoStallEnable=True
InfoOverspeedEnable=True
InfoWeaponSystemEnable=True
InfoCountermeasureEnable=True
FullScreen=False
[SCENERY]
POP_FREE_AUTOGEN=1
AUTOGEN_BATCH_LOD=2
AUTOGEN_TREE_MAX_DRAW_DISTANCE=9500.000000
AUTOGEN_TREE_MIN_DISTANCE_TO_LOD=2500.000000
IMAGE_COMPLEXITY=5
[Main]
User Objects=Airplane, Helicopter, Submersible, ExternalSim
LabelsSupported=Airplane, Helicopter
Location=440,129,1480,908,\\.\DISPLAY2
Maximized=2
HideMenuNormal=0
HideMenuFullscreen=1
[PANELS]
IMAGE_QUALITY=1
SAVE_AND_LOAD_PANEL_STATE=0
PANEL_OPACITY=100
PANEL_MASKING=1
PANEL_STRETCHING=1
UNITS_OF_MEASURE=0
QUICKTIPS=1
[Weather]
WindshieldPrecipitationEffects=1
MinGustTime=10
MaxGustTime=500
MinGustRampSpeed=1
MaxGustRampSpeed=200
MinVarTime=5
MaxVarTime=50
MinVarRampSpeed=10
MaxVarRampSpeed=75
TurbulenceScale=1.000000
WeatherGraphDataInDialog=0
AdjustForMagVarInDialog=1
DynamicWeather=1
DownloadWindsAloft=0
DisableTurbulence=0
CLOUD_DRAW_DISTANCE=5
DETAILED_CLOUDS=1
OPTIMIZE_DENSE_CLOUDS=0
CLOUD_COVERAGE_DENSITY=6
THERMAL_VISUALS=0
VolumetricFog=1
[CONTROLS]
Controls_Default=Standard
Controls_Current=Standard
KBDAIL=64
KBDELEV=64
KBDRUD=64
[TextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
[TextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
GForce=1,3
FuelPercentage=1,4
[TextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
WindDirectionAndSpeed=1,6
FrameRate=2,1
LockedFrameRate=2,2
GForce=2,3
FuelPercentage=2,4
[SlewTextInfo.1]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
[SlewTextInfo.2]
FrameRate=1,1
LockedFrameRate=1,2
[SlewTextInfo.3]
Latitude=1,1
Longitude=1,2
Altitude=1,3
Heading=1,4
AirSpeed=1,5
FrameRate=2,1
LockedFrameRate=2,2
[DynamicHeadMovement]
LonAccelOnHeadLon=-0.020000
LonAccelOnHeadPitch=-0.010000
RollAccelOnHeadLat=0.010000
YawAccelOnHeadLat=-0.100000
RollAccelOnHeadRoll=0.100000
MaxHeadAngle=5.000000
MaxHeadOffset=0.300000
HeadMoveTimeConstant=1.000000
[VirtualCopilot]
VirtualCopilotActive=0
[GRAPHICS]
MIPMAP_VC_PANELS=1
TESSELLATION=1
TEXTURE_MAX_LOAD=4096
NUM_LIGHTS=4
COCKPIT_HIGH_LOD=1
AIRCRAFT_REFLECTIONS=1
LANDING_LIGHTS=0
DAWN_DUSK_SMOOTHING=1
LENSFLARE=1
HDR=1
BLOOM_LEVEL=2
SHADOW_QUALITY=2
TERRAIN_SHADOW_CAST_DISTANCE=0
CLOUD_SHADOW_CAST_DISTANCE=0
OBJECT_SHADOW_CAST_DISTANCE=2
CONTENT_NO_SHADOW=0
INTERIOR_SHADOWS_CAST=1
EXTERIOR_SHADOWS_CAST=1
SIMOBJECT_SHADOWS_CAST=0
TERRAIN_SHADOWS_CAST=0
VEGETATION_SHADOWS_CAST=0
BUILDING_SHADOWS_CAST=0
CLOUD_SHADOWS_CAST=0
INTERIOR_SHADOWS_RECEIVE=1
EXTERIOR_SHADOWS_RECEIVE=1
SIMOBJECT_SHADOWS_RECEIVE=0
TERRAIN_SHADOWS_RECEIVE=1
VEGETATION_SHADOWS_RECEIVE=0
BUILDING_SHADOWS_RECEIVE=0
SHADOW_NUM_CASCADES_LOW=4
SHADOW_NUM_CASCADES_MID=5
SHADOW_NUM_CASCADES_HIGH=7
SHADOW_NUM_CASCADES_ULTRA=12
GROUND_SHADOW_TEXTURE_SIZE=2048
CLOUD_SHADOW_TEXTURE_SIZE=512
SHADOW_LOG_PARTITION_LOW=0.850000
SHADOW_LOG_PARTITION_MID=0.850000
SHADOW_LOG_PARTITION_HIGH=0.850000
SHADOW_LOG_PARTITION_ULTRA=0.850000
EFFECTS_QUALITY=2
EFFECTS_DISTANCE=2
TEXTURE_QUALITY=3
IMAGE_QUALITY=0
See_Self=1
Text_Scroll=1
[DISPLAY.Device.AMD Radeon R9 200 Series.0.0]
Mode=1920x1080x32
[DISPLAY.Device.AMD Radeon R9 200 Series.0.1]
Mode=1280x1024x32
[TrafficManager]
AirlineDensity=0
GADensity=0
FreewayDensity=20
ShipsAndFerriesDensity=0
LeisureBoatsDensity=0
IFROnly=0
AIRPORT_SCENERY_DENSITY=0
[AContain]
ShowLabels=1
ShowUserLabel=0
ShowLabelManufacturer=1
ShowLabelModel=1
ShowLabelTailNumber=0
ShowLabelDistance=1
ShowLabelAltitude=1
ShowLabelAirline=0
ShowLabelAirlineAndFlightNumber=0
ShowLabelFlightPlan=0
ShowLabelContainerId=0
ShowLabelAirspeed=0
ShowLabelHeading=0
LabelDelay=1000
LabelColor=FFFF0000
[TERRAIN]
LOD_RADIUS=6.500000
TESSELLATION_FACTOR=90
MESH_RESOLUTION=25
TEXTURE_RESOLUTION=29
AUTOGEN_VEGETATION_DENSITY=5
AUTOGEN_BUILDING_DENSITY=5
DETAIL_TEXTURE=1
WATER_REFLECT_CLOUDS=1
WATER_REFLECT_USERAIRCRAFT=1
WATER_REFLECT_SIMOBJECTS=0
WATER_REFLECT_TERRAIN=0
WATER_REFLECT_AUTOGEN_VEGETATION=0
WATER_REFLECT_AUTOGEN_BUILDINGS=0
WATER_REFRACT_CLOUDS=0
WATER_REFRACT_USERAIRCRAFT=0
WATER_REFRACT_SIMOBJECTS=0
WATER_REFRACT_TERRAIN=0
WATER_REFRACT_AUTOGEN_VEGETATION=0
WATER_REFRACT_AUTOGEN_BUILDINGS=0
ENABLE_BATHYMETRY=0
WATER_CLARITY=30
WATER_DETAIL=4
UseGlobalTerrainView=False
[ATC]
AutoOpenAirTrafficWindow=1
UsePilotVoice=1
PilotVoice=0
[INTERNATIONAL]
ASLAT=2
ASLON=1
MEASURE=0
[REALISM]
PFactor=1.000000
Torque=1.000000
GyroEffect=1.000000
CrashTolerance=1.000000
General=1.000000
UnlimitedFuel=False
AllowEngineDamage=False
TrueAirspeed=False
AutoCoord=False
RealMixture=True
StressDamage=True
GEffect=True
ManualLights=True
GyroDrift=False
CrashWithDyn=True
CrashDetection=False
OnCrashAction=0
AutoTrim=False
[ATTACHMENTS]
WeaponHighlight=False
HighlightDuration=1.000000
AutoWeaponSwitching=False
UnlimitedWeapons=False
UnlimitedCountermeasures=False
IgnoreAttachmentWeight=True
IgnoreAttachmentForces=True
[RECORDER]
RecordAITraffic=True
RecordAirportVehicles=True
RecordLeisureBoats=True
[SIM]
SYSCLOCK=0
OPTIMIZE_PARTS=0
[SOUND]
SOUND=1
SOUND_QUALITY=2
SOUND_LOD=0
PrimaryPlaybackDevice={DEF00000-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoicePlaybackDevice={DEF00002-9C6D-47ED-AAF1-4DDA8F2B5C03}
VoiceCaptureDevice={DEF00003-9C6D-47ED-AAF1-4DDA8F2B5C03}
[STARTUP]
DEMO=0
STARTUP_DEMO=
LOAD_SIMDIRECTOR=1
LoadWindow=1
[USERINTERFACE]
PAUSE_ON_LOST_FOCUS=0
PROMPT_ON_EXIT=1
SITUATION=C:\Users\Thomas Super GamerPC\AppData\Local\Lockheed Martin\Prepar3D v2\Prepar3D_Default
SHOW_SCENARIO_WINDOW=1
RestoreTimeOnMove=0
SHOW_MISSION_CAPTIONS=0
Map_Orientation=2
[PointOfInterestSystem]
CycleSetting=1
[FACILITIES]
COUNTRY=
STATE=
CITY=
GTL_BUTTON=4096
[Misc]
Com_Rate=7
[MULTIPLAYER]
condAccoutPassword=0

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

So, your issue is that your cfg file doesn't LOOK right? Does your p3d RUN right?

 

Delete the cfg file and let p3d build a new one.

 

Looks fine to me.

 

Vic

Share this post


Link to post

So, your issue is that your cfg file doesn't LOOK right? Does your p3d RUN right?

 

Delete the cfg file and let p3d build a new one.

 

Looks fine to me.

 

Vic

I have to agree with Vic. What exactly is the issue?

Share this post


Link to post

to just add this line processor

[Main]

FIBER_FRAME_TIME_FRACTION=0.005

Share this post


Link to post

to just add this line processor

[Main]

FIBER_FRAME_TIME_FRACTION=0.005

 

What???? [spills glass of chilled and falls off Sofa in disbelief!!!]

 

Your .cfg file looks fine kgriz but - whatever you do - DO NOT put that ridiculous FFTF addition anywhere near your .cfg file!!

Share this post


Link to post

What???? [spills glass of chilled and falls off Sofa in disbelief!!!]

 

Your .cfg file looks fine kgriz but - whatever you do - DO NOT put that ridiculous FFTF addition anywhere near your .cfg file!!

 

What's ridiculous about it?   That minor tweak works great for people using high end hardware though the .005 is just going to get ignored anyway.   It will read it as .10.   This has been discussed in many threads.   The FFTF is a valid tweak for getting 10-30% increase in FPS at the cost of sharp textures further from the plane.  In some cases, with a balanced setup, you won't see any texture distortion at all with this 'ridiculous' FFTF setting.   Given OP's choice of hardware, this tweak will help push at least another 5 FPS out of the sim in complex aircraft.

 

OP, the reason why your CFG doesn't look the same as many others is because we have all gone into our CFG files and separated the sections manually to make it more readable and manageable.   Default CFG always looks like a clumped together mess.

 

EDIT:  For the record, I use the FFTF tweak at a .10 setting (vs .33 default) and get another 8 FPS out of my sim in the PMDG 737NGX and my ground textures remain blur free.

Share this post


Link to post

I am sorry, I did not explain fully. I am trying to model-match with Vpilot. I have done the setup needed in VPilot but I need to add this to the CFG:

 

SimObjectPaths.9=SimObjects\IVAO_MTL

 

 

This (below) is supposed to be there already under the [Main] section of the cfg but it is not and adding it in doesn't do anything:

 
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\Submersible
SimObjectPaths.7=SimObjects\Weapons
SimObjectPaths.8=SimObjects\Countermeasures

Share this post


Link to post

Looks pretty normal to me. My default file looks quite similar.

 

Note that in P3Dv2.5 SimObject entries are now located as a seperate file in progdata.

Share this post


Link to post

I Can't thank you enough bakayoyo. I can now marked this as solved. Thanks everyone for your advice

 

Thanks again,

 

-Thomas

Share this post


Link to post

 

I am sorry, I did not explain fully. I am trying to model-match with Vpilot. I have done the setup needed in VPilot but I need to add this to the CFG:

 

SimObjectPaths.9=SimObjects\IVAO_MTL

 

 

This (below) is supposed to be there already under the [Main] section of the cfg but it is not and adding it in doesn't do anything:

 
SimObjectPaths.0=SimObjects\Airplanes
SimObjectPaths.1=SimObjects\Rotorcraft
SimObjectPaths.2=SimObjects\GroundVehicles
SimObjectPaths.3=SimObjects\Boats
SimObjectPaths.4=SimObjects\Animals
SimObjectPaths.5=SimObjects\Misc
SimObjectPaths.6=SimObjects\Submersible
SimObjectPaths.7=SimObjects\Weapons
SimObjectPaths.8=SimObjects\Countermeasures

 

 

Wait, I use vPilot and have never had to add any kind of SimObjectPath entry for it.   All aircraft matching should be done inside the vPilot client setup tool itself.   If it needs to add it it will do so itself but I don't remember seeing it there.   I have even made my open matching package out of other 3rd party AI packages using the VRM tool and still needed to do nothing inside the CFG file for it to take effect.

Share this post


Link to post

I just found this out from another user. Apparently in version 2.5 of p3d the 'SimObjectPaths" were taken out of the Prepar3D.cfg and moved to a whole new simobjects.cfg in C:\ProgramData\Lockheed Martin\Prepar3D v2. That was what was missing. Thank you guys so much for your help and suggestions, I can now mark this topic as solved. 

 

Best regards,

 

-Thomas

Share this post


Link to post

I am sorry, I did not explain fully. I am trying to model-match with Vpilot. I have done the setup needed in VPilot but I need to add this to the CFG:

 

SimObjectPaths.9=SimObjects\IVAO_MTL

 

 

This (below) is supposed to be there already under the [Main] section of the cfg but it is not and adding it in doesn't do anything:

 

SimObjectPaths.0=SimObjects\Airplanes

SimObjectPaths.1=SimObjects\Rotorcraft

SimObjectPaths.2=SimObjects\GroundVehicles

SimObjectPaths.3=SimObjects\Boats

SimObjectPaths.4=SimObjects\Animals

SimObjectPaths.5=SimObjects\Misc

SimObjectPaths.6=SimObjects\Submersible

SimObjectPaths.7=SimObjects\Weapons

SimObjectPaths.8=SimObjects\Countermeasures

 

P3Dv2 uses the simobjects.cfg file, rather than SimObjectPaths in the [Main] section of the .cfg, that's FSX.

 

C:\Users\All Users\Lockheed Martin\Prepar3D v2\simobjects.cfg

or

C:\ProgramData\Lockheed Martin\Prepar3D v2\simobjects.cfg

 

you maybe want an entry like this going by your post:

 

[Entry.9]

SimObjects\Path=IVAO_MTL

Share this post


Link to post

 

 


What's ridiculous about it? That minor tweak works great for people using high end hardware though the .005 is just going to get ignored anyway. It will read it as .10. This has been discussed in many threads. The FFTF is a valid tweak for getting 10-30% increase in FPS at the cost of sharp textures further from the plane.

 

It's ridiculous Brian for the very reason that it WILL be ignored. All that the OP would be doing is adding another spurious line of code to his .cfg file. Of course the FFTF tweak has it's Pro's and Con's (I use the .01 setting myself for the very reason that you stated), but I would suggest that he would be better advised to follow Vic's advice and solve his original problem with VPilot before he wanders off into the weird and wonderful Worlds af FFTF, AM et. al.  Once he has sorted that out satisfactorily then he can get as paranoid as the rest of us about the 'To tweak or not to Tweak' dilemma.  :D 

 

Cheers,

David. 

Share this post


Link to post

 

...Also it's possible some old addons intended for FSX and unconverted for P3D, may require old SimObjectPaths items placed in the [Main] section for reference, even though P3D would ignore them.

Share this post


Link to post

From what I have heard, I will be using the "FIBER_FRAME_TIME_FRACTION=0.005" as my first issue is now resolved. Thanks everyone for their time and support,

 

 

-Thomas

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this