Sign in to follow this  
YukonPete

World 2 Xplane making no difference?

Recommended Posts

So I installed world2xplane and followed the Quick start Guide for generating Switzerland. I downloaded and installed the required R2, FFLibrary and Open Scenery X.

 

I run the program and it generates the switzerland-latest folder and I place it in the X-Plane Custom Scenery folder. I then load X-plane and close it. I open the scenery_packs file and move the SCENERY_PACK Custom Scenery/switzerland-latest/ to below the Airports. I then reload Xplane and I don't see any difference whatsoever!

 

Any tips?

Thanks

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I have just done Vietnam, Malaysia, Thailand and Indonesia and I had exactly the same 'problem'. Cannot see any difference at all. So I too would be interested in an answer to this one.

Share this post


Link to post
Share on other sites

I did Switzerland, Alaska and Australia and got no changes! No extra building or roads.

Share this post


Link to post
Share on other sites

If there is no OSM data for the area then you get no output. It's pretty crummy here is the US as well.

Share this post


Link to post
Share on other sites

I've done Switzerland and it's well covered. Hmmm, have you got the latest world models folder (from the same site as the app) in your custom scenery folder and under the Switzerland-latest file in the .ini?

 

Just out of interest how long did it take to generate Switzerland? If you did it properly it should have taken several days.

Share this post


Link to post
Share on other sites

I've done Switzerland and it's well covered. Hmmm, have you got the latest world models folder (from the same site as the app) in your custom scenery folder and under the Switzerland-latest file in the .ini?

 

Just out of interest how long did it take to generate Switzerland? If you did it properly it should have taken several days.

Yes I do. I downloaded the files today.   And the world models folder is under the Switzerland-latest file in the .ini.

it took about 2 hours

Share this post


Link to post
Share on other sites

If there is no OSM data for the area then you get no output. It's pretty crummy here is the US as well.

This is what I've noticed as well - sucks

Share this post


Link to post
Share on other sites

I followed the Quick start Guide for generating Switzerland step by step so I don't understand why its not working! 

Share this post


Link to post
Share on other sites

Much easier to just download the w2xpl_Europe file and place that in the custom scenery folder.  All the work has already been done.  The w2xpl_Europe file covers all of Europe and really makes a difference in realism.

Share this post


Link to post
Share on other sites

Yes I do. I downloaded the files today. And the world models folder is under the Switzerland-latest file in the .ini.

 

it took about 2 hours

Something doesn't seem right with the generation if it only took a couple of hours. Luckily Tony, the author of W2XP is also the XP mod here so he'll be able to weigh in at some point.

Share this post


Link to post
Share on other sites

Regarding the order of entries in the ini file: I always thought that the libraries can be placed anywhere. Would it make a difference to put the world models over the w2xpl generated country-latest folder?

Share this post


Link to post
Share on other sites

Regarding the order of entries in the ini file: I always thought that the libraries can be placed anywhere. Would it make a difference to put the world models over the w2xpl generated country-latest folder?

No, all libraries are always called when needed. So their position in the ini file doesn't mean anything. Thier location in the sceneries folder only guarantees that they are inside of the search path.

Share this post


Link to post
Share on other sites

Please check your log file if there are any errors about missing scenery packs, and as stated, make sure you have all the libraries listed on the download page. 

 

Also, please post your scenery_packs.ini file. Switzerland is generally very good with OSM data, and should immediately see the difference.

Share this post


Link to post
Share on other sites

Message to Tony,

 

Hi Tony, apologies if I'm hijacking this thread, but any news on GB2 please?

 

Thanks

Phil Murfin

Share this post


Link to post
Share on other sites

It's been on the World2XPlane website for about 2 weeks now. I've called it GB Pro HD (as opposed to v2). The old version is also up there for less powerful computers.

Share this post


Link to post
Share on other sites

Just out of interest how long did it take to generate Switzerland? If you did it properly it should have taken several days.

 

Several days?

That sound very strange to me, which configuration file did you used?

Share this post


Link to post
Share on other sites

Something like Germany can take a long time, Switzerland generally takes about 2 or so hours for me. 

Share this post


Link to post
Share on other sites

Exactly, but we're speaking about hours, not days (2 hours for Switzerland for me too, if I recall correctly)... when I generate Italy at the maximum detail level usually it take 2/3 hours, I never tried Germany but I know that has much more user data so I'd estimate 5/8 hours of work so you must have a very slow computer, or a very strange configuration file, if you do need several days to generate a scenery.

 

@Scotchegg: let me say that's not a critic, I'm just trying to figure it out.

Share this post


Link to post
Share on other sites

I'm wondering if actually there might be something unusual in my W2XP generations. I'm doing one of southern U.S. now and it's taking days again (I mean several hours per day).

Share this post


Link to post
Share on other sites

I believe there's something definitively unusual.

You could try to download W2XP again putting it in a different folder and testing a short generation using default values, just to check timings... or maybe the problem is about OSM data, where and how do you get them?

Share this post


Link to post
Share on other sites

Very strange... but we're a little bit OT so I'd suggest you to open another thread so we can talk about that without hijack this one.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this