Sign in to follow this  
MarioDonick

X-Plane 10.45 beta 1 released: Torque bug finally fixed?

Recommended Posts

Laminar has released XP 10.45 beta 1.

 

Changelog (http://www.x-plane.com/?article=x-plane-10-45-release-notes)
 

Features for Beta 1:
  • Updated nav data from Robin
  • Vertical offset ratio available for external visuals
  • The “demo expired” popup now gives much more relevant advice. We look at what DRM sources you’ve unlocked from in the past (DVD, XDD, or USB stick) and tailor the “unlock the full version” message based on that.
Fixed for Beta 1:
  • C400 and C172 use new torque fix
  • AGBs:
  • Random spelling choice caused the shortest spelling to be picked, leaving blocks mostly empty
  • Neighbor-tile clip had wrong expression, causing trees to leak out
  • much better diagnostics and debugging
  • Selecting AI planes lets user pick livery (XPD-6090)
  • Synchronized all clutches if a pre-rotate button is present on the panel (XPD-6083)
  • transponder does not blink when transponder powered off or broken (XPD-6062)
  • Autogen trees are varied (XPD-4742)
  • If the pilot log file is never loaded due to an early exit due to an update, do not write the pilot log out on quit or we lose all pilot log entries (XPD-6141)
  • Fix GPS teardrop holding entry into left-hand (non-standard) holdings when inbound course (XPD-6142)
  • Prop torque was doubled in all propeller airplanes (not helos or vtols)
  • We now advise the user to check their net connection where appropriate (XPD-6124)
  • On first launch of the map window, we now show the current airport ID (XPD-6138)
  • Massive performance improvement with GPS map display: For anything else but the default 35nm range, the airspace warning would trash the airspace cache of the map. Now we cache up to four bounding boxes full of airspaces. That allows for two screens with different size settings, and two airspace warners.
  • Wrong heading cue from G430 (XPD-6041)
  • Airport sorting performance in GPS (XPD-6131)
  • Using a separate IOS with AI planes enabled no longer resets user’s aircraft randomly
  • Require an object to be reloaded with dynamic polygons if client requests it and the object cache has no dynamic polygons. This ensures the if the scenery engine gets to the Nimitz before the boat code does, we get our hard triangles when we need them. (XPD-4844)
  • Fixed demo timing out immediately
  • Plane-Maker finds the objects/ folder for airplanes in a case-insensitive manner
  • manual extension pump gear and flaps were mixed up
 

Ben wrote about it here:
 
http://developer.x-plane.com/2015/12/x-plane-10-45-beta-1-released/
 

The torque fix gets applied once you open and then re-save your aircraft file (.acf) in PlaneMaker 10.45. 

Now all developers who applied custom methods for countering torque (such as Carenado in their really big fleet) will have a "funny" time, because they need to re-evaluate and maybe change or remove their measures once XP 10.45 is final.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

At last....

 

IMHO, they should have written a "THANK YOU SO MUCH" note on that list addressed to "Murmur" for the dedication and excellent work that he took to find out that "bug".

 

It's also worth remembering how so many users and even worst - aircraft designers - fought the evidence of there being a torque bug, introduced somewhere along XP9, and kept presenting all kinds of silly and  void justifications for the behavior other users ( some of them with RL flying experience, sometimes LONG RL flying experience!!! ) were pointing out.

 

So many words and threads lost on this topic :-/

 

Time for them to start a new search for what is SO WRONG with ground handling in XP10, particularly that totally unplausible weathervane.... A wind of 5 knot causing so much of a veer to our taxiing aircraft, and on the cosmetics side... that awful screech sound...

 

For users of the Carenado aircraft, the fix is simple - just commenting a couple of lines in one of the LUA scripts, while Dan goes through the tedious task of updating his aircraft fleet....

 

For Mu-2J users, where a default aileron roll trim was always automatically set, and it's done in gizmo, I guess, it'll be a bit more complicated...

 

The LES dc-3 will probably become even more a charm to fly... 

  • Upvote 4

Share this post


Link to post
Share on other sites

Random spelling choice caused the shortest spelling to be picked, leaving blocks mostly empty

So happy they fixed this, this is one the main reason I started to give up with my Norway Pro scenery. Basically, the autogen was always choosing the smallest area which fits into an area causing exactly as this bug says, lots of empty spaces and repetition.

Share this post


Link to post
Share on other sites

So happy they fixed this, this is one the main reason I started to give up with my Norway Pro scenery. Basically, the autogen was always choosing the smallest area which fits into an area causing exactly as this bug says, lots of empty spaces and repetition.

 

I actually have no idea what this fix is about. Does this mean autogen should look more varied?

Share this post


Link to post
Share on other sites

I actually have no idea what this fix is about. Does this mean autogen should look more varied?

If I'm reading it correctly then yes. When I was making Norway I created a set of residential style blocks with various buildings however XP would only place the smallest building everywhere and I couldn't work out why. When placing the autogen, XP is meant to choose the best fit out of a random list of "Spellings", however it always seemed to choose just one of them instead, causing repetition. If one of the autogen spellings was a small space, then this would be repeated over and over again because it was the smallest area.

Share this post


Link to post
Share on other sites

If I'm reading it correctly then yes. When I was making Norway I created a set of residential style blocks with various buildings however XP would only place the smallest building everywhere and I couldn't work out why. When placing the autogen, XP is meant to choose the best fit out of a random list of "Spellings", however it always seemed to choose just one of them instead, causing repetition. If one of the autogen spellings was a small space, then this would be repeated over and over again because it was the smallest area.

 

Ah, very interesting! If have not checked this yet, but in combination with HD mesh v3 this would even make default autogen look much better, I suppose.

Share this post


Link to post
Share on other sites

So how is the torque now? 

 

I tried a few props after saving them in PlaneMaker, at least for the moment I am not noticing the roll.

Share this post


Link to post
Share on other sites

So how is the torque now? 

 

I saved our vFlyteAir SR20 in PlaneMaker 10.45b1, but did not notice any difference.

Share this post


Link to post
Share on other sites

Maybe any of the counter-rotating prop or other fixes were used before already ?

Share this post


Link to post
Share on other sites

Maybe any of the counter-rotating prop or other fixes were used before already ?

 

If your question is related to my note: No, the SR20 doesn't have any torque/prop-related fixes. Anyway, if now many users confirm that with other aircraft the 10.45b1 does indeed fix torque, the problem might be the SR20, not X-Plane. We'll see. (Edit: Actually nobody has complained about too much torque with the SR20. But still.)

Share this post


Link to post
Share on other sites

I'm not getting the beta update, the installer won't show it, the X-Plane splash screen won't notify the update nor the about dialog box. Is this update being rolled in stages?

Share this post


Link to post
Share on other sites

 

The LES dc-3 will probably become even more a charm to fly... 

 

That one may require an update by LES, since I don't think the DRM method they use will authorize the .acf if you load the model into Planemaker and save it.

 

I could be wrong about that, but I think I remember trying that once to make an adjustment and it didn't work.

Share this post


Link to post
Share on other sites

I'm not getting the beta update, the installer won't show it, the X-Plane splash screen won't notify the update nor the about dialog box. Is this update being rolled in stages?

 

Have you marked "check for betas"?

 

If yes, try redownloading the installer.

Share this post


Link to post
Share on other sites

Have you marked "check for betas"?

 

If yes, try redownloading the installer.

Hi Mario,

Yes beta is marked, however I'm going to redownload the installer. Curious is that at X-Plane startup I don't get the message box for getting the new beta or the about box saying that X-Plane is up to date.

Many thanks,

Share this post


Link to post
Share on other sites

I'm not getting the beta update, the installer won't show it, the X-Plane splash screen won't notify the update nor the about dialog box. Is this update being rolled in stages?

Make sure you grab the latest installer from their website http://www.x-plane.com/downloads/x-plane_10_installer-updater/

 

Also, make sure you have check box selected for betas

Share this post


Link to post
Share on other sites

For users of the Carenado aircraft, the fix is simple - just commenting a couple of lines in one of the LUA scripts, while Dan goes through the tedious task of updating his aircraft fleet....

 

 

 

 

How is this done, or should we just wait?

Share this post


Link to post
Share on other sites

Hmmmm, I don't have X-Plane installed .. :-/ and I trashed all of my guides for it ....

Share this post


Link to post
Share on other sites

I am going to wait on the update until I find that fps have not changed for some users. 

Share this post


Link to post
Share on other sites

FPS haven't changed here for me, it's just as good as the last version

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this