Jump to content

Sign in to follow this  
Denco

Stuttering problem

Recommended Posts

After a while of switching from fsx to Xplane I finally decided to do a flight from a more demanding scenery, I was flying in Slovenia and its neighboring countries for a while now getting used to X plane. I started from London City and wanted to just fly around before I land.

 

The framerate on take off were good, a roundish 26, which in my opinion was great considering the scenery I was in. After takeoff the frames dropped to 20 - 22 so I lowered my objects number to "tons", it was set to "too many" since I had more than 30 fps in my previous flights. Anyway I didn't lowered my objects setting because of fps I lowered it because of horrific stuttering which didn't went away after I decrease my object setting or even after the frames picked up to 30 to 50. I had to move quite a distance from the scenery before the fluidity returned to as it was before.

 

I'll link my settings bellow and I also want to mention that I have Nvidia's threaded optimization turned off since I heard it reduces stuttering. My rig is in my signature.

iBibTad.png

 

Any advice on this? It wasn't the lack of ram or Vram since ram usage was around 6000MB and Vram usage was 2400MB. I don't believe too high settings were the culprit considering the stuttering continued even after the fps was way above 30.

 

EDIT: 

Addons I use

SkyMaxx Pro ( altough no clouds were present in my flight )

Real Weather Connector


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites

I never use cloud detail above 25 %.

 

For the shadows I use only "overlay"

 

For HDR AA - 4x SAA and in NI I set:

 

Triple buffering: OFF

Vertycal Sync: 1/2  refresh Rate

Antialiasing mode: enhance app sett

Antialiasing: 4x MS

AA Transparency: 2x SGSS

 

AF mode: App controlled

Texture filtering negative LOD bias: Clamp

Quality: High Performance

Power management mode: Prefer maximum performance

Multiple display: single display ( I have only 1 monitor )

Threaded Optimization: OFF


I will believe in MFS the day I can Uninstall it !

Share this post


Link to post
Share on other sites

After a while of switching from fsx to Xplane I finally decided to do a flight from a more demanding scenery, I was flying in Slovenia and its neighboring countries for a while now getting used to X plane. I started from London City and wanted to just fly around before I land.

 

The framerate on take off were good, a roundish 26, which in my opinion was great considering the scenery I was in. After takeoff the frames dropped to 20 - 22 so I lowered my objects number to "tons", it was set to "too many" since I had more than 30 fps in my previous flights. Anyway I didn't lowered my objects setting because of fps I lowered it because of horrific stuttering which didn't went away after I decrease my object setting or even after the frames picked up to 30 to 50. I had to move quite a distance from the scenery before the fluidity returned to as it was before.

 

I'll link my settings bellow and I also want to mention that I have Nvidia's threaded optimization turned off since I heard it reduces stuttering. My rig is in my signature.

iBibTad.png

 

Any advice on this? It wasn't the lack of ram or Vram since ram usage was around 6000MB and Vram usage was 2400MB. I don't believe too high settings were the culprit considering the stuttering continued even after the fps was way above 30.

 

EDIT: 

Addons I use

SkyMaxx Pro ( altough no clouds were present in my flight )

Real Weather Connector

 

Try rebooting windows, that seems to work sometimes. Water reflections is a frame killer for me. World distance is a frame hog too, I have mine set to medium and it looks good enough. Try that and see how that works and you might be able to bring the number objects back up !


AMD Ryzen 7 1800x, 1080GTX, Ram - 32GB, 32" 4K Monitor, WIN 10, XP-11 !

Eric Escobar

Share this post


Link to post
Share on other sites

Denco

The most important "Tweak" for me regarding X-Plane is to turn OFF Threaded Optimization in the nVidia control panel. I think you will find that stuttering will be a thing of the past.  I updated my video drivers a while ago and the stuttering was back until I remembered to do this again.

All the best.

Dennis


Dennis Elliott
 

Share this post


Link to post
Share on other sites

I never use cloud detail above 25 %.

 

For the shadows I use only "overlay"

 

For HDR AA - 4x SAA and in NI I set:

 

Triple buffering: OFF

Vertycal Sync: 1/2  refresh Rate

Antialiasing mode: enhance app sett

Antialiasing: 4x MS

AA Transparency: 2x SGSS

 

AF mode: App controlled

Texture filtering negative LOD bias: Clamp

Quality: High Performance

Power management mode: Prefer maximum performance

Multiple display: single display ( I have only 1 monitor )

Threaded Optimization: OFF

With SkyMaxx Pro having clouds detail set to 50% brings minimal fps loss. At least on my system. 

 

Try rebooting windows, that seems to work sometimes. Water reflections is a frame killer for me. World distance is a frame hog too, I have mine set to medium and it looks good enough. Try that and see how that works and you might be able to bring the number objects back up !

I think I'll play around with the world distance setting. Its a shame though since the sim is running smoothly otherwise.

 

Denco

The most important "Tweak" for me regarding X-Plane is to turn OFF Threaded Optimization in the nVidia control panel. I think you will find that stuttering will be a thing of the past.  I updated my video drivers a while ago and the stuttering was back until I remembered to do this again.

All the best.

Dennis

Threaded optimization is off.


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites
Here's what I'd recommend with that as your current settings:

 

1) Change framerate-lock so it isn't locked to monitor refresh rate. I read on one of the dev blogs that when X-Plane can't manage as many frames as the monitor refresh, it cuts the FPS by a fixed amount of 50%. I get higher FPS without this setting.

 

2) Number of objects and roads is a frame-killer. Scale it way back, and then sneak back up on it gradually to find the optimal setting for your system.

 

3) I'd also recommend reducing anisotropic filter way back. You probably won't notice any real reduction in quality except near the far horizon.

 

4) Reduce cloud puffs to 20-25%. That sounds low, but the actual visual effect isn't greatly diminished at lower settings (this may have less effect with SkyMaxx Pro installed; it's pretty efficient).

Primary sim is X-Plane 11 on Windows 10
i7 6700 4.0 GHz, 32 GB RAM, GTX 1660 ti, 1920x1200 monitor

Share this post


Link to post
Share on other sites

 

Here's what I'd recommend with that as your current settings:
 
1) Change framerate-lock so it isn't locked to monitor refresh rate. I read on one of the dev blogs that when X-Plane can't manage as many frames as the monitor refresh, it cuts the FPS by a fixed amount of 50%. I get higher FPS without this setting.
 
2) Number of objects and roads is a frame-killer. Scale it way back, and then sneak back up on it gradually to find the optimal setting for your system.
 
 

 

1) Didn't know that thx. Don't really have fps issue, compared to fsx, but a gain is a gain nevertheless :)

 

2) http://developer.x-plane.com/2016/03/the-autogen-is-really-fast/

 

EDIT:

 

I'll try decreasing shadow and reflections quality. 


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites

1) Didn't know that thx. Don't really have fps issue, compared to fsx, but a gain is a gain nevertheless :)

 

2) http://developer.x-plane.com/2016/03/the-autogen-is-really-fast/

 

EDIT:

 

I'll try decreasing shadow and reflections quality. 

I actually have Cloud Puffs set at minimum, around 10%....massive performance increase but no real loss as Skymaxx controls the output.

 

I am no expert, but I got the tip from a few videos and also the Skymaxx forums.


Will Reynolds

 

Flight Sim Addict

 

Posted Image

Share this post


Link to post
Share on other sites

Reduce Number of Cars to Siberia, that is a killer when flying big cities. Also I see you have 8g of ram, why not use Extended DFS?


Carlos Franklin

Sims: XPlane

Asus Sabertooth z77 - i7 3770k @ 4.6 HT WC - 32gb Corsair @ 2133 (XMP) - Asus GTX 1070 - 250 Evo Pro SSD for Win10 Pro - 500 Evo Pro SSD for XP11

 

Share this post


Link to post
Share on other sites

Ehehe, even better - use no AV software at all ! Well, I have the default protection that comes built in in Windows 10 ... More than enough, and a scan with Malwarebytes from time to time...


I will believe in MFS the day I can Uninstall it !

Share this post


Link to post
Share on other sites

I've lowered my "Number of Roads" to default and "Detail level" to Medium and lowered my AA to FXAA only. I now get 35+ fps leaving london city, but the stutters are still present. Just not so severe. I've also added Xplane to my exclusion list in my AA.

 

YCH372b.png

 

So I've come to conclusion that stutters are not caused by too high settings. Something else must be at play here. Are there official forums for xplane? Maybe I should try their support.


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites

 

 


I now get 35+ fps

 

Denco, assuming you have a 60Hz monitor, have you tried to lock-frames to 1/2 of monitor's refresh?


Carlos Franklin

Sims: XPlane

Asus Sabertooth z77 - i7 3770k @ 4.6 HT WC - 32gb Corsair @ 2133 (XMP) - Asus GTX 1070 - 250 Evo Pro SSD for Win10 Pro - 500 Evo Pro SSD for XP11

 

Share this post


Link to post
Share on other sites

Denco, assuming you have a 60Hz monitor, have you tried to lock-frames to 1/2 of monitor's refresh?

My monitor is 120Hz. I'll try 1/4 and let you know.

 

EDIT: Wait locking my fps by 1/2 and 1/4 will give me fps lock of 30, correct? If so I'll still try it but its not a solution. I prefer higher frame rate.


ASUS Maximus VIII Hero Alpha

Intel Core i7 6700K 4.5GHz

Corsair Vengeance Black LPX 32GB

Asus STRIX GTX 1080

Samsung 850 EVO 500GB SSD

Share this post


Link to post
Share on other sites

Are there official forums for xplane?

x-plane.org is probably the most frequented forum. It is not an official forum (there is none), but I guess seen as semi-official by many.


Mario Donick .:. vFlyteAir

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

×
×
  • Create New...