Sign in to follow this  
WebMaximus

TrackIR5 not working in P3D

Recommended Posts

I was forced to wipe my PC and now with a fresh installation of the latest P3D my TIR5 doesn't recognize P3D running.

 

Anyone else experienced this?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Did you remember to update the game definitions in the TrackIR software?

Share this post


Link to post

Yep, I sure did and also I'm running both P3D as well as TIR as admin and I have all the recommended versions of SimConnect installed.

Share this post


Link to post

Yes, I'm using the drivers that come with version 5.4.2.27545 and I don't use EZDOK or any other software that would interfere with TIR. This is a clean installation and up to this point the only things installed are P3D, the NGX and FSUIPC.

 

I've tried uninstalling the TIR hardware followed by the x64 drivers as well as the TIR software and I then unplugged my TIR device and restarted my PC. After that I manually removed any traces of TIR both from my file system as well as from the registry. Then I rebooted my PC again and after that I reinstalled the latest version of the TIR software still with the TIR device unplugged and once the drivers and software were both installed again I reconnected the TIR device.

 

However I'm pretty sure this is not a connection problem of any kind since the TIR device is working just fine. It's only in P3D it doesn't work and only the leftmost green LED comes on rather than both the left and the right LED which normally would let you know an enhanced game title has been recognized.

 

I read over in NaturalPoint's support forum about some guys who solved the problem by renaming Prepar3D.exe to P3D.exe and claimed that fixed the problem but then some other guys said that still didn't fix the problem for some of them so I don't know really. I'm not very tempted to start messing around by renaming stock LM files and especially not after just having performed a clean installation of my PC. I do intend to keep it as clean as possible like I always try to.

 

Right now I really don't have a clue how to solve this problem so until I hear back from NP's support team because I also created a ticket I guess I'll just have to give myself a chance to remember what it's like to fly without TIR...

Share this post


Link to post

Have you tried starting up TrackIR first and then P3D? I used to start P3D first, but after install P3DV3 I could not get TrackIR to recognize P3D, untill I accidentally changed the order, and then it worked! Hope it does for you to.

Share this post


Link to post

1. Make sure you have the latest Track IR software version installed or (if frustrated, determined or vengeful :) ) reinstall if you wish.

 

2. Make sure the unit is plugged in and proper selections made.

 

3. Run, as administrator all the simconnect variants found in your Prepared 3D 3.3.5 (or whatever) / Redist file.

 

4. Restart computer.

 

5. Start Track IR as administrator and set up accordingly.

 

6. Run P3D 3.35 ( or whatever) as administrator.

 

7. Make sure you stick your head with device nailed, glued or otherwise attached in front of Track IR camera.

 

8. Enjoy!

 

9. (optional) If it all works, send me a new 1080 GTX in profound gratitude! :) 

 

This should work every time.

Share this post


Link to post

When you have TIR running with it's display showing and you then start P3d - does the TIR screen disappear? I would assume not, since it only does that when it connects to P3D. Now, leaving P3D running, what happens if you manually try to shut down TIR? Does it hang or close.

 

I ask because I get this happening on occasion. 

 

If it hangs and you can't close it - open task manager and delete the TIR process. Then restart TIR and as soon as the dialog appears, shut it down - you should get the closing clients message - now restart TIR. - see if that works

 

Second scenario - TIR connects but noting moves - strangely enough I've found that blocking the sensors on and off seems to shake it up and it starts to work.

 

Worth a try.

 

Vic

Share this post


Link to post

Finally found the culprit being me starting P3D as admin. Before this I've tried running TIR both as admin and not but I never tried to not run P3D as admin and apparently this was causing the issue.

 

Really strange though since I always had P3D running as admin in the past without any issues with TIR.

 

Oh well, honestly I don't even recall why I was always running P3D as admin but guess it was a recommendation/requirement I read somewhere or was told.


Forgot to say thanks for trying to help me out guys :drinks:

Share this post


Link to post

 

 


Finally found the culprit being me starting P3D as admin. Before this I've tried running TIR both as admin and not but I never tried to not run P3D as admin and apparently this was causing the issue.

 

Running P3D as Admin caused the problem?? o.O  That's weird. 

  • Like 1

Share this post


Link to post

Running P3D as Admin caused the problem?? o.O  That's weird.

 

Yep, couldn't agree more.

Share this post


Link to post

Running P3D as Admin caused the problem?? o.O  That's weird. 

 

Yep, I had the same problem a while back with Prepar3D and TrackIR. Sure enough the solution was a simple at just "Run As Administrator". Glad that the fix was that easy.

Share this post


Link to post

Strange indeed, but happy that it works now for you

Share this post


Link to post

Just checked my installation: I run both TrackIR (v5.4.1) and Prepar3d.exe as Administrator.

Share this post


Link to post

Just checked my installation: I run both TrackIR (v5.4.1) and Prepar3d.exe as Administrator.

 

Yeah, that's how I used to have it as well until I had to wipe my PC and do a clean reinstall.

 

Very strange how it's not working running as admin since it's usually the other way around.

Share this post


Link to post

Yep, I had the same problem a while back with Prepar3D and TrackIR. Sure enough the solution was a simple at just "Run As Administrator". Glad that the fix was that easy.

 

I think you didn't read his post properly... for him the solution was to *NOT* "run as administrator"... so the opposite of your case.

Share this post


Link to post

I just experienced the exact same issue with TrackIR and P3d V3.4. After working correctly ever since I got this computer, all of a sudden today TrackIR would just stop responding via SimConnect in the middle of a flight (both green lights stayed on). TrackIR was still working correctly when viewed in the TrackIR app. I reinstalled all the SimConnect versions again and did a clean reinstall of the TrackIR software and that seemed to fix everything. I'm using the most recent version of the TrackIR software 5.4.2.

Share this post


Link to post

Jay is correct. On a fresh system without FSX Boxed installed we only have ESP simconnect installed with P3D. If we intend to use addons from the FSX era we must install the three legacy simconnects 60905, 61242, and 61259.

Share this post


Link to post

I only installed the SimConnect from "redist\Interface\FSX-SP2-XPACK" and I have no problem with TrackIR or other software.

Share this post


Link to post

Yes that's the one TIR uses. But you may come across other addons that use 61242 and even 60905. You'll see popular addon devs recommending you install all three, like PMDG.

 

The addon version is not an age thing it's a compatibility thing. 61242 works with all versions of FSX so many addons use that, but 61259 only works with SP2 so addons can work on P3D and FSX:SE by utilising 61259.

  • Like 1

Share this post


Link to post

I only installed the SimConnect from "redist\Interface\FSX-SP2-XPACK" and I have no problem with TrackIR or other software.

This also immediately solved my problem of Track IR 5 not connecting with P3d v4.
The path to get there is:
Prepar3d v4 / redist / Interface / FSX-SP2-XPACK / retail / lib
then click execute the file: SimConnect.exe
 
and BINGO, it worked.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this