Sign in to follow this  
marospy

nVidia Inspector cannot override FSX settings

Recommended Posts

Hello,

 

I have a bit of an issue with my FSX:SE and I hope someone can help me with it.

So basically I'm trying to override FSX:SE Filtering and Anti-Aliasing settings using nVidia Inspector as described here
http://www.avsim.com/topic/324786-nvidia-configuration-guide-inspector-2xxxx-drivers-version-20-explanations-of-all-settings/

However I'm not sure if the settings are being applied correctly or not. The reasons why I think the settings are being applied is because when I set the frame limiter to 30.5 it works.

But when I set the Anisotropic filtering using nVidia Inspector and turn it off in FSX there is no filtering happening.

Here is a picture of my nVidia Inspector settings
nvidia_set.jpg

 

and here is my FSX settings

 

fsx_set.jpg

 

and here is a picture from inside FSX

 

fsx_pic.jpg

 

It is clear than no kind of filtering was done, and to my understanding that FSX settings should be overwritten.

Hope some knows the solution to this.

Thanks in advance.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

It looks like, in your picture of Nvidia Inspector, your setting for  Anisotropic Filtering Mode is "User Defined"

 

and set to the OFF position.

Share this post


Link to post
Share on other sites

It looks like, in your picture of Nvidia Inspector, your setting for  Anisotropic Filtering Mode is "User Defined"

 

and set to the OFF position.

Ops , I took a picture for the wrong settings here are the FSX settings.

 

Capture.jpg

 

However, the setting for Anisotropic Filtering is actually correct, "User Defined / Off" to my understanding simply means override FSX settings.

 

Can you post your settings ?

Share this post


Link to post
Share on other sites

The proper fsx setting for filtering is Triliniar in the fsx menu and the user defined and 16x as you have is correct in the NI menu.

 

You also want to uncheck anti aliasing in the fsx menu and set it up via the same as the link you posted.

Share this post


Link to post
Share on other sites

I notice that your profile is for MS Flight simulator X.  I have the same version of Nvidia Inspector and that profile doesn't exist.  In mine I have Microsoft Flight Simulator 10.  Is it possible that you have two conflicting versions.  Also your Antialiasing -Mode and Antialiasing - Setting should not be Application Controlled. Set the moded to Override any application setting and pick the setting of your choice, I use 16xS [Combined: 2x2 SS + 4x MS]

 

In FSX Antialiasing should be unchecked and filtering should be Trilinear.

Share this post


Link to post
Share on other sites

The proper fsx setting for filtering is Triliniar in the fsx menu and the user defined and 16x as you have is correct in the NI menu.

 

You also want to uncheck anti aliasing in the fsx menu and set it up via the same as the link you posted.

Why does FSX has to be set to Trilinear if it will be overwritten anyways ?

Share this post


Link to post
Share on other sites

Why does FSX has to be set to Trilinear if it will be overwritten anyways ?

I do not have the answer I am going by what NickN has said at simforums he writes the fsx bible. Some developers like MajesticSoftware recommend also to set Trilinear in the fsx menus they have said in their testing sometimes graphics bugs can occur with any other setting than Trilinear. The Nvidia Inspector overwrites this by using 16x AF.

Share this post


Link to post
Share on other sites

I do not have the answer I am going by what NickN has said at simforums he writes the fsx bible. Some developers like MajesticSoftware recommend also to set Trilinear in the fsx menus they have said in their testing sometimes graphics bugs can occur with any other setting than Trilinear. The Nvidia Inspector overwrites this by using 16x AF.

I am quite sure NickN wrote somewhere It doesn't matter however his reasoning is that you will be able to detect if nVidia Inspector stopped working as you have low settings inside FSX.

 

Anyhow I solved my problem, some guy on reddit pointed that the new nVidia drivers are not compatible with FSX and nVidia Inspector, I gave it a try and rolled back my driver and it worked.

 

Thanks for your help.

Share this post


Link to post
Share on other sites

Update : It's working with the new drivers, I was doing something wrong.

Cheers.

Share this post


Link to post
Share on other sites

Anyhow I solved my problem, some guy on reddit pointed that the new nVidia drivers are not compatible with FSX and nVidia Inspector,

 

I don't think that's true.  I'm using the 368.39 driver and all is well.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this