Sign in to follow this  
2811520112gh

P3D v3.4.9.18400 Crash/Error

Recommended Posts

To whom it may concern,

 

I write this, because I'm running with new P3d, all is ok working, except for that p3d stop working after a short flying time. This happens almost every time I fly!!

PC: Intell I7 core 4.2 Ghz, Hard drives all SSD, 32 Gb ram, 2 x Nvidia Gtx Titan Black.

I have to say, that I updated my P3d v 3.3.5 Using the client installer, as this said to be ok!

Also to be said, that this problem also occurred with the old version, but not that often as now! 

 

I continuously having below error after 25 - 40 minutes of flying:  

 

Log Name:      Application
Source:        Application Error
Date:          10/1/2016 2:36:56 PM
Event ID:      1000
Task Category: (100)
Level:         Error
Keywords:      Classic
User:          N/A
Computer:      geertholgersen
Description:
Faulting application name: Prepar3D.exe, version: 3.4.9.18400, time stamp: 0x57d9b14e
Faulting module name: ntdll.dll, version: 10.0.14393.206, time stamp: 0x57dacde1
Exception code: 0xc0000374
Fault offset: 0x000d9841
Faulting process id: 0x25d4
Faulting application start time: 0x01d21bd7707dd76d
Faulting application path: E:\Prepar3D_v3_Academic_3.3.5.17625\Prepar3D.exe
Faulting module path: C:\WINDOWS\SYSTEM32\ntdll.dll
Report Id: dc919368-006a-4ede-946d-6b1bbe1decb2
Faulting package full name:
Faulting package-relative application ID:
Event Xml:
<Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
  <System>
    <Provider Name="Application Error" />
    <EventID Qualifiers="0">1000</EventID>
    <Level>2</Level>
    <Task>100</Task>
    <Keywords>0x80000000000000</Keywords>
    <TimeCreated SystemTime="2016-10-01T12:36:56.861906100Z" />
    <EventRecordID>820</EventRecordID>
    <Channel>Application</Channel>
    <Computer>geertholgersen</Computer>
    <Security />
  </System>
  <EventData>
    <Data>Prepar3D.exe</Data>
    <Data>3.4.9.18400</Data>
    <Data>57d9b14e</Data>
    <Data>ntdll.dll</Data>
    <Data>10.0.14393.206</Data>
    <Data>57dacde1</Data>
    <Data>c0000374</Data>
    <Data>000d9841</Data>
    <Data>25d4</Data>
    <Data>01d21bd7707dd76d</Data>
    <Data>E:\Prepar3D_v3_Academic_3.3.5.17625\Prepar3D.exe</Data>
    <Data>C:\WINDOWS\SYSTEM32\ntdll.dll</Data>
    <Data>dc919368-006a-4ede-946d-6b1bbe1decb2</Data>
    <Data>
    </Data>
    <Data>
    </Data>
  </EventData>
</Event>

 

This don't help me, as I have no Idea what to do with this report. So my hope is, that some body out there, may have the answer to this problem.

 

Thanks for Your help.

Regards

Geert Holgersen - DK

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

OK, I'm running a system scan now to se if that can leed me to the problem.

But I don't think so - hi, Not many answers to this problem with p3d.

Let's se if there will come other answers to this topic. Will revert.

 

rgds

Geert

Share this post


Link to post
Share on other sites

I had an ntdll error go away when I ran the FSDT stand alone AddOnManager installer, which updates couatl.exe.  This happened when I updated to v3.4 and hasn't been a problem since. Might not be related but it's an easy check if you have either FDST or Flightbeam scenery.

Share this post


Link to post
Share on other sites

I've had several ntdll crashes, but they are random and I am unable to replicate them. Last 5 flights have been trouble free, and I haven't done anything to the sim before or after. Strange, but that's how it goes. I save often during my flights just in case. 

 

Also I had a period with blurry textures that suddenly disappeared - also without me doing anything knowingly with the sim to solve it. Now it just works... 

Share this post


Link to post
Share on other sites

See the AVSIM CTD Guide regarding the ntdll.dll error (link in my signature).

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

 

 


Thanks for Your help.
Regards
Geert Holgersen - DK

 

Are you running any 3rd party AI traffic schedules, like for example, My Traffic 6?

Share this post


Link to post
Share on other sites

Hello again,

Thanks for all Your replies, to my topic abt p3d CTD.

Yes I'm running all ORBX/FTX, GSX, and My traffic pro. And of course a lot of diff. aircraft's.

Ben looking into the CTD guid, as suggested from Jim. But honestly, it didn't help me, as there seems to be so many different answers to the CTD, so one almost give up  before started - hi.

 

However, I got  another idea, that's the many different Microsoft Visual's, that we seems to work with.

One is the MS visual 2010, seem to have some impact to all scenery. 

I deleted visual 2010, and discovered that I now had a lot of new buildings i the large cities.

and I got with of the CTD in many places, but I have to work some more with this, before I can make

a conclusion on this. But I wondering why I got more buildings pupping up now?

I find this very interesting, and will continue my investigation and run a lot more test's.

So left working on my pc is ms visual 2012 -   2013 - 2015 -(x64 and x86).

 

I may crazy!!! But I think I'm up to something - hi

 

Regards  Geert

Have a nice weekend :dance:

Share this post


Link to post
Share on other sites

Geert,

 

The ntdll.dll error is often eliminated by renaming the My Traffic 6 military traffic BGL file, which is located in the My Traffic scenery folder. Just change its qualifier from .Bgl to .Bgl.Orig.

 

Your observation regarding the Visual C++ 2010 runtime is quite interesting, but unfortunately I have no explanation as to why you observed that result. Did uninstalling the 2010 version not only lead to more autogen buildings being visible, but did it also stop the ntdll.dll error?

 

Jay

Share this post


Link to post
Share on other sites

 

 


One is the MS visual 2010, seem to have some impact to all scenery.
I deleted visual 2010, and discovered that I now had a lot of new buildings i the large cities.

 

P3D does not use Microsoft Visual 2010.  Maybe some addon's to P3D might.  More buildings might have appeared as you have stuff stored in memory and, when you restarted, even more autogen started to appear.  Sometimes it takes some time for all of the autogen to load but normally, it's instantaeous.  If you have high settings it will take longer and, if the Bufferpool tweak is not properly employed with the right parameters, it could take even longer.

 

 

 


Ben looking into the CTD guid, as suggested from Jim. But honestly, it didn't help me, as there seems to be so many different answers to the CTD, so one almost give up before started - hi.

 

The CTD Guide provides fixes that worked for others throughout the flight simulation community (not just this website).  If you do not want to try them then you will be stuck with this crash.  The only for sure, positive solution is to uninstall/reformat/reinstall Windows, then P3D. 

Share this post


Link to post
Share on other sites

Hi, and thanks for Your reply.

 

Yes Jim, but now You suggest me to start all over agn, with my pc etc. this is some job!!

And yes "my trees don't grove into heaven" we try a lot of things to get with of this CTD.

I don't run any tweaks on my P3D Cfg, I simply don't need these tweaks, I have tried some of them,

but they ave no impact at all.

Will try to change the military BGL in my traffic program!.

 

But here is for me the problem make my P3D CTD all the time. Aktiv Sky 2016 is the problem.

Not running this program make me able, for the first time, to fly Orlando - Miami and Portland - Los Angeles with out CTD, turning on the AS 2016 I'm back to CTD!!

 

So hope there is a solution to this!

 

Regards

Geert

Share this post


Link to post
Share on other sites

I was getting the AS16 crash every time I shutdown P3D.  They issued an update to fix this issue as it is known by them.  As I recall I was still getting crashes so disabled the MyTraffic6 miltraffic.bgl and the ntdll.dll errors stopped.

 

 

 


Yes Jim, but now You suggest me to start all over agn, with my pc etc. this is some job!!
And yes "my trees don't grove into heaven" we try a lot of things to get with of this CTD.

 

I certainly wish I could provide a magic solution to your CTD's but every installation, every computer, every hardware in computers is different.  There are no solutions that fix crashes for everyone.  So, as I suggested in the AVSIM CTD Guide, you need to investigate it all yourself and you can do it by following my guide on page 10 and bringing P3D back to the default (p3d.cfg and scenery.cfg rebuilt; dll.xml, exe.xml moved to a temp folder).  Everything should work perfectly as you have no modules loading, you cannot use AS16 or anything else.  Next you bring back the dll.xml, exe.xml.  Now you can use your addons.  Still no crashes, then the problem was in your p3d.cfg or scenery.cfg.  You can try bring back your old scenery.cfg.  That has the MyTraffic6 entry though and that could be triggering your crashes.  Disable the military traffic.bgl and that should fix everything.  Problem resolved.  If not, then you have to look at what you did last (moved the old scenery.cfg back).  The issue is somewhere in there.

 

Hope this helps.

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Hello Jim,

Thanks again for Your info, I have been thru Your the CTD guide, and run MC programs to se if

they could provide me with some thing, but all seems to be nice and dandy!!

Also moved my P3D cfg file to the desktop and rebuild. Will trye, again, to rebuild  exe.xml and dll.xml!. But haven't tried the Scenery cfg, so will do so later, I just have to test a bit more to se,

if the CTD is gone, now where I closed my AS 2016 program, (it have been updated every time new updates available)! As You say, it differs from PC to PC, and believe You me, I have a high end PC so

no problems handling P3D sim, FPS always around 35 - 70, depending on how cloudy the airport will be!!

Will be working on it and revert later, hopefully with some god news -hi

 

Have a nice day

Best regards

Geert

Share this post


Link to post
Share on other sites

Have you tried Disabling all Back-Round processes before you take flight in Prepar3D,  Maybe something like your Anti virus Software is Updating or even an app like Team Viewer is dancing in the back round.

 

Disable as much as you can,  and add your Prepar3D folder to your Exclusions zone to Anti virus software 

Share this post


Link to post
Share on other sites

Hello agn.

 

To "Poppet" I will say, Yes I always have an Exclusion zone, have no virus scan running in any of my sim. programs!!

I have now don following: new Scenery.cfg - then updated agn. with all Orbx/Ftx stuf - ect.

New Dll.xml and Exe.xml (in 2 places) C:\Programdata\Lm\P3d and C;\Appdata\Roaming\Lm.

These 2 files are not similar although they have same name!?

Also reinstalled Actice Sky 2016 and Active Sky Cloud Art.

Have now been flying from several places  in the world, and so fare no CTD, okay I can't say witch

of above, did the trick! as I did all at the same time!

However, who knows it may return again one of these days. That's the live for us simmers - hi.

So let's just have this topic open a while more!!

 

Regards

Geert

Share this post


Link to post
Share on other sites

 

 


New Dll.xml and Exe.xml (in 2 places) C:\Programdata\Lm\P3d and C;\Appdata\Roaming\Lm.
These 2 files are not similar although they have same name!?

 

That's good.  That's the way it is supposed to be.  Glad you are having no more CTD's and can enjoy your flight sessions again!

 

Best regards,

Jim

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this