Sign in to follow this  
saturdayboy

P3D v3.4 hangs/crashes when loosing focus

Recommended Posts

Hi there, I ran into this problem a couple of months ago and after reading (incl. the great AVSIM CTD-Guide) and trying everything I have read so far, I'm giving up and asking for your precious help.

 

P3D 3.4 inconsistently hangs while the sound keeps running when I switch to another application and that happens in almost any thinkable situation - never while running in the foreground.

 

Last 3 AppCrashView outputs:

 

https://www.dropbox.com/s/bqlt3l8kmgfxsj0/P3D_appcrash_log_1.txt?dl=0

https://www.dropbox.com/s/7y6jcsxkjv1m2ye/P3D_appcrash_log_2.txt?dl=0

https://www.dropbox.com/s/3jdi1hbio25qfgr/P3D_appcrash_log_3.txt?dl=0

 

Scenarios:

  1. ... after P3D ran in a small window for hours in flight preparation where I jumped between applications and my 2 screens. I took off in fullscreen, switched to window mode and clicked inside my browser.
  2. ... after P3D ran in fullscreen and I clicked into my 2nd screen.
  3. ... after P3D ran in a small window in the background for some time without touching anything.

... and so on. I couldn't get P3Dv2 run into the same problem so far though.

P3Dv3.4 is running with around 45fps. I never ran into OOM's.

 

(failed) troubleshooting so far:

  1. installed earlier nVidia drivers (341.x, 352.x, 359.x ...) using DDU - reverted back to newest
  2. new Prepar3D.cfg, DLL.XML, scenery.cfg etc.
  3. disabled all addons
  4. no tweaks
  5. new Windows user
  6. System File Checker
  7. disabled unnecessary startup applications

System:

  • Intel Core i5-4690K @ 3.50GHz
  • 8 GB RAM
  • nVidia GeForce GTX 760
  • Win10 Pro 64Bit
  • no overclockings

Thank you for any advice.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Same issue for me with 3.3.5 as I discussed here. I haven't found the problem yet and nothing in the CTD-guide seems to solve the issue, neither a full P3D reinstall (or even Windows).

Normally P3D crashes without giving errors, while a few times I've had a kernelbase.dll error but it's not a specific error.

 

I hope it's not some Windows 10 update.

 

 

System:

  • Intel Core i7-6700K never OC
  • 16 GB RAM
  • nVidia GeForce GTX 770
  • Win10  64Bit
  • no overclockings

Share this post


Link to post
Share on other sites

I had a similar problem earlier this year and isolated it to the MSI Afterburner App. Haven't got time right now to go into the details - sorry. Google MSI Afterburner CTD. Hope this helps guys....

Share this post


Link to post
Share on other sites

Hello Saturday, Welcome to Avsim
 

disabled unnecessary startup applications


Have you disabled as much as you can ? What about your Anti virus Software, have you added Exceptions for Prepar3D ?

Are you running Prepar3D and any other Add On that Launches with Prepar3D as administrator ?
 

installed earlier nVidia drivers (341.x, 352.x, 359.x ...) using DDU - reverted back to newest


Have you tried doing a Clean Install of your drivers ? Maybe try Driver Display Uninstaller and only Install the bare Minumum 

==========

Uninstalled the Migration Tool, Restart your Computer, Insuring the Migration Tool files have been removed from the bottom your Core Prepar3D folder

LoadedModule[188]=C:\Games\Prepar3D v3\MigTool.dll

===========

Are these Add On's up to date ? Have you disable these and then tested ?

C:\Games\Prepar3D v3\Modules\FSUIPC4.dll
LoadedModule[196]=C:\Games\Prepar3D v3\as_srv\as_btstrp.dll

===========

Bring Prepar3D back to a Close Default state again by Deleting the blue folders, Prepar3D will rebuild these folders again as default. Back-Up any Control settings you may have.

Launch Prepar3D and test it in a Default only state, By doing this you are eliminating any Corrupt files

► Libraries ► Documents ► Prepar3D v3 files

► Computer ► Local Disk (C:) ►ProgramData ► Lockheed Martin

► Computer ► Local Disk (C:) ► Users ► you ► AppData ► Roaming ►Lockheed Martin

► Computer ► Local Disk (C:) ► Users ► you ► AppData ► Local ► Lockheed Martin

Share this post


Link to post
Share on other sites

Thank you very much for your reply, Elaine.

  • P3D and all it's external addons are ignored by anti virus and everything is launched with admin rights. 
  • I used DDU every time I installed a new Nvidia driver.
  • I uninstalled Migration Tool and there are no leftovers.
  • Everything is up to date (FSUIPC, Active Sky etc.)
  • I have put P3D into "close to default" state like you suggested.

Unfortunately still no luck.

 

After I started a flight in window mode I was able to minimize it, drag it around, pull it to the 2nd screen for about 30mins before it crashed in the background again while I was browsing. I'm starting to doubt that it's P3D related, although I'm not having that problem with any other 3D-applications so far. I'm going to try DCS soon.

 

It all started after I took a 6 months break with P3D. It worked perfectly well earlier this year (around March). I'm suspecting a Windows update or something else. It's just hard to find out exactly what the problem is without having other references like users with the same issues for instance.

Share this post


Link to post
Share on other sites

It seems like I have found a "solution". 

 

Although my gpu temps are stable within 60°C, I have adjusted the base clock to -50MHz and the memory clock to -150MHz. Furthermore I have forced P3D to high priority. So far I was able to make 2 flights in around 3h time without any problems. It's not an elegant solution, but considering the countless hours I have spend so far, I'm happy that it's finally running ... at least for now.

Share this post


Link to post
Share on other sites

The final solution is to disable NVidia Share. No more freezes!

That might have been the final solution if I had NVidia to disable but I dont. I use an AMD card on a Win 7-64 box.

 

My symptoms are similar to the described ones. I have a two screen setup, P3D V3.4 (windowed) in one, and a browser, AS16 weather, and so on in the other. When setting up a flight, I will be switching back and forth between them. One flight in three or four, I will click on the P3D window and it will not accept focus. The screen greys out and the title bar changes to (not responding). 

 

EDIT: Might or might not be relevant but I use the space-bar and mouse to navigate to VC. 

Share this post


Link to post
Share on other sites

I have solved this (at least for me) and I wanted to let you know what I did in case it helps you as well. 

I was also suffering from this shutdown. It was always the kernelbase.dll and occurred when I would click back in the P3D window after doing things in other windows. 

 

It happened in all my planes but I mostly fly PMDG. In the 737s it happened maybe 10% of the time. 50% or so in the 777 and after I got the new 747 I was getting it nearly 100% of the time before I even could take off. 

 

This solution is a PITA - to be honest - but could definately be worse. I solved this by creating a new windows profile (admin account). That's it. I have now done about 10 747 flights and 777 flights in the last two days and this crash has not happend once. I am 100% positive I would have seen it by now based on how often it was occurring before. 

 

The solution itself is easy and, luckily, P3D and most of your add-ons should work fine. The bigger pain in the you-know-what comes in resetting ALLLLL of your other stuff such as windows settings, app settings, moving documents etc etc etc. 

 

It's possible to test this before you go to all that trouble. Below are my steps, I hope this helps anyone else having this crash. 

 

  1. Create new windows profile and make sure it is an Admin account.
  2. Restart the computer and log in as the new account.
  3. P3D should launch fine and most of your addons should work without reinstall with the below exceptions that I saw for my setup. I'm sure there are other similar problems to other addons, but if you have as many add-ons as me you'll be happy it's not necessary to completely reinstall P3D from scratch.
    • I needed to reinstall and register FSUIPC
    • My Addon Manager sceneries (FSDT, Flightbeam etc) needed to be re-registered
    • Needed to reinstall FTC Central 3 (but all my sceneries remained)
    • Re-map all controls/axis
    • Redo PMDG Options

I recommend you do all this and try flying for a few flights to see if the crash goes away. If it does, you can go about the long process of importing/installing/setting up whatever else you may have on your system, but since it's an admin account it's pretty easy to copy over files from your first profile. 

 

Hope this helps!

Share this post


Link to post
Share on other sites

Building a new user profile is one of the solutions posted on page 21 of the AVSIM CTD Guide, especially for the kernelbase.dll error.

Share this post


Link to post
Share on other sites

Thanks Jim - never came across it in all of my googleing. Just lots of posts with no solutions.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this