TheBoom

VAS issues caused by camera views?

Recommended Posts

Hi all, been out of the flight sim loop for a while. Decided to give 3.4 a try and along with PTA and couple other tweaks I've to say it never looked better.

However I keep running into OOMs on approaches, even with low-medium settings and such. I noticed though my Ezdok has an issue where everytime I switch to the outside cameras it kinda reloads the whole picture if you know what I mean. Also it has to always skip through the world cam before getting to the aircraft cam so I'm not sure if thats causing some sort of weird memory leak but I heard it mentioned on some other threads. Someone suggested deleting the camera.cfg and letting P3D rebuild it as well as rerun the EZCA config tool but that didn't do much for me.

Any thoughts or inputs on this?

If someone can confirm that this corresponds to the OOMs I might ditch Ezdok and get Chaseplane instead.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Recent Nvidia drivers have been causing major memory leaks for many. Check those threads out, and try an older driver - the 376.53 drivers are OK for me. (Note the hotfix drivers didn't help in my case).

Share this post


Link to post

If it won't help, what is your pagefile size? What SSD's you use? (manufacturer)

Share this post


Link to post

Limited VAS is making P3D unusable. GA planes and short distance flying seem to be the only option for now. LM please release the 64 bit version, and it should be free.

Share this post


Link to post

Oh dear that's not true. I use advanced jets with awesome ORBX scenery (latest and greatest) flying in and out of complex Flytampa and Aerosoft airprots  and I don't even reach 3.6 GB of used VAS. It's about appropriate config, nothing more nothing less (although I can't help you if you use FSLabs lol)

Share this post


Link to post

 

2 hours ago, TheBoom said:

Hi all, been out of the flight sim loop for a while. Decided to give 3.4 a try and along with PTA and couple other tweaks I've to say it never looked better.

However I keep running into OOMs on approaches, even with low-medium settings and such. I noticed though my Ezdok has an issue where everytime I switch to the outside cameras it kinda reloads the whole picture if you know what I mean. Also it has to always skip through the world cam before getting to the aircraft cam so I'm not sure if thats causing some sort of weird memory leak but I heard it mentioned on some other threads. Someone suggested deleting the camera.cfg and letting P3D rebuild it as well as rerun the EZCA config tool but that didn't do much for me.

Any thoughts or inputs on this?

If someone can confirm that this corresponds to the OOMs I might ditch Ezdok and get Chaseplane instead.

Try this entry in your prepar3d.cfg and see if that reduces VAS increase when switching views:

UseGlobalTerrainView=True

This should prevent texture-reload on cam switching

 

 

27 minutes ago, kakusso said:

Limited VAS is making P3D unusable. GA planes and short distance flying seem to be the only option for now. LM please release the 64 bit version, and it should be free.

With proper system hygiene and reasonable sim configuration P3D is perfectly capable of long haul heavy metal flying even in 32bit.

And why should the 64bit version be for free? LM isn't a charity or non-profit organisation as far as i know 

  • Upvote 4

Share this post


Link to post
8 minutes ago, woozie said:

 

Try this entry in your prepar3d.cfg and see if that reduces VAS increase when switching views:

UseGlobalTerrainView=True

This should prevent texture-reload on cam switching

 

 

With proper system hygiene and reasonable sim configuration P3D is perfectly capable of long haul heavy metal flying even in 32bit.

And why should the 64bit version be for free? LM isn't a charity or non-profit organisation as far as i know 

How rude...

Share this post


Link to post

aaaw, rude? :) I didnt mean to come across rude, but P3D is far from unusable as long as you configure it with limited VAS in mind. And again, why should the 64bit version be free? Its a major step in P3D development and going from 32bit to 64bit architecture will require many thousand man-hours

Share this post


Link to post
2 hours ago, TheBoom said:

Hi all, been out of the flight sim loop for a while. Decided to give 3.4 a try and along with PTA and couple other tweaks I've to say it never looked better.

However I keep running into OOMs on approaches, even with low-medium settings and such.

I also use EZDOK (now v2), but I doubt it has to do with increased VAS consumption. I also had OOMs in P3D v3.4, which is known for inferior VAS managment. I downgraded the client to 3.3.5 and the OOMs went away (Scenery and Content still at v 3.4).

Cheers,
Chris

Share this post


Link to post

Currently flying the second leg of a flight from Sydney to Heathrow (part 1 yesterday from YSSY to VHHH with Chaseplane) today I am enroute from VHHH to EGLL using EZdok v2 and the latest drivers from NVidia, my VAS is stable 1.3gig remaining and I am half way along the route.

 

Just about to declare a low fuel emergency over Russia

 

 

Edited by SierraHotel

Share this post


Link to post

Thanks for all the replies so far. TBH I've always had vas and oom issues in P3D. But it only used to be on approaches of long haul flights (6 hrs or more). But with P3D 3.4 it's a lot worse, PMDG 737 LOWW-LIRP (both addons) ooms. I even ditched Vector and am using UT now. 

I already have useglobalterrainview=true. 

SSD is a Samsung EVO 250 256GB. Pagefile are on my HDDs and are well above the recommended sizes. 

One thing I just noticed though is there might be scenery conflicts. I have cars and other vehicles driving on grass. 

Edit : Quick question for those of you who claim to have a lot of remaining VAS during flights. Do you regularly switch to outside views throughout the flight?

Share this post


Link to post
3 hours ago, kakusso said:

Limited VAS is making P3D unusable. GA planes and short distance flying seem to be the only option for now. 

Wow what a statement to make. :laugh:

-----------------------------------------------------------

Shanan,

Hi and welcome back to P3D/flight simming.

Let get a few myths out the way, you can run high setting like I do, you can use e.g FSL A320 fly anywhere you like without a OOM.

I don't use ezdoc now, I use chaseplane. Also if you wish chaseplane shows how much VAS you have left.

All I do and all I fly is the FSL A320 since it came out for P3D. Its the biggest VAS using aircraft out there or about the same as PMDG 777 to be fair.

I use Orbx Global- Vector with everything turned off apart from the first two ticks on the Roads page.-OLC Europe.

I have active only the two airports I am going to use.

I have yet to have an OOM, to tell the truth I gave up even looking as I normaly have around 700-1.2GB left. 

So AS16-Cloud art-chaseplane-FSL A320-BAV running. Setting lots max some 3/4.

If people have VAS problems its there set up and how there using the sim with no care.

 

Don't use the new drivers, they have a VAS leak, make sure to use 376.33

Hope that helps?

 

 

Share this post


Link to post
27 minutes ago, TheBoom said:

Thanks for all the replies so far. TBH I've always had vas and oom issues in P3D. But it only used to be on approaches of long haul flights (6 hrs or more). But with P3D 3.4 it's a lot worse, PMDG 737 LOWW-LIRP (both addons) ooms. I even ditched Vector and am using UT now. 

I already have useglobalterrainview=true. 

SSD is a Samsung EVO 250 256GB. Pagefile are on my HDDs and are well above the recommended sizes. 

One thing I just noticed though is there might be scenery conflicts. I have cars and other vehicles driving on grass. 

Edit : Quick question for those of you who claim to have a lot of remaining VAS during flights. Do you regularly switch to outside views throughout the flight?

You didnt mention your current NVIDIA driver version yet (or i might have missed it). Mind you, the last recent drivers seem to a have an issue with unusual high VAS usage (or leaking). Try the 376.33 drivers, they are the last ones that are known to handle VAS properly in P3D. If you are on Win10 you might wanna disable automatic driver updates as Win10 will force an update to 376.5x drivers. You can do that by editing the local policy, let me know if you need details about how to disable automatic driver updates through policy. 

 

In regards to your last question: Yes i do switch to external views every now and then and it doesnt really affect my VAS usage. Since p3d 3.4 hotfix 2 it seems to apply a much more aggressive method to reclaim VAS. In heavy scenerys my VAS always hovers at about 600MB remaining VAS and never really goes beyond that, no OOMs since months

Share this post


Link to post
24 minutes ago, Nyxx said:

Wow what a statement to make. :laugh:

-----------------------------------------------------------

Shanan,

Hi and welcome back to P3D/flight simming.

Let get a few myths out the way, you can run high setting like I do, you can use e.g FSL A320 fly anywhere you like without a OOM.

I don't use ezdoc now, I use chaseplane. Also if you wish chaseplane shows how much VAS you have left.

All I do and all I fly is the FSL A320 since it came out for P3D. Its the biggest VAS using aircraft out there or about the same as PMDG 777.

I use Orbx Global- Vector with everything turned off apart from the first two ticks on the Roads page.-OLC Europe.

I have active only the two airports I an going to use.

I have yet to have an OOM, to tell the truth I gave up even looking as I normaly have around 700-1.2GB left. 

So AS16-Cloud art-chaseplane-FSL A320-BAV running. Setting lots max some 3/4.

If people have VAS problems its there set up and how there using the sim with no care.

 

Don't use the new drivers, they have a VAS leak, forgot the # of the version you should use I think off the top of my head it ends in .33 google it.

Hope that helps?

 

 

+1

 

and 373.06 is also a really nice driver btw (3.4.9.18400)

 

Michael Moe

Share this post


Link to post

I just looked up my drivers and edit post hehe Michael :biggrin:

Just one of many on the drivers.

FSL Forums

http://forums.flightsimlabs.com/index.php?/topic/11719-nvidia-driver-37866/

BTW turn, car, boats all that rubbish OFF. Eat FPS and CPU time and at FL3xx you don't need them

Do I use out side view?

Yes but really not much, Normally when I am parked at gate at the end of flight I have a good look round and also watch a reply of my landing. Also chaseplane goes into outside view Cinema mode if you have not moved your mouse for 10 mins, so normally in cruse. But like I said always around 700+ VAS left even after all that.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now