Lorby_SI

Prepar3D V4 Addon Organizer 0.94 released

Recommended Posts

Hi @ll,

P4AO has been updated to 0.94, catching the situation where users would try to apply it to a scenery.cfg that has an incorrect encoding. In this case the tool will not start and you will see an error message instead - to prevent users from destroying their scenery.cfg.

If this message is shown, please use an advanced text editor like Notepad++ and change the Encoding of the scenery.cfg back to Unicode / UCS-2 Little Endian.

http://lorby-si.weebly.com/downloads

Note: there still is an unresolved issue that when deleting a whole package the configuration files are not written properly. The exact circumstances have yet to be determined, but for now, please don't delete Packages on the Package view.

 

Best regards

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I deleted the 'imported Scenery' from packages, that went OK.  BUT  even though the entry is removed from the GUI, the folder is not deleted.(Documents > Prepar3D v4 Addons).

 

 

Share this post


Link to post
Share on other sites

I have been using this amazing tool to add all kinds of scenery that I am installing in my newly created P3D v3 Add Ons directory.  I even added some stuff by just pointing it to my side by side P3D v3 install and it worked.  A few sceneries have issues but most work just fine.  Thanks for making this for us!

Share this post


Link to post
Share on other sites

I take it this also works for P3Dv3 seeing how we have no choice now. 

Share this post


Link to post
Share on other sites
8 hours ago, Wise87 said:

I take it this also works for P3Dv3 seeing how we have no choice now. 

Hello Dan,

no, it does not manage addons for P3D V3. But I could make it so, it is just a question of ignoring one of the config files and setting different paths.

But do you really think that this is necessary? I imagine that seen from a 3PD perspective, V3 is already obsolete.

Best regards

 

Share this post


Link to post
Share on other sites

I would vote for a v3 option.  I think it is going to be some considerable time before all my 'essential' addons are compatible with v4.

Might as well get into the habit of using the add-on.xml method.

Share this post


Link to post
Share on other sites

I agree, and it may also make the transition to V4 much easier when a lot of folks finally make the switch.

For myself I need to stay with V3.2 until some pieces of the jigsaw are in place such as  MakeRwys, Pollypots goflight interface tool, Virtual avionics FMC and the NGX, without these I won't fly anyway.

Share this post


Link to post
Share on other sites

The reason I asked about V3 was FSDT has already moved to the new system on both V3 and V4 and FlightBeam is soon following. As it stands now V3 users are stuck and can't make changes except in the scenery.cfg. 

Share this post


Link to post
Share on other sites
2 hours ago, Wise87 said:

The reason I asked about V3 was FSDT has already moved to the new system on both V3 and V4 and FlightBeam is soon following. As it stands now V3 users are stuck and can't make changes except in the scenery.cfg. 

Hi @ll,

I will see what I can do for V3. I am a bit short on time currently, I still have three payware products to finalize for V4.

Best regards

 

Share this post


Link to post
Share on other sites

Hi @ll,

version 0.95 of the Addon Organizer is capable of handling P3D V3 (you can switch between sim versions).

But I am not sure if it will work with 3.2 - as far as I know, the discovery of addons through XML files was introduced with 3.3.

Please let me know how it works out (and don't forget that backup feature!). I can add an option to create the addon components as if they were installed too (as opposed to be discovered automatically), if there are issues in 3.2

Best regards

Share this post


Link to post
Share on other sites

I know some time has passed since the last update here, but is there going to be a new version of this addon manager?

Share this post


Link to post
Share on other sites

Hello,

there have been many updates since then. Version 1.38 is being tested currently, and will be released as soon as possible.

Best regards

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now