Sign in to follow this  
davidzill

Prepar3d V4 screen tearing w/ vsync on

Recommended Posts

New Prepar3d user, V4, I have FPS locked at 60 (refresh rate), vsync on, I'm getting screen tearing especially when panning head around w/ trackir.  Brought fps down to 30, same thing. I have NVI however I am using only prepar3d settings, I don't have an NVI profile activated. Any ideas?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

What OS are you using?  Do you have Aero turned off?  Desktop composition (part of Aero) must be enabled to receive Vsync in Prepar3D.

Share this post


Link to post

Try NVI,  Vsync set to 1/2 refreshrate.

Off in P3D itself.

Share this post


Link to post

Set your monitors to 30 Hrtz ( if possible ). Then Unlimited in P3D.

  • Upvote 1

Share this post


Link to post
7 hours ago, Bert Pieke said:

Try NVI,  Vsync set to 1/2 refreshrate.

Off in P3D itself.

1/2 refresh rate does work in P3D? Never works for me.. v2, v3 and v4.

 

 

Share this post


Link to post
3 hours ago, Jiri Kocman said:

1/2 refresh rate does work in P3D? Never works for me.. v2, v3 and v4.

 

 

All I know is that I have set Vsync to Off in P3D, and set it to 1/2 refresh rate in NVI.

The framerates in P3D are holding steady at 30, and no tearing... so I am happy.

Share this post


Link to post
12 hours ago, davidzill said:

New Prepar3d user, V4, I have FPS locked at 60 (refresh rate), vsync on, I'm getting screen tearing especially when panning head around w/ trackir.  Brought fps down to 30, same thing. I have NVI however I am using only prepar3d settings, I don't have an NVI profile activated. Any ideas?

I would add trying to uninstall existing video drivers completely (like a fresh installation, using DDU) and reinstalling the same video drivers. In my case, I recently had the a similar problem as yours, and this solved the issue.

Cheers, Ed

 

Share this post


Link to post

I used this guide to solve stutters:

It involves proper affinity mask and nvidia vertical sync 'adaptive' with vsync off. Now my sim is smooth as silk.

ymmv.

 

Share this post


Link to post
On 23/06/2017 at 1:06 AM, Bert Pieke said:

All I know is that I have set Vsync to Off in P3D, and set it to 1/2 refresh rate in NVI.

The framerates in P3D are holding steady at 30, and no tearing... so I am happy.

I've never seen NVI 1/2 refresh rate work myself.
Are you sure you do not have a frame rate limiter on somewhere?

gb.

Share this post


Link to post
4 hours ago, gboz said:

I've never seen NVI 1/2 refresh rate work myself.
Are you sure you do not have a frame rate limiter on somewhere?

gb.

I checked, and you are correct, I am limiting at 30 in P3D itself.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this