Hilkiah

difficulty selecting departure phenom 300

Recommended Posts

HI all,

 

Just picked up the Phenom 300 and decided to try a flight EGLL/LFPG.  Read through the G1000 pdfs and have some familiarity with the G1000 from the Phenom 100 which I used to fly earlier in the year.

 

My main issue is when selecting the departure most times the airport field keeps rapidly changing...as if in  constant scan.  The only way to stop it is to press the inner knob, but then I cant use the outer knob to select the departure (as nothing is highlighted).  I then have to press the PROC button to to back to the Procedures page.  Selecting Departures again does the same thing.  The workaround is then to go back to the PROC page and select approach, use the outer knob to select approach or transition, press PROC then go back to selecting Departure.  Its as you have to gingerly handle the G1000.  I think this was the same issue I had with the Phenom 100 which is why I stopped flying it.  Has anyone had a similar experience and is there a way to fix it?  I really wanna love the Phenoms!!

 

Thanks.

Hilkiah

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Same issue here.

The GS1000 is frustrating I find. The phenom will be off to the wreckers yard once the Aerosoft airbus is out.

Share this post


Link to post
Share on other sites

Couldn't agree more.  I have the same issue plus I can't even get the departure to change from the one that shows once I get to that section.  In other words i can't select a different departure,  This is ridiculously frustrating.  I bought the jet because I like the bus jets and Flight1 Mustang and King Air were great in FSX but I switched to p3d v4 and Flight1 hasn't seen fit to make them compatible yet despite saying they would be back in June.  Their G1000 worked it should but not in the Carenado.  if anyone has simple solution I am up for it.  Yes I have read the manuals and even watched the tutuorials on YouTube and thought I was doing exactly what they said to do.  So I am either stupid (please don't answer that) this is piece of junk..

Share this post


Link to post
Share on other sites

Only workaround that works, is to access your MFD using the 2d menus.

Share this post


Link to post
Share on other sites

Same. the garmin 1000 bug and Carenado does not fix it ..

Share this post


Link to post
Share on other sites

Hi Guys.

It is beginning to look like this aircraft is system dependant. I do not have the problem that you folks are having. I can make a flight plan without any problems and fly ILS approaches just fine. There seems to be a commonality here in this thread where people report problems and other folks do not appear to have them. For my part, I had to install/uninstall a few times before the aircraft worked as it should. For example, initially I had to wait overnight for the Navigraph extension to update itself. Now it updates in a few minutes after each new airac. Again, initially, the cockpit graphics would stay a shade of whitish grey and refuse to kick in with the correct graphics and gauges. Now it works fine for me. Very strange behaviour on differing systems. I had to get help from Bert to sort out a problem with the digital checklists, but that was merely a cosmetic problem where a line was repeated twice in the code.

Not much help to you guys I'm afraid though.

Regards...Ken.

Share this post


Link to post
Share on other sites
Posted (edited)

Ohh I just found this topic. Same issue here and I just posted a video as well.

 

 

Edited by RancidViper

Share this post


Link to post
Share on other sites

I have this issue intermittently. I find that re-starting the sim sometimes fixes it, but it will often happen again if I try to make any changes to the flight plan after takeoff.

In general, the G1000 in this plane is junk. It doesn't work right, even when it's not experiencing a bug problem.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now