Sign in to follow this  
RetardRetard

Is this what VR performance is about?

Recommended Posts

I have to ask how you would rate VR smoothness in Aerofly FS 2. 

I recently got what I would rate a very good gaming computer + Rift in order to enjoy VR flights for the first time. But my impression so far is... Meh. It's not about the resolution, I am fine with that. It's the nervous rendering of frames and micro-stutters. The entire world I am viewing in cockpit feels...well...nervous and jumpy. Difficult to explain. It's not solid. 

My FPS are on 90 according to the Rift application and I assume ASW is active. But here's the thing... it doesn't really get smoother if I reduce graphic settings to minimum either. Or if I pick an area with minimal surroundings. It's still a nervous view in my HMD - especially after head movements.. 

I though the FS2 simulator would be a walk in the park for my rig 

i7-8700K (normal clock)
Asus Geforce 1080ti OC version 
16 GB DDR4
Samsung EVO 960 250 GB 

Latest Nvidia drivers and headset up to date. VSync is off in FS2 and I set resolution to "monitor". I use Oculus mode for VR when launching the game. 

Any ideas? Other games don't behave like this.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

That’s very strange.  My PC spec is a lot lower than uours and I get 120fps plus.  Just as a try - launch your occulus, then forget it, go to the Steam site and launch FS2 in VR mode - the link is on the left hand side and click the occulus mode launch.  Worth a try.

Kev

Share this post


Link to post
Share on other sites

That was my experience also in AeroFly FS2, stutters, reprojection, freezes, was not good! Thats why i asked a refund on the game, although i read others saying the opposite. I dint had a 1080 ti then, was a 980 ti!

Share this post


Link to post
Share on other sites

Sounds like you just might be using the oculus tray tool with ASW active. If so, turn it off. Aerofly with the Oculus doesnt need ASW on a machine with your specs, and tends to hate it.

This is pretty much what you should see in AF VR

 

Share this post


Link to post
Share on other sites

I don't have Aerofly but when your frames are jumpy and shuddery it is called judder and is almost always caused from your settings being too high, or Super Sampling too high. I would try setting all settings to low and Super Sampling set to no more than 1.5 in OTT,  see if you get a solid frames. Then after getting things looking OK as far as judder, start increasing things slowly. takes a bit of time but well worth doing. The rig you have is more than capable. Good luck.

Share this post


Link to post
Share on other sites

@RetardRetard,

    Before you focus on VR performance, make sure your single HD (1920x1080) monitor Aeofly FS2 performance is correct: (Graphic settings at high for now - Nvidia 1060 8xMSAA - Intel CPU 4.2 Ghz)

1) If you have the Colorado scenery, short final into Aspen Pitkin RWY 15 with Learjet virtual cockpit should see FPS (Ctrl+F1) at 250 fps

2)  At San Francisco takeoff in B747-400 at RWY 28L virtual cockpit EFIS showing , FPS = 170

Share this post


Link to post
Share on other sites

I don't think it matters what your fps in aerofly is set to ie 120fps when you go into vr mode it is reduced to 90fps when I started using afs2 in vr mode back in September vr was very smooth but now have some stuttering now and again also autogen buildings in distance I get bad shimmering even in 2d I have stop using afs2 for now I know they are looking at a fix for this so in the meantime using p3dv4 nice and smooth and no shimmering which is important for me but I prefer to fly in vr specially the Cessna 172 and the scenery looks great.

Share this post


Link to post
Share on other sites

@jimimac,

       The frame rate does matter in non VR mode! You really need as much as 220 fps in non-VR mode since for VR, you have to drive two separate views (left and right eye) and then for image clarity, you need to run SuperSampling (aka Render Scale Factor or Pixel Density) at least at 1.5 which is roughly 2500x2000 resolution per eye before downsampling (and it gets exponentially worse as you set SuperSampling up towards 2.0). In the end run, you get maybe about 40% of the non-VR rate in VR. You can easily see what your rate is in non-VR mode if you disable Vsync but you can't tell easily in VR mode - either 90 fps or 45 fps with ASW - and you can't tell how close you are to missing 90 fps which will cause some stuttering. So my approach for minimal stuttering is to establish my graphic setting in single HD monitor, non Vsync, mode trying to get 220 fps. This is also then the best way to get someone who is having performance problems to benchmark their own system, and then if they get 220 fps on average, they should have a great VR experience. After the most recent update of FS2 (2.07.39),  use of Nvidia drivers 388.71 on WIndows 10, AND no CPU/GPU clock throttling (set maximum/high performance in WIn 10 power plan and Nvidia power management), FS2 is quite smooth again.

 

Dave W.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this