Sign in to follow this  
GV-SP

REX Radar CTD

Recommended Posts

I recently installed the REX/Milviz WX Radar gauge to use with the Falcon. But on almost every flight I have tried it causes a crash to desktop. I have run the updater for the gauge as well as have the latest version of the Falcon. 

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

10 minutes ago, GV-SP said:

I recently installed the REX/Milviz WX Radar gauge to use with the Falcon. But on almost every flight I have tried it causes a crash to desktop. I have run the updater for the gauge as well as have the latest version of the Falcon. 

Hi Folks,

RE: P3Dv4

Yeah - I've been getting CTD as well - which I haven't had in a very long time - I did recently upgrade my REX Wx Radar but I haven't really been doing much else but testing this aircraft - so I can't say if it's isolated to this aircraft or it affects all aircraft using the REX Wx Radar ? 

Along those lines - P3Dv4 crashes if I attempt to start a session with the Falcon - if I start with another aircraft - I can switch to the Falcon just fine...

Regards,

Scott

Share this post


Link to post
41 minutes ago, scottb613 said:

Hi Folks,

RE: P3Dv4

Yeah - I've been getting CTD as well - which I haven't had in a very long time - I did recently upgrade my REX Wx Radar but I haven't really been doing much else but testing this aircraft - so I can't say if it's isolated to this aircraft or it affects all aircraft using the REX Wx Radar ? 

Along those lines - P3Dv4 crashes if I attempt to start a session with the Falcon - if I start with another aircraft - I can switch to the Falcon just fine...

Regards,

Scott

I use the Cub as my default aircraft. When I start P3D and the scenario selection screen opens with the Cub rotating in the window, I then change the aircraft to the Falcon, and proceed to “Load”. So far, no problems at all with P3D crashes doing this.

I also have the WXAdvantage radar (latest version). I’ve been using it on every flight with the Falcon, and no CTD issues as yet. (Fingers crossed)

Share this post


Link to post

I had to uninstall that WX Advantage radar. More trouble than benefits IMO.

Cheers, Ed

Share this post


Link to post

I have not had any problems with the WX radar since it was updated back around the end of Sept or beginning of Oct '18.

Al

Share this post


Link to post

Milviz just released a fix for P3D V4.

If you had loaded a aircraft that had the radar then changed planes it would CTD. If you loaded a plane that did not have the radar then you could change planes.

The new fix solves this issue and i never have a CTD now. Is this the issue you guys are having?

Share this post


Link to post

I purchased the radar then loaded a flight with the falcon and had issues even with flying with the radar off. 

Share this post


Link to post
4 hours ago, GV-SP said:

I purchased the radar then loaded a flight with the falcon and had issues even with flying with the radar off. 

First make sure that you are using the most recent version of the WX radar gauge and that you have set up the VC panel correctly with the Falcon 50 configuration utility. If you don't have the most recent WX radar gauge version, then download it, reboot and see if that fixes the problem.

Also, check the REX support site. I had a recent thread  there on this topic in the WX Radar subforum and I posted a few workarounds.  Make sure that you start with the default P3d4 scenario. Then change to the Falcon 50 and load your flightplan. Only then run ASP4. If you use REX Sky Force instead of ASP4, you won't get any CTDs (at least I didn't). There is something messed up with the Flysimware implementation of the the REX WX Radar, but REX can't reproduce it and only you and I have reported CTDs with the most recent WX radar gauge version.

Share this post


Link to post
4 hours ago, jabloomf1230 said:

There is something messed up with the Flysimware implementation of the the REX WX Radar

This is false. We have this radar in many of our aircraft the only time this issue happened was when P3D V4 came out. And the customers reported an issue for any aircraft that uses the radar even if its only the 2D panel.

To prove this all you have to do is use the old radar version and add the 2D to any default plane. Now load that plane in V4 and switch planes and you will get a CTD.

Edited by Flysimware

Share this post


Link to post

You obviously didn't read my thread over at REX support. Your two planes (LJ 35A and Falcon 50) work perfectly for everyone except me. What I figured out is whatever is happening with the two aircraft occurs when ASP4 injects the first weather change. REX seems to think it's some obscure conflict with COUATL, the FSDT Python interpreter, but it only happens with the two Flysimware aircraft. I thought that I was the only victim, but GV-SP above just posted an identical issue. I should add that the LJ35A worked perfect prior to P3d 4.3 with the previous version of the REX WX radar gauge. And I also have three other aircraft with the REX WX radar gauge in the VC and all work fine. 

I spent a lot of time with REX trying to figure out what was wrong (and tested about 5 beta versions). They initially were having problems  with the gauge in 4.3 when ASP injected weather, but the release version of the WX radar gauge fixed the problem for almost everyone.

I'm not complaining, because I worked around the CTD. I'm sorry that you took offense.

Share this post


Link to post
5 minutes ago, jabloomf1230 said:

I'm not complaining, because I worked around the CTD. I'm sorry that you took offense.

No offense taken. Just wanted to correct a public statement that is false because it's just not an issue with our products.

Share this post


Link to post

So you're saying that other aircraft with the REX WX radar gauge are still causing CTDs? I'm confused.

Share this post


Link to post
17 minutes ago, jabloomf1230 said:

So you're saying that other aircraft with the REX WX radar gauge are still causing CTDs? I'm confused.

I talked about a test using the "old" version. That will cause the CTD with other aircraft which proves its not our models.

Edited by Flysimware

Share this post


Link to post

One more thought on this. My system is rock solid. It runs DCS, XP11 and P3d4 without CTDs. The last time that I experienced even a few CTDs was long ago when using P3d V3. At that time, the source was determined to be a flooding of the SimConnect channel caused by a bug in a common add-on.

I'm not saying that this is what is happening here, but it is plausible that the stress imposed by either of the two elegantly complex aircraft, combined with the initial ASP4 weather injection (and all the other add-ons like GTN gauges, FSUIPC5, TrackIR and COUATL, etc.) can cause something similar. I might take a look at the SimConnect logs to see if anything jumps out. 

Share this post


Link to post

I've just completed a flight out of PAJN,  with ASP4 running, very bad visibility, Frame on my set up 20-24, 100 miles out  returned to PAJN, missed approach due to fog.

GTN750, milviz radar, ( including FSuipc5)

I7 4770 @ 4.2 , 16 gb  mem, GTX 1080 ti

edit , should have added os..  w10 (1809)

bob

edit 2... I have the 'WX Advantage Radar' folder on my 'K' drive (but not in the P3D v4) and have it  in the exceptions of my Internet Secruity.

Edited by onebob

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this