unc1rlm

P3dv4 at bootup

Recommended Posts

Posted (edited)

I have been plagued with p3dv4 starting up almost everytime I boot up. I do not know if this is a bug or what. I have a 1080ti (Nvidia) an I know there was some stuff about power settings  etc but this is aspirating.

Any helpful info appreciated. I always give time to shut down and still it does this. I have window 10x64 latest update.

Thanks,

BobM.

Direct x12 and i get this too.

https://imgur.com/yhgzb1D

Edited by unc1rlm

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

I have this problem too. Who knows what the deal is.

Share this post


Link to post

It's a windows "feature". If any application has not closed completely when system is shut down, it will reopen on reboot. After you close P3d you can look in the task manager to see how long it takes to actually close - THEN you can shut down system

Share this post


Link to post

Thank you vgbaron....thats a drag...not being short...but who wants to go thru that everytime they shut down. I may be wrong but I would think p3dv4 could do something that would shut their program down. Been fighting this for a number of years.

I will read the above post and see if it helps.

Very best to you,

BobM.

Share this post


Link to post

 Just give the computer a couple minutes after closing p3d before selecting the shutdown process.

  • Like 1

Share this post


Link to post

I did a couple things...turned the sign in "off" and the one next to it in privacy in settings and lets see what happens.

Thank you Dave!! and everyone else for your input..

Greets to all,

BobM.

Share this post


Link to post

The "problem" here is the fact that P3D takes quiet a long time to be really shut down after quitting the sim. If you have any addon depending on a closed P3D, you can easily realize that by firing up this addon after you quit P3D. In my case, it is the compiler for GSX Level 2: if I fire this up after quitting P3D, the Compiler tells me "wait to close sim". This message remains for about 40-60 seconds after quitting P3D. Means: if you turn off your PC within those 40-60 seconds, Windows 10 thinks P3D was running at shutdown and fires it up again after rebooting.

Long story short: as others mentioned, just wait some additional seconds after quitting P3D and it will not fire up again after a reboot.

Share this post


Link to post

Thank you Chris,

Bestest,

BobM.

Share this post


Link to post
Posted (edited)

Another one of Microsoft's odd additions to Windows 10. They even made it progressively harder to turn off properly after introduction. That's why I had to add a small shutdown feature to my right-click menu on the desktop, which is basically the same shutdown you get from the ALT + F4 shutdown menu. That completely kills all those features and shuts down / restarts properly.

0puynf4.jpg

Edited by Sethos1988

Share this post


Link to post
Posted (edited)

excellent!! How did you add that?

BobM. 

Edited by unc1rlm

Share this post


Link to post

You can either download the one I made; https://www.dropbox.com/s/sl2bxjufnrpsz9h/Shutdown Modifier.7z?dl=0 (Packed with 7-Zip) then double-click "Add Power Options" and confirm. You can open them in a text document to confirm the contents.

or if you don't trust random files off the internet, you can create a text document (preferably with something like Notepad++ to make sure it's the right format), then add the below;

Windows Registry Editor Version 5.00

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\Shutdown]
"Icon"="shell32.dll,-28"
"MUIVerb"="Power Options"
"Position"="Bottom"
"SubCommands"=""


[HKEY_CLASSES_ROOT\DesktopBackground\Shell\Shutdown\shell\001flyout]
"MUIVerb"="Force Shutdown"


[HKEY_CLASSES_ROOT\DesktopBackground\Shell\Shutdown\shell\001flyout\command]
@="shutdown /s /f /t 0"

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\Shutdown\shell\002flyout]
"MUIVerb"="Force Restart"
"CommandFlags"=dword:00000020

[HKEY_CLASSES_ROOT\DesktopBackground\Shell\Shutdown\shell\002flyout\command]
@="shutdown /r /f /t 0"

Then rename it to have a .reg extension. Then you can double-click it.

You can make another text document and add;

Windows Registry Editor Version 5.00

[-HKEY_CLASSES_ROOT\DesktopBackground\Shell\Shutdown]

Which removes the entry again if needed (also included in my dropbox link).

Share this post


Link to post

Ok if I add to registry with the download and confirm...when does it show up on the start menu?

 

Thank you,

BobM.

Share this post


Link to post

Not the start menu, right click menu on the desktop, at the very bottom. The second you double-clicked it and said 'Yes' to the confirmation box, it should be visible.

Share this post


Link to post

Oh ok, that works 🙂

BobM

Share this post


Link to post

Worked like a charm..i get the couatrl error as its shutting down because of FSDT or GSX but continues to shutdown without touching anything and p3d didn't pop back up.

Thanks,

BobM.

Share this post


Link to post

No problem, glad it worked.

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now