Jump to content
Sign in to follow this  
DChockey08

How I fixed my "slow loading autogen" issue

Recommended Posts

Good morning everyone,

I keep seeing posts on this forum about the slow-loading autogen problems that have been present in P3Dv4 with the higher autogen draw settings. I’m starting this topic not to discuss a problem or LM but to offer anyone who wants it a way to fix the problem, albeit with some trade-offs. You may not like my fix. I’m not asking you to, I’m just giving out what I have done. I have lurked this forum many times over the years and had countless errors solved so why not give back. Note that I’m sure these solutions have been posted many times in the forum, but I figured I’d open a new topic to give it some visibility because some people are still struggling to understand it.

Let me start by saying one thing:

This issue is not a bug. It’s merely the way the simulator allocates it’s resources. For the autogen to load faster, you have to sacrifice some FPS. As NickN at Simforums would say: there’s no such thing as a free lunch. Higher FPS: less resources to load in scenery. Lower FPS: more resources to load in scenery.

Enter: The FFTF setting.

The Fiber Frame Time Fraction tweak has been talked about in the most technical terms I never understood when reading these forums but allow me to offer my layman’s understanding of the setting:

The setting (between 0.01 and 1.00) tells the simulator how many computer resources to dedicate to the loading of scenery at the expense of performance.

A minimum FFTF setting of 0.01 tells P3D to dedicate the minimal amount of resources to loading in scenery, while maximizing the FPS count. Note that with the simulator setting set to “Unlimited Frames”, P3D will use this value.

A maximal FFTF of 0.99 will tell P3D to throw everything it has at loading in scenery, FPS be darned. Load in this setting in London or New York and a 9900k will struggle to maintain 1 frame per year. I kid, I kid. Note that with the simulator set to “Locked Frames” (at any value) will set the FFTF to 0.33.

Enter, P3Dv4

I have to admit I knew nothing about the FFTF setting until P3Dv4 was released. If you were like me, the extended autogen draw radius added enormous amount of immersion.

I always flew on unlimited frames (and thus an FFTF setting of 0.01) in previous versions without any blurries or late loading scenery. However, with the autogen setting turned up, flying a jet meant landing at airports without autogen simply because it hadn’t had time to load.

It makes sense that this ‘bug’ was introduced with P3Dv4: if you triple your autogen radius, the amount of autogen loaded around you is multiplied by 9. Flying at 250 knots over LA, there’s simply no time to load this amount of autogen before you overfly it on a setting of FFTF set to 0.01.

So, all this whole hash up to this part has been to try and explain the problem, as I have come to understand it, as best I can. You have the ability to tell the simulator what you want: higher frames or faster loading scenery.

So, what do we do? There’s two ways. One is easy, free but less-than-ideal, the other is more time consuming and requires payware, but offers the best of both worlds.

 

Option 1: Lock your frames

This has been offered as a solution on countless posts on this issue. Lock your frames which will set you FFTF setting to 0.33.

“But that makes my frame rates suffer!”

Yes, what do you expect? You have to give something to get something. Your frame rates go down because the autogen is loading faster.

 

Option 2: Dynamic FFTF

The problem with locking your frames is that the FFTF stays at 0.33 even at times when you wouldn’t want it to. This is why I originally gave up on this problem and decided to just lower my autogen radius. I was ok with lower frames during flight in order to get the autogen to kick in, but the frames would just get too low when about to land at big airports. Plus, think about it. If you’re at 500 feet, who cares if the autogen is loaded in the distance anymore? You’re not moving.

I read about this program and it has solved my problems with the autogen issue somewhat. It gives me the best of both worlds. I usually steer-clear of “auto-tweaking” programs because I think they just mess with your setup, but this one does something so specific that it works.

FFTF works two ways:

  1. locking a frame rate in and telling the program to change the FFTF setting every 5 seconds based on that value (I don’t use this setting)

  2. setting your FFTF value based on altitude (this is the fix).

The way I use it is this: I tell the program to set me for a FFTF value of 0.5 for any altitude over 5000 feet AGL. That way, when I’m on approach, autogen loads as fast as my aircraft to the horizon. This does of course come at an FPS cost, but I’m not near an airport or looking at AI traffic yet so it’s acceptable.

Below 5,000 feet AGL, the program will gradually reduce the FFTF setting to 0.01 at 0 feet AGL. Think about what that means: by the time I get on final approach at around 3,000 feet AGL in the 777, the autogen has loaded to the horizon. Now is when I want the FPS. FSDT’s KLAX is about to load in the distance as well as all the AI traffic so if I stay on a 0.5 setting for FFTF there’s no way that’s acceptable. So the program lowers it while im on approach. My FPS remains stable because while there’s more to load, now the FFTF setting has increased.

Of course the program lets you play around with these settings so you can do it to your liking. 0.01-0.50 at a 5,000 cap works well, but YMMV.

 

Sorry for the wall of text, but I hope this can be of value to some in understanding the problem for what it really is (an allocation of resources, not a bug), and how to go about fixing it.

Let’s please not turn this thread into an LM bashing thread or talk about how the problem is unacceptable as I’ve seen in other threads.

If you have any questions let me know, I’ll be happy to clarify anything.

 

Regards,

Pierre

  • Like 2
  • Upvote 4

Share this post


Link to post

Is there an option 3, to manually set your preferred FFTF setting in the cfg file?


Bert

Share this post


Link to post

For me, FFTF at 0.1 and FPS locked at 60 combinated with others parameters allow me to see autogen during the whole flight even at FL370. 😎

Share this post


Link to post
33 minutes ago, Bert Pieke said:

Is there an option 3, to manually set your preferred FFTF setting in the cfg file?

I believe if you set your frames to locked at any value and then manually change it in the cfg file, it will go to that value, yes. But others can correct me.

If you set to "Unlimited" though the sim will override your value and set it to 0.01.

Share this post


Link to post
On 4/16/2019 at 5:51 PM, BlueSky31 said:

For me, FFTF at 0.1 and FPS locked at 60 combinated with others parameters allow me to see autogen during the whole flight even at FL370. 😎

If I am not wrong, setting a FPS Limit in P3D automatically forces FFTF=0.33.


Greetings, Chris

Intel i7-8700K@5.0GHz, 2x16GB 3200MHz CL14 RAM, Sapphire RX 6900 XT SE, Windows 10 Home 64bit, Prepar3D 5.3, MSFS

Share this post


Link to post

I think the default is FFTF=O.33 locked or unlocked that's why when you takeoff and land you are more likely to get stutters and scenery loading problems, as I understand it LM set it between the best option.

There was a YouTube vid explaining this some time ago approaching KLAX. 

Edited by rjfry

i9 10900K\ASUS 490 APEX \ MSI RTX 2080Ti GAMINGX TRIO \ 3 +1TB M.2  Samsung 970 EVO Plus  \ 2 X 1TB Samsung 850 EVO \ 2TB BarraCuba SATA\ 32GB G.SKILL Z 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5.2hf

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post
1 hour ago, AnkH said:

If I am not wrong, setting a FPS Limit in P3D automatically forces FFTF=0.33.

I thought it was the default value in any case 🤔

Share this post


Link to post

Yes, it is the default. But you can change it, as you know. However, if you change it to 0.1 but still use the internal frame limiter, it has no effect and 0.33 will be used no matter what you put in your config (as I said, I am not entirely sure about this). The only way you could test this is with a limit that is higher of what you normally get (or increase the settings until you have this situation) and then compare the FPS with 0.1 vs. 0.33 or no entry in the config.


Greetings, Chris

Intel i7-8700K@5.0GHz, 2x16GB 3200MHz CL14 RAM, Sapphire RX 6900 XT SE, Windows 10 Home 64bit, Prepar3D 5.3, MSFS

Share this post


Link to post
41 minutes ago, AnkH said:

Yes, it is the default. But you can change it, as you know. However, if you change it to 0.1 but still use the internal frame limiter, it has no effect and 0.33 will be used no matter what you put in your config (as I said, I am not entirely sure about this). The only way you could test this is with a limit that is higher of what you normally get (or increase the settings until you have this situation) and then compare the FPS with 0.1 vs. 0.33 or no entry in the config.

That is incorrect if I read that right. If you set it to 0.10(uses 2 decimal places) and use the internal limiter it will take effect. Infact if you don't have the dynamic tool I would say .10 is a good place to start.

I have used the dynamic tool since the day it was released, and its obvious main positive is it can change the FFTF value on the fly while in the sim. So if you need FPS it will lower the value, and if you need regen it'll up the value based on how you set it up.

  • Upvote 2

Share this post


Link to post

Use FFTF Dynamic and set your min and max FFTF depending on fps or altitude...

 


Gerard

12900K (8 cores @ 5.1-5.5 GHz / 8 cores @ 3.9 GHz ) - Asus ROG Strix Gaming D4 - GSkill Ripjaws 2x 16 Gb 4266 mhz @ 4000 mhz / cas 16- Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 2800/1800 2TB - 1x SSD M2 2800/1800 1Tb - Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 2x 8 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 2800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
54 minutes ago, GSalden said:

Use FFTF Dynamic and set your min and max FFTF depending on fps or altitude...

 

Yep. We have done this for a long time. 

Michael Moe 


Michael Moe

 

fs2crew_747_banner1.png

Banner_FS2Crew_Emergency.png

Share this post


Link to post

I also use FFTF Dynamic with FPS locked at 30  works great for my setup.


i9 10900K\ASUS 490 APEX \ MSI RTX 2080Ti GAMINGX TRIO \ 3 +1TB M.2  Samsung 970 EVO Plus  \ 2 X 1TB Samsung 850 EVO \ 2TB BarraCuba SATA\ 32GB G.SKILL Z 3600MHZ \ Windows 10 Home\ ASUS 28" 4K monitor\ 4TB Portable Drive\P3DV5.2hf

Raymond Fry.

PMDG_Banner_747_Enthusiast.jpg

Share this post


Link to post

Good evening. I found this thread, because i have a strange behavior of my Autogen.

Till the last days i used the in windows included driver 432.00 and limited this to 30,5FPS with nvidia inspector.

It works smooth. But, i had to reduce speed during descend to get autogen back. And to go early to less then 250kts.

Since a few days, i have tried since long time the 457.30 newest driver.

I tried unlimited frames. Funny, that in that moment, unlimited frames the autogen is loading better, than before with locked and old driver.

I tried to lock the new driver, but i got micro stutters. It was not smooth anymore.

I tried, Nvidia inspector, RTSS, half refresh rate. When i am using RTSS it was smooth, but with that locked method, my core 1 goes up to 100% always. And no or not much autogen was loaded. It was too slow.

Now i found a point, changed my resolution in nvidia cotrol panel to 30hz. Oh my, it was butter smooth, except my mouse, she was then really laggy, but the sim was smooth.

CPU usage was not more at 100% and GPU usage was not as 100% as well.

But autogen was not loaded quicker, it was worse.

Any recommendations?

With this fiber tweak, what value should insert in my cfg.

8700K@5GHZ HT Off and 2080Ti, 32GB Ram.

Thank you.

Regards Marius

Share this post


Link to post

Now i got it i guess.

When i set in prepar to unlimited, the FFTF is overwrite to 0.01. That causes the slow loading autogen. OK.

No i set in prepar for example to 120. The value is by default at 0.33. That loads the autogen fast, and always, but it is CPU demand and heavy for CPU usage.

Now, when i enter the tweak FIBER_FRAME_TIME_FRACTION=0.10 in [MAIN] section, i save CPU power, the autogen in my case is loaded fast enough and have crisp textures on ground.

To made this perfect for me, i set my monitor refresh rate to 30HZ.

At first my test CPU usage at core one is much lower, than without this tweak, the autogen was loaded even with a round with a Raptor. AND, it is like butter ultra smooth experience. 🙂

I am looking forward to made a testflight tomorrow 🙂

Good night, and thanks for the nice post. You helped me really out, and after all the years in P3D, i learned something new, that i never understand before 😮

Marius

  • Like 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...