Jump to content
Sign in to follow this  
bobcat999

Flight Sim Blog - Performance Fix!

Recommended Posts

Posted (edited)

I love the Flight Simulator Blog..  They are always on the cutting edge with help and advice.  They did a version of the tree fix that worked really well, and I have never read any nonsense over there - it seems fairly well grounded in fact / logic.

Anyway, they are publishing this finding...

https://www.flightsimulator.blog/2021/03/29/dramatic-performance-drop-workaround/

Go on then...  Who is going to try this first?..  :biggrin:

Edited by bobcat999
  • Like 5

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel Core I7 8086K @ 5.1 GHz with water cooling, EVGA RTX 3080Ti Ultra (Default Profile), 32 GB RAM @ 3600 MHz (XMP), 2 x Samsung 1 TB NVME M.2.

Share this post


Link to post
Share on other sites

LOL, so you must remove all default airports and only use modded ones? 
 

That is no different to saying that in order to eliminate aviation accidents, don’t build aircraft. It will work....😁

  • Like 3

GregH

System Spec: Core i7 6700K @ 4,7GHz; GTX980Ti, 32GB DDR4 3200; WD Black NVMe; Samsung EVO850 SSD; CH Products Yoke, Pedals & Quad; Airbus Side Stick, TrackIR; 1440p

Share this post


Link to post
Share on other sites
Posted (edited)

They should stick to fixing the Tree Draw Distance.

However, Bobcat - being a qualified MSFS2020 Test Pilot - I will try it now. . .

If I'm not back here posting in 30 minutes assume the worst.

 

Edited by Will Fly For Cheese
  • Like 7
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

I think we might be missing the point.  There may be clues here as to what is happening. 

This is for Asobo to fix I know, but people reported some of the symptoms disappearing when they gradually uninstalled the world scenery packs. 

Looks like something needs optimising somewhere for sure.

Just trying this now.  No major drama.  Drag a few folders somewhere else - drop them back later.  Trying Salzburg now, a major pause-fest for me normally.

First time in was a long load until I found steam was updating Xplane in the background and pinching all my bandwidth!  Piece of word not allowed!  (steam, not Xplane). :biggrin:

Edited by bobcat999
  • Like 3

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel Core I7 8086K @ 5.1 GHz with water cooling, EVGA RTX 3080Ti Ultra (Default Profile), 32 GB RAM @ 3600 MHz (XMP), 2 x Samsung 1 TB NVME M.2.

Share this post


Link to post
Share on other sites

I don’t have world packs and great FPS!

Share this post


Link to post
Share on other sites

But isn't it the same as P3D with Vanilla scenery or P3D with Orbx England installed? - you're going to take a Frame hit for the latter (typically 15-20 FPS)

Someone has figured out that if you remove complex Airports from the sim in MSFS 2020 you're going to gain frames.

Did we not know that?

  • Like 1
  • Upvote 1

Share this post


Link to post
Share on other sites
Posted (edited)

No Cheese, its not the fact that you are at the complex airports, it is that they are (allegedly) affecting the sim in some way just by being in the scenery folder, even when you are not near them.  Anyway, its inconclusive yet (for me).

Having to restart my PC to test again.  Major bandwidth problems tonight.  If it isn't steam pinching it, its windows update! :unsure:

Edited by bobcat999
  • Like 2

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel Core I7 8086K @ 5.1 GHz with water cooling, EVGA RTX 3080Ti Ultra (Default Profile), 32 GB RAM @ 3600 MHz (XMP), 2 x Samsung 1 TB NVME M.2.

Share this post


Link to post
Share on other sites

Okay. I understand.

i've done it - as you said - and the frames are looking a bit snappier than they were.

Going up now and will report back.

(And I BACKED UP the files in to a separate Folder so they can be put back)

  • Like 1

Share this post


Link to post
Share on other sites
Posted (edited)

I am not doeing this method Dramatic Performance Drop Workaround - Flight Simulator Blog

Today i have a superb flight with a 747-8 from YSSY to WADD beautiful Bali from Aerosoft and i don`t realy saw performance hits that boders me - 5h40mins flighttime no CTD and a dream of a flight

so why i should do this; if it keeps like that i will wait for the next performance update from Asobo, it shure will come.

The other is i have the feeling this 1.14.6.0 performance update did a lot - good job Asobo ! 😎

 

cheers 😉

Edited by pmplayer
  • Like 1

My Rig : Intel I7-7820X 8 Core ( 16 Threads ) @ 4,5,  Asus Prime X299-A,  32 GB 3600-16 Trident Z,  750W Corsair CX750 80+ Bronze,  MSI 8GB RTX 2080 Super Ventus XS OC,

WD 4TB and WD 6TB 7200 HD,  Windows 10 V.1909 - Now on Win10 V.21H1, in use 3 4K monitors 2x32 Samsung 1x27 LG  3840x2160.

Share this post


Link to post
Share on other sites
14 minutes ago, Will Fly For Cheese said:

If I'm not back here posting in 30 minutes assume the worst.

Godspeed Mr. Cheese.

Not my my machine, but KPDK Dekalb-Peachtree is another performance black-hole (has been prior to SU/WU3 and seems to be a repeatable use-case). Could you please give that a try?

Share this post


Link to post
Share on other sites
Posted (edited)

Well my fps and general smoothness was great, but sorry to report it did not cure my Salzburg problem. 
Approach from the south, touch and go in the C172, turn to the right (East) and it is a complete stutter-fest. 
Do the same but turn to the left, west of the airport, and it is dead smooth. 

Go back to the East of the City and the dreaded pauses come back again.  It is showing the usual 'manipulators' problem with GPU dropping to zero utilisation for seconds at a time.  Sometimes difficult to get back to the menu even (Esc key) it is that bad.

Maybe it is a different issue and the scenery is broken in this area.  It used to be one of my favourite flights and was dead smooth a few months ago - it's a pity.

So, I moved the scenery files back as the Salzburg runway looked like a roller-coaster with them removed.  :unsure:  Nothing else to do but wait for Asobo to fix it I suppose.

Edited by bobcat999
  • Like 3

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel Core I7 8086K @ 5.1 GHz with water cooling, EVGA RTX 3080Ti Ultra (Default Profile), 32 GB RAM @ 3600 MHz (XMP), 2 x Samsung 1 TB NVME M.2.

Share this post


Link to post
Share on other sites

Back on the ground with Engines off. 

It does fly better wth this Fix bobcat, definitely - reckon I had 5-8 FPS better than I had. (and that's the difference between Yellow and Green and NOT being limited by Main Thread)

Nice one bobcat - it certainly works a treat.

DylanM - go try it - just back up the folder before you do - so if it doesn't work for you, you can come back to where you were.

We are all Virtual Aviator Pioneers - in this new synthetic Environment.

I'm so glad my Copilot came along for the ride;

yjghjg.png

 

  • Like 3

Share this post


Link to post
Share on other sites

@Will Fly For Cheese  Well... At least your co-pilot cheered me up! 

I think it is fairly obvious we are looking at more complex issues here, with many factors causing different performance issues. Maybe interlinked, or maybe not. 

Asobo must be pulling their hair out trying to trace them - obviously not easy or they would have done it by now.

I wonder what they found at 76T?  They fixed that up well.

 

  • Like 1

I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel Core I7 8086K @ 5.1 GHz with water cooling, EVGA RTX 3080Ti Ultra (Default Profile), 32 GB RAM @ 3600 MHz (XMP), 2 x Samsung 1 TB NVME M.2.

Share this post


Link to post
Share on other sites

@bobcat999 why not try the "Cheese Fix". Remember the problems Bob had on the weekend .

Something about removing the fs-base-nav folder and let the sim update it.

Just maybe ...

  • Like 1

Intel i7 - 6850K @ 3.60 GHz   |   Palit JetStream RTX 2070 Super  |  32 GB RAM  |  Saitek peripherals

Share this post


Link to post
Share on other sites
10 minutes ago, SAPilot said:

@bobcat999 why not try the "Cheese Fix". Remember the problems Bob had on the weekend .

Something about removing the fs-base-nav folder and let the sim update it.

Just maybe ...

Thanks!  I will take a look.


I like to fool airline passengers into thinking I have my own swimming pool by painting a large blue rectangle on my patio!

Intel Core I7 8086K @ 5.1 GHz with water cooling, EVGA RTX 3080Ti Ultra (Default Profile), 32 GB RAM @ 3600 MHz (XMP), 2 x Samsung 1 TB NVME M.2.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...