Jump to content
Sign in to follow this  
GSalden

Lower fps and framerate reduction over time

Recommended Posts

Here I use 2 pc’s.

8700K @ 5.0 / 16 Gb 3600 mhz  / 3090 / M2 /  1x 4K display

9740 @ 4.7 / 32 Gb 3200 mhz / 3090 / M2 / 2x 4K as one front view

After the latest update the 9740 pc shows about 10-15% lower fps than before. No big issue as at Schipho EHAM with lots of Live Traffic (AIG)  I can have 45 fps. With Vsync On and 30 hertz it is good.

However, after flying for 2 hours the fps has dropped till 26 which means 15 ( vsync / 2 ). And the ac is flying at 35000 ft with little clouds over the Mediterranean….

Wheh I make the view smaller so it fits on 1 screen the fps stays low. 

Anyone experienced this ?

https://www.dropbox.com/s/cfy2uzabpknnc8p/Foto 25-11-2021 19 45 20.jpg?dl=0

 

Edited by GSalden

Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites

Try turning traffic off, apply and save, then turn back on, apply and save. That helped my situation. 

  • Like 1

/ CPU: Intel i7-9700K @4.9 / RAM: 32GB G.Skill 3200 / GPU: GTX 1080ti 11GB /

Kyle

Share this post


Link to post
Share on other sites

All traffic is Off inside MSFS  I use PSXT Live Traffic.

But even with PSXT not running ( so no Live Traffic ) this occurs.


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites

It's an old bug that's been around for a long time now, probably a memory leak


| Intel I9 10900K | Corsair 32Gb 3200MHz | Asus Rog Strix OC 2080Ti | Samsung 970 EVO Plus 1TB |

Share this post


Link to post
Share on other sites
27 minutes ago, RALF9636 said:

But in my case low cpu usage, low RAM usage, low VRAM usage. But the fps drops. If there was a memory leak I would see that….

My cpu can go up to 4.7 but stays around 4.3 as there is little load on the cores ( see the link with screenshot in my first post ).


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites
4 minutes ago, GSalden said:

But in my case low cpu usage, low RAM usage, low VRAM usage. But the fps drops. If there was a memory leak I would see that….

My cpu can go up to 4.7 but stays around 4.3 as there is little load on the cores ( see the link with screenshot in my first post ).

Can you do me a favor. When it does happen, can you enable the developer mode and select display fps. I am curious to see if you get the same issue have been reporting for a while The manipulator threads will go crazy and have a really high ms response.


https://fsprocedures.com Your home for all flight simulator related checklist.

Share this post


Link to post
Share on other sites
17 minutes ago, GSalden said:

But in my case low cpu usage, low RAM usage, low VRAM usage. But the fps drops. If there was a memory leak I would see that….

My cpu can go up to 4.7 but stays around 4.3 as there is little load on the cores ( see the link with screenshot in my first post ).

Yes, that's what I see as well. I don't think it is a memory leak, must be something else. 

Nevertheless the issue exists for a while. It happens sporadically to me, mostly when flying in Europe. I haven't found a way to reproduce it or narrow down the possible cause. Seems Asobo hasn't either so far.

 

Share this post


Link to post
Share on other sites

Making now a route from EBBR-ESSB with A32nx and i had also a weird frame drop ( from Denmark to Sweden) which stayed stable to 30s-40 fps. Usually i have over 60s on cruise conditions. I thought it was AI traffic ( AIG or AIGT) in the beginning  but after many tests i went back to go 60s by reducing terrain level of detail. 100% cpu main thread issue 

 


i9-11900K •  ASUS ROG-STRIX 3090 OC • Asus ROG-Maximus Hero XIII • G.Skill Ripjaws V 64GB DDR4 3600 CL16 • Asus ROG Swift PG279Q 27" Gaming Monitor  • VKB-Sim Gladiator Mk.II • Thrustmaster TCA Quadrant Airbus Edition

Share this post


Link to post
Share on other sites

Made a complete flight from Amsterdam to Bodrum. See the fps after landing ! !

https://www.dropbox.com/s/kmlzonzmrrs2q4o/Foto 25-11-2021 12 34 54.jpg?dl=0

The Main thread is now 69.4 ms ….The manipulators are 59.8 ms ….

Fps just 14 ….
Load on the cores was low. Enough RAM, enough VRAM 

- - - 

To compare : here 10 min after startup at Amsterdam Schiphol. See the big difference:

https://www.dropbox.com/s/3rxbkcy8o3tzt0j/Foto 26-11-2021 07 40 20.jpg?dl=0

 

Edited by GSalden

Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites
10 hours ago, GSalden said:

low cpu usage

Across all cores it's low but if you open task manager you will see that one thread is maxed out. AI traffic is on the main thread and when you fly for a long time the poor single core has to deal with dozen of aircraft.

I bet that if you disable traffic completely the framerate returns to normal values.

It's the same old story, maybe FS2030 will use multithreading properly.

  • Like 1

i9 10850K / 32 GB 3200 MHz CL16 / RTX 3090 / Acer Predator X34P

Share this post


Link to post
Share on other sites
28 minutes ago, MrFuzzy said:

Across all cores it's low but if you open task manager you will see that one thread is maxed out. AI traffic is on the main thread and when you fly for a long time the poor single core has to deal with dozen of aircraft.

I bet that if you disable traffic completely the framerate returns to normal values.

It's the same old story, maybe FS2030 will use multithreading properly.

As you can see in my first screenshot none of the cores is maxed out….

What I do agree upon is that it might have to do with AI aircraft.

I just finished a test at Schiphol spotting AI aircraft. Within the 20 minutes I tested the framerate went done another 4 fps.

At this moment I am making the same 3h flight but without AI aircraft to see what will happen.

Will report back in this thread….


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites
20 minutes ago, GSalden said:

As you can see in my first screenshot none of the cores is maxed out….

Yes, now I saw it... it was 83%. But it was also 300 MHz below the frequency of the others. Maybe it actually gets maxed out and throttles down to 4 GHz to avoid overheating? 

I don't understand how the CPU temperature can be 33 °C honestly 🙂  Are your sensors OK or it's picking up  the water temp sensor...?

Edited by MrFuzzy

i9 10850K / 32 GB 3200 MHz CL16 / RTX 3090 / Acer Predator X34P

Share this post


Link to post
Share on other sites
1 hour ago, MrFuzzy said:

Yes, now I saw it... it was 83%. But it was also 300 MHz below the frequency of the others. Maybe it actually gets maxed out and throttles down to 4 GHz to avoid overheating? 

I don't understand how the CPU temperature can be 33 °C honestly 🙂  Are your sensors OK or it's picking up  the water temp sensor...?

My system is pull/pushed liquid cooled. Therefore the low core temps.

Just did another test. It was a 3h flight but after half an hour I set the sim to 2X speed and let it run for 45 minutes.

When I came back I saw a framerate drop to 19 fps ! At 35000 ft … No AI aircraft enabled this time.

https://www.dropbox.com/s/q0r77cgsphi3wwq/Foto 26-11-2021 11 07 50.jpg?dl=0
 

Later today I will do the same 3h flight only then at normal sim speed.


Gerard

7940x ( 14 cores ) : 14 cores @ 4.7 - Gigabyte X299 Gaming 7 - 32 Gb G.Skill Trident Z 3200Mhz Cl 14 - Inno3D RTX3090 X4 iCHILL 24 Gb - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - Thermaltake Level 10 GT case - EKWB Extreme 240 liquid cooling set push/pull - 2x 43” Sony 4K tv's in NVSurround

8700K : all 6 cores @ 5.0 GHz - Asus ROG 370 - 16 Gb 4000 MHz @ 3600 Mhz - Inno3D RTX 3090 X3 iCHILL 24 Gb  - 1x SSD M2 1800/1800 2TB - 2x  Sata 600 SSD 500 Mb - 1x 55” Sony 4K tv

My flightsim vids :  https://www.youtube.com/user/fswidesim/videos?shelf_id=0&sort=dd&view=0

 

Share this post


Link to post
Share on other sites
3 hours ago, GSalden said:

My system is pull/pushed liquid cooled. Therefore the low core temps.

Just did another test. It was a 3h flight but after half an hour I set the sim to 2X speed and let it run for 45 minutes.

When I came back I saw a framerate drop to 19 fps ! At 35000 ft … No AI aircraft enabled this time.

https://www.dropbox.com/s/q0r77cgsphi3wwq/Foto 26-11-2021 11 07 50.jpg?dl=0
 

Later today I will do the same 3h flight only then at normal sim speed.

Which is your terrain level of detail? I had the same fps drop during cruise ( after 1 hour of flight ) and only when i reduced tod from 200 to 100 i  brought back my usual  fps/performance.


i9-11900K •  ASUS ROG-STRIX 3090 OC • Asus ROG-Maximus Hero XIII • G.Skill Ripjaws V 64GB DDR4 3600 CL16 • Asus ROG Swift PG279Q 27" Gaming Monitor  • VKB-Sim Gladiator Mk.II • Thrustmaster TCA Quadrant Airbus Edition

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    53%
    $13,405.00 of $25,000.00 Donate Now
×
×
  • Create New...