Jump to content
Sign in to follow this  
Rob G

Question about In-Sim Vsync

Recommended Posts

So I was trying to play around with the In-Sim Vsync settings today. I was using the In-Sim Developer FPS counter as a guide. MSFS was on a monitor that was configured to 60Hz so I turned on Vsync and set it to 50% of monitor framerate. However, instead of it indicating something around 30 FPS, which was what I was expecting, the In-Sim framerate counter would not go above 12fps.

 

UPDATE: OK, more information but I am still confused: I have two monitors. One was set to 24Hz for refresh rate and one was set to 60Hz. I had MSFS running on the monitor set to 60Hz. However, when I set the In-Sim Vsync on and set it to 50% of refresh rate, it ended up at 12 FPS, which was half the refresh rate on the monitor it was not running on. I know that's what happened because when I changed the refresh rate of that monitor to 60HZ, the FPS counter in the sim landed on 30FPS.

But why would it be executing Vsync based on the monitor it is not running on? That makes no sense to me.

Edited by Rob G

Intel i9-10900, ASUS ROG Maximus Hero XII WiFi motherboard, 32GB of 4000Mhz CAS 15 memory, ASUS GEFORCE RTX 3090, 1000watt power supply, 2 NVME drives and 4 SSD's, Oculus Quest 2

Share this post


Link to post
Share on other sites

Perhaps it reads both and chooses the lower one, or perhaps the lower one is set as the main monitor?
Either way, you appear to have found the ideal solution.

 

  • Like 1

Share this post


Link to post
Share on other sites

Yes, so you have found a potential reason for it, so it sounds like you just need to experiment a bit as I have not seen anyone run into this same situation before.

Although MSFS might not be running on the slower one, it is all part of the same overall video output. 
Normally a computer picks a setting that can definitely run on both monitors, so that is probably what has happened. 

I have not seen anyone run a monitor at 24Hz; normally 60Hz is the lowest. Is there a reason for the 24Hz?


Call me Bob or Rob, I don't mind, but I prefer Rob.

I like to trick airline passengers into thinking I have my own swimming pool in my back yard by painting a large blue rectangle on my patio!

Intel 13900KF in a ROG Strix Z690 motherboard with water cooling, EVGA RTX 3080Ti, 32 GB Patriot 4400 DDR4 RAM (but running 3800 CL15), 3 x Samsung 1 TB NVME M.2, with MSFS on a Samsung 980 pro (7 GB/s).

Share this post


Link to post
Share on other sites

Using VSync and setting my framerate to 50% (30 fps) is smooth enough for me and I can use a higher LOD (300) and ultra settings as the graphics card is only having to produce half as many frames.

 

running msfs at high priority also seems to be helping with smoothness.

  • Like 1

Ryzen 5600X, AM4, 6 Core 12 thread - Nvidia 3080 - 32 Gig DDR4 RAM - Windows 11 64 bit MSFS 2020 Premium Deluxe Edition Resolution 2560 x 1440 (32 inch curved monitor)

Share this post


Link to post
Share on other sites
4 hours ago, cianpars said:

Using VSync and setting my framerate to 50% (30 fps) is smooth enough for me

It was smooth enough for me in P3D then MSFS since launch...until I discovered a pathway to essentially zero frametime variance and produced a smoothness in a class of its own, I dare say perfect smoothness, and it is not matched by in-sim or NCP Vsync.  That pathway is RTSS' framerate limit (not scanline sync) with front edge sync.  This method while producing perfect smoothness even at a frame rate of 30 comes with a show-stopping detriment:  it creates a horizontal 'tearline' that migrates up the monitor with each pass.  Oftentimes you won't notice it unless it's in your FOV.   Cpt_Piett kindly did a frametime variance check w/ his Gsync screen and determined you get very decent FTV w/ the Gsync screen.  So I bought a new Gsync screen and discovered using RTSS' framerate limit  w/ front edge sync loses the tearline and retains the smoothness so is the best possible option.   Plus, I really like fact you can alter framerate lock in RTSS w/o stopping the sim.  So my practice involves seeing what unlocked framerate gets to as I'm ready to pushback then setting the lock maybe 6 or so frames below that to give a little headroom.  For example at EDDH this morning unlocked rate was around 41 or so, so set the lock to 35 and had perfect smoothness.  I prefer this to give both CPU and GPU headroom because when you can simulate perfect animation at less then unlocked the CPU/GPU do not need to work as hard, so runs at lower power and temp and there is nothing of substance sacrificed in this versus unlocked.

Edited by Noel
  • Like 1

Noel

System:  9900K@5.0gHz@1.215v all cores, MSI MPG Z390M GAMING EDGE AC, Noctua NH-D15S w/ steady supply of 40-60F ambient air intake, Corsair Vengeance 32Gb LPX 3200mHz DDR4, Sabrent NVMe 2Tb x 2, RTX 3080 Ti FE, Corsair RM 850W PSU, Win10 Pro, Dell curved 3440x1440, TCA Boeing Edition Yoke & TQ, Cessna Trim Wheel, 30 frames vSync to 60Hz.

 

Share this post


Link to post
Share on other sites
5 hours ago, Noel said:

That pathway is RTSS' framerate limit (not scanline sync) with front edge sync

Noel, where exactly does one set 'Front Edge Sync' ?


Intel 13900K w/32 Gb GSkill DDR5 RAM, EVGA 3090 Ti Ultra GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Thrustmaster A-10 Throttle and Virpil Constellation Alpha Stick and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites

Its set in the "Compatibility properties" section in the setup menu. Its the drop down next to "Enable Framerate Limiter".

As an aside this also allows you to use RTSS with frame generation on the 4090 but does induce some noticeable latency.

 

  • Like 1

Chris Warner

 

PMDG : JS4100, MD-11, 737 NGX (Soon!)

Share this post


Link to post
Share on other sites
59 minutes ago, MrRoper said:

Its set in the "Compatibility properties" section in the setup menu. Its the drop down next to "Enable Framerate Limiter".

As an aside this also allows you to use RTSS with frame generation on the 4090 but does induce some noticeable latency.

 

Thank you, I appreciate that. I looked in there but missed the dropdown menu. 


Intel 13900K w/32 Gb GSkill DDR5 RAM, EVGA 3090 Ti Ultra GPU, lots of SSD's and M.2 drives, Fractal Torrent Case, Thrustmaster A-10 Throttle and Virpil Constellation Alpha Stick and MFG Rudder pedals. Currently on Win11

 

 

Share this post


Link to post
Share on other sites
On 11/24/2022 at 4:13 PM, Rob G said:

OK, more information but I am still confused: I have two monitors.

If I remember correctly.. RTSS would divide the refresh rate by the number of monitors..

If that is still going on, you might have 50% of 60Hz / 2.

Edited by Bert Pieke

Bert

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this  

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
×
×
  • Create New...