Sign in to follow this  
Darcy

Anyone found a solution for the stuttering/pause in 4.01?

Recommended Posts

I love this program but I had to go back to 4.0 so the stutterin/pausing would go away. I have tried the things suggested in other posts but was wondering if someone had success in stopping the pausing that happens just before someone speaks?Seems funny to me that 4.0 works without stuttering and the update stutters. Oh well just checking and like I said I love flying with Radar Contact!ThanksDarcy Coutts

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I agree.....I too had to go back to 4.0...Too much hesitation between communications......But, like you, I enjoy RC, that I continue to use it in it's original format...Paul

Share this post


Link to post
Share on other sites

I guess I have the same problem. Haven't noticed any stuttering but the delay between communications is way too long. For example, when told to contact Center, I get yelled at because it takes too long to make the call. It usually takes 30 to 40 seconds for the required responses to start. Takes over a minute to get ATIS. I uninstalled the whole program and reinstalled ver. 4.00 only. Worked fine. Installed 4.01 and the delay is back. I too will have to just use 4.00 and not 4.01 unless a fix is found for this.Jim

Share this post


Link to post
Share on other sites

I wonder how many there is like us? Anyways just did another flight on 4.0 and I couldn't go back to FS ATC.

Share this post


Link to post
Share on other sites

I had to roll back too. I was going to post to see if JD had come upwith a solution or if it is possible to get the other enhancements in the update without the voice "stiching". So we can have the best of both worlds.Glenn Thomson

Share this post


Link to post
Share on other sites

Hi Darcy and all,I conducted a survey amongst the RC beta testers and from the responses I had there were no obvious pointers as to why some experienced the problem and others didn't.The only clear indication was that those running RC4 via WideFS (i.e. on a separate PC to FS) didn't suffer the problem. If any of you have a spare PC with sound capability that might be an option. A modest PC will run RC4 quite happily.I have noticed that amongst those who reported the problem there were more Athlon users than Pentium ones. Whether the Athlon can handle multi-tasking as well as a Pentium with Hyperthreading is open to debate.So for now I'm sorry I can't thrown more light on the problem. Speaking personally I haven't experienced it so it's hard to gauge how annoying it is.

Share this post


Link to post
Share on other sites

Ok, maybe only a few users have this problem, maybe though a lot do have this but simply don't post here for one or another reason.Till now i thought at least the RC team would be working on a patch to get rid of the stutters (and/or delays as described above) but it seems nothing is happening? So, basically the people who experience the stutters and delays won't ever be able to upgrade to a new patch/update?I think the statement that maybe a pentium with hyperthreading can handle this better than an Athlon and leave it there is too easy.Any powerful processor should be able to handle the workload, it also works fine in version 4.0, right?. There must have been a change in the routine to create the wavs which causes this... Maybe it's an idea to release some beta patches to people who experience these problems to see where the problem exactly is and from there work on?Don't get me wrong, i love the program and use it every day but i would like to upgrade too without having to buy an intel ;)Cheers,Martin

Share this post


Link to post
Share on other sites

Just for the record I am running a Pentium 2.0 Audigy 2. Frame rates are fine. I too just want to help because this program is that good!

Share this post


Link to post
Share on other sites

Hi Martin,Radar Contact is programmed by one person - John Decker. He is aware of the problems some are having and he will probably add to this discussion.The stutters have come about as a result of a single change in the way the wavs are gathered and played. In 4.0 each wav to be played is located and then played. So for "Speedbird 1234" there are 5 seeks and five wavs played. Many who bought v4.0 complained that speech was not fluid so John looked at a way of speeding things up and making speech more fluid.So with v4.01 he now looks at what wavs he needs to play and gathers them all in a single action. Having gathered them he then strings them together and adds a variable amount of 'silence' between each wav depending on the slider position selected for that 'voice'. Five wavs gathered - one action to play them. On paper, far more efficient and during testing no-one on the team reported any problems. In fact, quite the opposite. many of us felt the voices were much better.Herein lies the problem. If the action of gathering the wavs is causing a pause before an instructon is played I don't know how that can be eliminated. I'm not a VB programmer so I can't say what's possible and what's not.The way the wavs are retrieved with v4.01 is far more efficient but relies perhaps on enough system resources to retrive them quickly enough. For those of you with a single PC try locking your frame rates at 30 or 25 and see if it makes a difference. If it does then it's clear that if you give the system a fighting chance it will help RC4.<>To release a beta patch we would have to design a different system of retrieving the wavs. I don't know if that's possible. We'll discuss it amongst us and see what's possible.I'm sorry I can't give you better news but rest assured we are aware of your frustrations and will do what we can to make things better.Cheers,

Share this post


Link to post
Share on other sites

Me got those problem of stuttering/pause, My system PIV 2Gig ram 6800GTI hypertrading enable I have even install on a fresh winxp FS activesky LDS767 RC4 with the last update v4.01.When i ask to ground for delivery it take's a while before the answer,and when I fly for stuttering problem I got sovently reproach for not respecting altitude end so on, with the last version there are also some CDT wich i don't think other addon cause it.hope this contribute.Fabrizio

Share this post


Link to post
Share on other sites

To let you know: I have frame rate locked at 22 and still got the stutters. This is a good discussion and I hope it helps out in the long run.Thanks

Share this post


Link to post
Share on other sites

I get the stuttering too, even while just cruising. :(How do you roll back to version 4.0?

Share this post


Link to post
Share on other sites

I suggest that you try to disable HT (Hyperthreading) and see if that changes anything.In my sparetime I play-around with sythesizers and samplers (both hardware and software) and the on PC I use for that purpuse I have disabled HT since I otherwiser experience studders when I have too many software- synthesizers/samplers/effects going on at the same time.I am not sure if this will fix anything with RC4 (since I am myself running RC4 on a separate PC, and have never had any studder-problems with RC4), but I think it will be worth a try, and I would like to hear your findings.Also see perhaps if you can setup you Anti-virus system to exclude the RC4 folder from its realtime protection scans. Some AV-products introduce a lot of overhead while scanning files and RC4 relies on lots of wav-files.http://jdtllc.com/images/rcv4bannerbeta.jpgPelle F. S. Liljendal

Share this post


Link to post
Share on other sites

Hi Ray, thanks for the explanation about how the wavs are 'compiled' in the new version. Btw, i don't have the problem of the delays but the freezes and stutters instead. Well, i will keep on experimenting too like trying different hard disks etc. My framerates are locked already because i think it's a good thing to do anyhow and i always disable antivirus, firewalls etc during fs9 sessions. It might have to do with the write caching maybe...Thanks and i hope one of us can find a solution (other than using another pc etc ;) )Martin

Share this post


Link to post
Share on other sites

I must say that Ive upgraded with the patch and dont have any problems at all that are described above. I find it really improves the fluidity of the voices and I no longer have the gaps inbetween words.I am running on a single pc with dual monitors. Processor is AMD64 4000XP.Graham

Share this post


Link to post
Share on other sites

There really doesn't seem to be any really simple answer (otherwise someone clever would have popped up with it). For example, I have quite a low grade spec pc AMD Athlon XP3000 2.17GHz - 1Gb RAM and I have nothing like the problems mentioned above. I guess one of the real difficulties as outlined by Ray above is that very few of the beta team (if any) have the stutters and so the 'fix' is difficult to nail.

Share this post


Link to post
Share on other sites

Hi Martin and all,We had a discussion amongst the beta testers and someone mentioned he was running RC4 on a separate hard drive to FS9 and he wasn't sufferring with pauses, stutters etc. Now it so happens that I am also running RC4 on a separate drive without problem so I wonder if this might be a factor. Given the number of times RC needs to access the drive if FS is also trying to access data at the same time then there are going to be delays whilst data is recovered.If you have a spare hard drive then try installing RC4 to that. I appreciate it's a pain because of the large number of files and you will need a new key of course but it could be the answer. It's certainly worth a try and more palatable perhaps than junking the Athlon for a Pentium ;-)Cheers,

Share this post


Link to post
Share on other sites

I don't think its the Athlon vs Pentium because I have a Pentium and have the problem. Do you think it could have anything to do with the "Allow Indexing Service to index this disk for fast file searching"? This is under hard drive properties. I have this unchecked.Maybe those who are getting the stutter/pausing might let me know whether that is checked or unchecked? I hate to reinstall then uninstall then reinstall.Also if anyone tried putting RC4.01 on another drive and this corrected the problem could you let us know.Thanks

Share this post


Link to post
Share on other sites

HI, I have it installed on a seperate (almost dedicated ;) ) harddisk and it made no difference in the stutters. I was also thinking about the indexing service and just unchecked it to see if it would make a difference but according to your post i don't think so then ;)But i keep trying, i will now disable write caching on the disk ;)

Share this post


Link to post
Share on other sites

Hi there,I'm suffering from stutters as well, however I'm willing to do anything to help get this fixed as the faster voices made this program what I consider "the perfect ATC addon"!!!!Unfortunately I don't have a spare PC but I'm willing to try out anything. I am running FS9 from a clean boot (msconfig) and defrag once a week or after adding/removing software. I'm also using avast, which is turned off while simming though. I have a generic sound card with latest drivers but it sure is not a creative card ;-)See my sig for system info. Let me know if I should provide more detail.Cheers,Petehttp://members.aol.com/pzsoulman/myhomepage/logo.gifAMD64-3400,1GB/2700DDRAM,WinXP(SP2),DirectX9.0c,Geforce6800(128MB)(Det.71.89), CH Yoke/Pedals

Share this post


Link to post
Share on other sites

Hi Darcy,I hope I wasn't suggesting Pentium = Good, Athlon = Bad. I just said that of those who had reported the problems more had Athlons than Pentiums.Good suggestion on the indexing service but mine is enabled and doesn't cause a problem. But try it - there's nothing to lose.Also, change one thing at a time. Try reverting from a PMDG737/747 panel to a default one for a single flight and see if that makes a difference. Try the default weather instead of AS6. Keep your hard drives defragmented. Shutdown anti-virus programs of course.I've just had a suggestion from JD. Try lowering your scenery complexity levels to medium adn see if that makes a difference. Anthing that takes some of the pressure off the CPU allowing it more cycles will help. You all know your systems better than us. If anyone on the team had this problem we'd be bombarding them with questions. If only...Cheers,

Share this post


Link to post
Share on other sites

Hi all again ;)Tried indexing on and off, write cache on and off, no difference. What i would like to try is a completely different harddisk, other brand, etc. Is there a way to move the installation to a different hd or do i have to reinstall it all then?Martin

Share this post


Link to post
Share on other sites

Hi Martin,Once you introduce new hardware to your system you may require another key. But that won't be a problem. Just send the info to Rick.Copy the whole RC4 folder to the new drive and then open RegEdit and do a find and replace on Radar Contact replacing the old drive letter with the new one. That should work. You might post details of the old/new drives for info.Thanks,

Share this post


Link to post
Share on other sites

Evening all.....I was lucky enough to help beta test the update and I have to say I found no problems as mentioned above. I use an AMD XP3700+ with 2GB PC3200 an GeForce 6600 and a Maxtor 7200 120GB disk. RC runs via WideFS. My guess would be that the issue has to be with CPU/hard drive access bottleneck. I've listed below a few of the tweaks that I use which have certainly helped my system run to the best of its ability, perhaps they may help some of you!I use systembooster xp which is free to try for 30 dayswww.systembooster.comThis tweak does not only apply to folders but also programs. Basically when you run a program it gets its own memory allocation. It also gives you a much more stable system. Programs run faster but it does also utilize more RAMUnder - My Computer/Tools/Folder Options/View - check "Launch folder windows in a seperate process" this allows each operation to have its own memory address rather that swapping out everytime some thing runs - should only be used with 1GB memory and above and will also increase stability.***WARNING - DO NOT USE THIS TWEAK IF YOU ARE USING AN ATI VIDEO CARD. IT COULD LEAVE YOUR SYSTEM UNBOOTABLE***Under - CONTROL PANEL/SYSTEM/ADVANCED/PERFORMANCE/SETTINGS/ADVANCED/MEMORY USAGE. Change the option from Programs to System Cache.

Share this post


Link to post
Share on other sites

Nice tips, i will try some out tonight. Ray, it's another existing hard disk which i will use so i think i won't need another key.This evening i will try out and if anything comes out i will post here ;)Martin

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this