Jump to content

Archived

This topic is now archived and is closed to further replies.

bojote

Simple Stutters Fix for FSX

Recommended Posts

Something you need to know first:Stutters can happen for SEVERAL reasons, they can be due to memory timing problems, CPU reaching 100%, GPU overheating / overload... there are literally 'hundreds' of reasons why you would experience stutters, this FIX is not a 'magical' solution to your stuttering problems, however there is a procedure that will fix 100% of your autogen induced stutters.This 'fix' assumes you have a HEALTHY machine and that you ONLY experience the stutters when panning around in high density autogen areas EVEN with bufferpools disabled.The fix involves editing the Autogen/default.xml file in your FSX root directory and making sure it is saved in UTF-8 format. This is a VERY simple step to follow, you only need to:1) Open the Autogen/default.xml file in notepad2) Once you open it, you'll notice the FIRST line of the file contains: <?xml version="1.0" encoding="utf-16"?>3) Change the above line to this: <?xml version="1.0" encoding="utf-8"?>4) Save the changes and thats it!A word of caution: When you do this change, the next time you open FSX you'll see that the A/C in the welcome screen has no textures. there is nothing to worry about, this happens everytime there is a change to the default.xml file, and the second time you start FSX everything will be fine.FSX 'parses' XML files 'assuming' they are in the format indicated in the encoding field. The default.xml file is an ASCII only file, but its encoding is set to UTF-16, which is completely absurd. (ascii files in UTF-16 encoding take TWICE as much space), yet this file is NOT encoded in utf-16, just the XML header says so, and the XML parser in FSX will treat it as such. This 'fix' will also give you some aditional FPS! try it.If you want to see for yourself:1) Add to the [TERRAIN] section of your fsx.cfg file the following entries (this is just temporary) just for testing purposes: TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=6000 TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=60002) Start FSX and set the Autogen slider to EXTREMELY DENSE3) Go to PNW (the most autogen intensive product I have) and takeoff from KSEA airport, take a fast Jet, spin around while looking around the VC using the mouse. Preferably, 'record' a test flight with FSRecorder with a sampling rate of '1 frame' and re-play it while moving your mouse to look around the cockpit while the recording is playing. Do it with the default.xml before and after the utf change so you can objectively judge for yourself.Enjoy!

Share this post


Link to post
Share on other sites
Something you need to know first:Stutters can happen for SEVERAL reasons, they can be due to memory timing problems, CPU reaching 100%, GPU overheating / overload... there are literally 'hundreds' of reasons why you would experience stutters, this FIX is not a 'magical' solution to your stuttering problems, however there is a procedure that will fix 100% of your autogen induced stutters.This 'fix' assumes you have a HEALTHY machine and that you ONLY experience the stutters when panning around in high density autogen areas EVEN with bufferpools are disabled.The fix involves editing the Autogen/default.xml file in your FSX root directory and making sure it is saved in UTF-8 format. This is VERY simple step to follow, you only need to:1) Open the Autogen/default.xml file in notepad2) You'll notice that the FIRST line of the file contains this: <?xml version="1.0" encoding="utf-16"?>3) Change the above line to <?xml version="1.0" encoding="utf-8"?>4) save the changes.A word of caution: When you do this change, the next time you open FSX you'll see that the A/C in the welcome screen has no textures. there is nothing to worry about, this happens everytime there is a change to the default.xml file, and the second time you start FSX everything will be fine.FSX 'parses' XML files 'assuming' they are in the format indicated in the encoding field. The default.xml file is an ASCII only file, but its encoding is set to UTF-16, which is completely absurd. (ascii files in UTF-16 encoding take TWICE as much space), yet this file is NOT encoded in utf-16, just the XML header says so, and the XML parser in FSX will treat it as such... If you want to see for yourself:1) Add to the [TERRAIN] section of your fsx.cfg file the following entries (this is just temporary) just for testing purposes: TERRAIN_MAX_AUTOGEN_TREES_PER_CELL=6000 TERRAIN_MAX_AUTOGEN_BUILDINGS_PER_CELL=60002) Start FSX and set the Autogen slider to EXTREMELY DENSE3) Go to PNW (the most autogen intensive product I have) and takeoff from KSEA airport, take a fast Jet, spin around while looking around the VC using the mouse. Preferably, 'record' a test flight with FSRecorder with a sampling rate of '1 frame' and re-play it while moving your mouse to look around the cockpit while the recording is playing. Do it with the default.xml before and after the utf change so you can objectively judge for yourself.Enjoy!
Hi ******* :)When I opened the XML file with notepad and changed to 8,nothing happened.Now when I go back to open the XML file it opens with notepad.What did I do wrong?´(windows 7 ultimate)Best regards Anders Vesterlund

Share this post


Link to post
Share on other sites

You are some kind of mad scientist genius Bojote, if there was a FSX hall of fame you would be in it...

Share this post


Link to post
Share on other sites
Hi ******* :)When I opened the XML file with notepad and changed to 8,nothing happened.Now when I go back to open the XML file it opens with notepad.What did I do wrong?´(windows 7 ultimate)Best regards Anders Vesterlund
Don't worry, you should not see 'anything' after 'saving the file. Its as simple as that. What you will see is a huge improvement in the test scenario I described above.

Share this post


Link to post
Share on other sites

BojoteI have a logitech G940 installed and in the "default.xml" for the G940 the utf-8 is already set, so do you still need to change it for the autogen as well? There is also a autogen_default.xml file in \setup\Xpackcache and utf-16 is set there. Do we need to change that value too? A lot of the default.xml files associated with ORBX also have utf-16 set whereas FEX has utf-8 set. It is strange why some values are -8 and some -16!! :( Thanks for the tip.RegardsPeterH

Share this post


Link to post
Share on other sites
3) Go to PNW (the most autogen intensive product I have)
FINALLY! Someone who agrees with me lol!I'll try this out! Thanks again,

|Ryan Butterworth|

| i7 4790K@4.4GHz | 32GB RAM | EVGA GTX 1080Ti | ASUS Z97-Pro | 1TB 860 Evo | 500GB 840 Evo Win10 Pro | 1TB Samsung 7200rpm | Seasonic X750W |

 

 

Share this post


Link to post
Share on other sites
BojoteI have a logitech G940 installed and in the "default.xml" for the G940 the utf-8 is already set, so do you still need to change it for the autogen as well? There is also a autogen_default.xml file in \setup\Xpackcache and utf-16 is set there. Do we need to change that value too? A lot of the default.xml files associated with ORBX also have utf-16 set whereas FEX has utf-8 set. It is strange why some values are -8 and some -16!! :( Thanks for the tip.RegardsPeterH
Peter, there could be cases where add-ons write the 'correct' encoding. do you have a product called Xpack? it looks as if it changed your autogen file already to the correct formating, so you don't have to do 'anything'In my case, we are talking night and day difference. I use a laptop to remotely monitor my desktop via the performance counter tool. Even CPU was reduced considerably (from 75% to 45%).I think it is fair to say that only people with an utf-16 default.xml are 'affected' by this problem.
BojoteI have a logitech G940 installed and in the "default.xml" for the G940 the utf-8 is already set, so do you still need to change it for the autogen as well? There is also a autogen_default.xml file in \setup\Xpackcache and utf-16 is set there. Do we need to change that value too? A lot of the default.xml files associated with ORBX also have utf-16 set whereas FEX has utf-8 set. It is strange why some values are -8 and some -16!! :( Thanks for the tip.RegardsPeterH
wait.. you are not confusing the default.xml file from your controllers right?

Share this post


Link to post
Share on other sites
You are some kind of mad scientist genius Bojote, if there was a FSX hall of fame you would be in it...
Just an enthusiast 'mad' about performance :)

Share this post


Link to post
Share on other sites
Guest scottmm73
Peter, there could be cases where add-ons write the 'correct' encoding. do you have a product called Xpack? it looks as if it changed your autogen file already to the correct formating, so you don't have to do 'anything'In my case, we are talking night and day difference. I use a laptop to remotely monitor my desktop via the performance counter tool. Even CPU was reduced considerably (from 75% to 45%).I think it is fair to say that only people with an utf-16 default.xml are 'affected' by this problem.wait.. you are not confusing the default.xml file from your controllers right?
For those who may be confused. The FSX default xml file is located in the FSX root directory/Autogen folder. Obviously default.xml is the file we are looking for. Right click this file and select edit. Do as instructed above and all should be good.Thanks for all you do, ******* (Hey zeus).

Share this post


Link to post
Share on other sites
For those who may be confused. The FSX default xml file is located in the FSX root directory/Autogen folder. Obviously default.xml is the file we are looking for. Right click this file and select edit. Do as instructed above and all should be good.Thanks for all you do, ******* (Hey zeus).
Have tried many tweaks over the years and have never been impressed. This one impressed me!!!Thanks for your work!

Geofa

WANTED DEAD OR ALIVE-the best Flight Sim!

Share this post


Link to post
Share on other sites
Guest PFL

Agree completely, this one blows my mind!Max. Autogen @ KSEA on my ASUS G73JH i7 720QM ATI 5870 - with FPS average of 20, and smoooth!Amazing, thanks.:(

Share this post


Link to post
Share on other sites

I really dont see the purpose of this tweek as all it does is GREATLY reduce the autogen. The reduction in autogen more precisely the trees naturally will make things smoother. The same smoothness can be obtained by simply lowering your autogen slider a notch or two.


Jim Wenham

Share this post


Link to post
Share on other sites
This 'fix' assumes you have a HEALTHY machine and that you ONLY experience the stutters when panning around in high density autogen areas EVEN with bufferpools disabled.The fix involves editing the Autogen/default.xml file in your FSX root directory and making sure it is saved in UTF-8 format. This is a VERY simple step to follow, you only need to:1) Open the Autogen/default.xml file in notepad2) Once you open it, you'll notice the FIRST line of the file contains: <?xml version="1.0" encoding="utf-16"?>3) Change the above line to this: <?xml version="1.0" encoding="utf-8"?>4) Save the changes and thats it!A word of caution: When you do this change, the next time you open FSX you'll see that the A/C in the welcome screen has no textures. there is nothing to worry about, this happens everytime there is a change to the default.xml file, and the second time you start FSX everything will be fine.-------------------------------Ok i tried .When i first opened fsx the ac in the welcome screen had perfect textures.I placed my cs757 (which is my worst ac ,fpswise) in eham aerosoft. Everything looked fine and smooth and then as soon I took off at about ft 2000 I looked out the window and the autogen was gone.All was flat and ugly.Closed the sim, restarted the sim,placed my cs757 in eddm, took off,....I got bad fps jumps from 19 to 30,autogen was back but looking out the left or right windows the autogen was "stuttery" Buildings were moving back and forth as if there was an earthquake .. autogen and scenery complexity were all the way tothe right. End of test.my specs i7980x-gtx480-ocz 6 gb ram-win 7 x64.Thanks anyway.Vic

Share this post


Link to post
Share on other sites

VERY IMPORTANT! PLEASE READIt appears, based on comments that I've received from some users AND including John Venema, that this 'change' prevents FSX from 'reading' the file, so, in reality, this change is the same as if you deleted the file.So, I suggest you do a 'before and after' test to determine if this is for you. I'm fully aware that 'deleting' default.xml was a performance recomendation from the FS2004 days, but it is not nowadays! so, IF you decide to keep this change to benefit from the performance boost, test first to see if you are ok with the autogen supression that will occur.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    39%
    $9,970.00 of $25,000.00 Donate Now
×
×
  • Create New...