Archived

This topic is now archived and is closed to further replies.

Superpilotv2

FSX won´t start!

Recommended Posts

Hi folks, on Monday I reinstalled FSX after upgrading to the mew system. It went fine and I got very good results with FSXMark11. Yesterday I reinstalled parts of my FSX planes and sceneries (CS 757, FTX PNW and all OzX things and both Dukes) Now I can´t launch FSX anymore. I get the splash screen ans sometimes I get the GUI, but then a message from windows pops up that says that had been a serious error and therfore FSX has to be closed. I also installed (and recently unistalled) the Shader mod 3, but no avail. Does someone know what to do?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The first thing to try is to rebuild a fresh fsx.cfg. If that doesnt work, start uninstalling each addon one at a time until you find the culprit

Share this post


Link to post
Share on other sites

Hi,Don't batch install all your add-ons in the future. Install one at a time and then test FS between each install.

Share this post


Link to post
Share on other sites

Rebuilding the FSX.CFG brought me back into the GUI but when I tried to get to the Free Flight menu, I saw that the trike in the preview screen didn´t turn ant shortly after I accessed the menu, FSX crashed with the same error as above. I´m going to uninstall every addon one by one.

Share this post


Link to post
Share on other sites

Hey Steffen,I had this only the week before last after having repeated crashes within FSX whilst flying. After a while it wouldn't start at all. I just did a repair on Acceleration from within Programs and Features (W7 here, if you're XP it's add and remove) and it worked. Same thing can be achieved by sticking the Acceleration DVD in the drive and running the setupWorked for me...Hope this helps!jake

Share this post


Link to post
Share on other sites
Hey Steffen,I had this only the week before last after having repeated crashes within FSX whilst flying. After a while it wouldn't start at all. I just did a repair on Acceleration from within Programs and Features (W7 here, if you're XP it's add and remove) and it worked. Same thing can be achieved by sticking the Acceleration DVD in the drive and running the setupWorked for me...Hope this helps!jake
Thanks for that tip. My problem is that I don´t have acceleration , only the professional edition. So do I have to reinstall both service packs again?

Share this post


Link to post
Share on other sites

Tried the repair tool and reinstalled both service pack, but it didn´t help either. I can get into the programm with no problem and set it up correctly but if I try to access the free flight or the missions menu FSX crashes and reloads.Btw. FTX is turned off via the FTX central so it doesn´t interfer with FSX. I also tried to install the newest DX components, bud it didn´t work.

Share this post


Link to post
Share on other sites

If I were you I would do the following.1. Uninstall all of your addons one at time2. Uninstall FSX and the service packs3. Clean the registry4. Set your overclock back to the stock settings5. Reinstall FSX following NickN's guide to the "T"6. Reinstall each addon one at a time, including going into FSX after each addon install and testing. 7. Provided all goes well, turn your overclock back on. Some of the problems could be due to your overclock as has happened to some people in the past. You will know when you return to your overclocked settings if all of the sudden you start having FSX issues again.When I did my original FSX install, I would boot FSX after each addon install and test to make sure the addon and FSX worked properly. The I would exit FSX and even went as far as rebooting the rig before installing the next addon. I'm not sure a reboot is necessary after installing each addon, but I would at least test FSX after each addon you install to make sure its still functioning propertly. It will make it a lot easier to track down problems.

Share this post


Link to post
Share on other sites

Also, make sure to turn your antivirus off during the install of FSX. Honestly, the problems you're describing sound like something corrupt in FSX itself, rather than an issue with an add-on. Were it me, I'd uninstall everything and start again and, as others have mentioned, take an incremental approach to changes.

Share this post


Link to post
Share on other sites
Thanks for that tip. My problem is that I don´t have acceleration , only the professional edition. So do I have to reinstall both service packs again?
Professional edition. Many addons require the Deluxe version and/or Acceleration. That could be the problem.Best regards,Jim

Share this post


Link to post
Share on other sites
Professional edition. Many addons require the Deluxe version and/or Acceleration. That could be the problem.Best regards,Jim
Well, Jim, I don´t thing that this has something to do with the different version. I had it running before for over one year on my old system with zero problem and even had it successfully running before I installed the addons.Maybe the Professional Edition is the german version of the Deulxe edition cause I have the SDK on the CD. And the SDK is only sold with the Deluxe edition.

Share this post


Link to post
Share on other sites
If I were you I would do the following.1. Uninstall all of your addons one at time2. Uninstall FSX and the service packs3. Clean the registry4. Set your overclock back to the stock settings5. Reinstall FSX following NickN's guide to the "T"6. Reinstall each addon one at a time, including going into FSX after each addon install and testing. 7. Provided all goes well, turn your overclock back on. Some of the problems could be due to your overclock as has happened to some people in the past. You will know when you return to your overclocked settings if all of the sudden you start having FSX issues again.When I did my original FSX install, I would boot FSX after each addon install and test to make sure the addon and FSX worked properly. The I would exit FSX and even went as far as rebooting the rig before installing the next addon. I'm not sure a reboot is necessary after installing each addon, but I would at least test FSX after each addon you install to make sure its still functioning propertly. It will make it a lot easier to track down problems.
I deinstalled every addon but it refuses to work. So I´ll gonna start from scratch. Could you please supply the link to the guide, I don´t find it anymore. About the oc: I can´t think that my oc has anything to do with it, but unless my setting are stored in the BIOS, it´s not that difficult to revert back.

Share this post


Link to post
Share on other sites

have you tried the Uiautomation.dll replacement?Vic

Share this post


Link to post
Share on other sites
have you tried the Uiautomation.dll replacement?Vic
I placed the Vista version in the FSX folder but it didn´t change anything.

Share this post


Link to post
Share on other sites

Hi,I had this happen to me once a very long time ago. After countless hours of trying to track down the culprit, it turned out to be a vendors software protection scheme. I had to reinstall FSX and all of my addons with the exception of the offending software, I can't for the life of me remember the vendor.This was after I was "forced" to clean my system registry because the uninstall program left remnants. Sloppy work on the part of the vendor.Not sure if this is your problem, just a thought.

Share this post


Link to post
Share on other sites

Also check your dll.xml and exe.xml files because some addons add entries there and not all play nice when installing them in a batch like that.

Share this post


Link to post
Share on other sites
I deinstalled every addon but it refuses to work. So I´ll gonna start from scratch. Could you please supply the link to the guide, I don´t find it anymore. About the oc: I can´t think that my oc has anything to do with it, but unless my setting are stored in the BIOS, it´s not that difficult to revert back.
Here's the link to the setup guide.http://www.simforums.com/forums/setting-up-fsx-and-how-to-tune-it_topic29041.htmlThe reason I mentioned that you should revert to your normal/stock clock settings is to be sure that there is no instability with your overclock causing your issues. Not long ago a few users here report not the same issue as your having, but some issues none the less with FSX instabilities and they were solved by backing off their overclocks.If it was me personally, I would have installed your OS then FSX and all your addons first while at stock CPU settings, rather than installing your OS then overclocking, then installing FSX. Make sure to test FSX along the way after you start installing your addons that way if you have a problem you will be able to pin it down a lot easier.

Share this post


Link to post
Share on other sites
Here's the link to the setup guide.http://www.simforums...topic29041.htmlThe reason I mentioned that you should revert to your normal/stock clock settings is to be sure that there is no instability with your overclock causing your issues. Not long ago a few users here report not the same issue as your having, but some issues none the less with FSX instabilities and they were solved by backing off their overclocks.If it was me personally, I would have installed your OS then FSX and all your addons first while at stock CPU settings, rather than installing your OS then overclocking, then installing FSX. Make sure to test FSX along the way after you start installing your addons that way if you have a problem you will be able to pin it down a lot easier.
Thanks mate. I have recently reinstalled FSX and service pack one as prescribed in the guide. So far everything works normal and I could fly a bit. I didn´t reinstall my OS when I upgraded to my current components. Is this a problem?

Share this post


Link to post
Share on other sites
I didn´t reinstall my OS when I upgraded to my current components. Is this a problem?
Probably not, but I wouldn't have done it that way.Personally, if I was going to do a major upgrade like you did, which was to basically build a new system, I would have started from scratch since I like to leave nothing to chance, but that's just the way I am. Anytime I have ever tried taking a short cut its ended up costing me in the end so I always start as fresh as possible, especially when it comes to FSX or computer stuff in general.Anwyay, glad to hear that your progressing and that its working.

Share this post


Link to post
Share on other sites

SP 2 is installed and trike is turning and no crash. So I´m as far I had been before. But I had not luck activating my copy till now, so as said in another thread this maybe impiles another reinstall. Oh man, how I hate this poorly programmed game but it´s the only one we have! I hope MS Flight will he here soon.

Share this post


Link to post
Share on other sites