Archived

This topic is now archived and is closed to further replies.

Bubi42

nHancer or Nvidia Inspector?

Recommended Posts

I asked this question in the PMDG NGX forum but didn't get a response - so I thought I'd ask here.... Ages ago, I set up FSX graphics with the aid of Nick Needham's guide using nHancer.Now I'm reading a lot of recommendations by Ryan (at PMDG) and others who talk about setting FSX graphics up with Nvidia Inspector....So, which is better or can/should they both be run together?Thanks for any guidance!Toni.

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Inspector has superseded NHancer now as the preferred tool. I think NHancer is discontinued, Inspector is way better now for going forward so I recommend.

Share this post


Link to post
Share on other sites

don't mean to hijack this thread.. but I have to ask.. this is very confusing to me.. ok, so I have the 470 and I'm just getting ready to install the new drivers for it.. so then to change settings, I don't even go to the default nvidia control panel just to the inspector ... and when I click on apply - is that it all the time, even when I reboot?

Share this post


Link to post
Share on other sites

Once you set up inspector, you are good to go. The settings are saved in a profile and are used whenever you start FSX.

Share this post


Link to post
Share on other sites

I don't use either and get absolutely stunning graphics in FSX. I use the default Nvidia profile for FSX set up by Nvidia techs. I'm concerned these programs (nHancer and Inspector) are placing even more stress on computer systems and creating more graphics issues. I did try the Nvidia Inspector and set it up per recommendations of the thread at PMDG and saw little or no improvements so I uninstalled it. I was hoping it would improve antialiasing in FSX. Of course, if it did fix antialiasing, I'm sure Nvidia would pick up on it and put the fix in their next drivers. That's my two-cents.... Best regards,Jim

Share this post


Link to post
Share on other sites
Once you set up inspector, you are good to go. The settings are saved in a profile and are used whenever you start FSX.
...just to be sure, where exactly should nvidia inspector reside and how can I ensure it executes each time I start FSX? Is a batch file needed or is it fully 'automatic'? Toni.

Share this post


Link to post
Share on other sites

You can put NI anywhere on your PC, just make sure that all the files included in the version that you download are moved to where you want it to run from and all files included in the download have to be in the same folder that you want to run it from. Once you set up NI for FSX and hit apply FSX will start with those settings automatically everytime you start FSX.

Share this post


Link to post
Share on other sites

works like a charm for me.. I have a 470 and I just update to the 280 drivers.. and I get no shimmering whatsoever.. very crispy!!

Share this post


Link to post
Share on other sites

... I have the 580 and have done the same. Toni:- I keep the Nvidia driver source files in "E:\Nvidia\Drivers\280.26"... 280.26 is the latest; each version has it's own folder, and I keep the last six versions.When I've downloaded the new driver file, I open up the Control Panel and uninstall the old Nvidia products, then reboot the machine into Safe Mode. In Safe Mode I run "Driver Sweeper", from:http://phyxion.net/ , selecting all Nvidia components.Once that's done I reboot to normal mode, go to the E:\Nvidia\Drivers\ folder, then to the latest download (which is an .exe file) and double-click it. I choose "Custom Install" as I don't want any 3D or audio "stuff" added to the pc, and then I let it install to it's default folder - "C:\NVIDIA\DisplayDriver\280.26.A reboot follows, and then I launch Inspector (ignoring the Nvidia control panel completely), and setup the FSX as per Ryan or Nick's configuration. These settings will stick, and will be used whenever you launch FSX, but I may play with the settings from time-to-time, but generally that's the process. OK? smile.png

Share this post


Link to post
Share on other sites

There is something to consider also Toni, and it's very straightforward, if you want to run the latest drivers, or even the last three, ( can't remember since when) then you will have to use Inspector anway, as the latest drvers do not run in Nhancer. As was said earlier in the thread, I'm unsure whether they have continued with Nhancer anyway. Also, Jim, is there any chance you could post the settings you're using for your video card.

Share this post


Link to post
Share on other sites

I recently u/g to a 460 GTX win7-64 i7-860 8GB Fsx/accel Dell WS 24 1900x1200 and used Inspector with Ryan's settings. I still have some shimmering when in motion and always have jagged edges on taxiway and runway lines. Most planes have jagged lines on wings and vertical stabilizer. The PMDG paint has all the large 800 numbers on the edges of the vertical stabilizer glowing with dancing dots.Any suggestions would be greatly appreciated. Ray

Share this post


Link to post
Share on other sites
I was hoping it would improve antialiasing in FSX. Of course, if it did fix antialiasing, I'm sure Nvidia would pick up on it and put the fix in their next drivers. That's my two-cents....
Jim, it does not "fix" antialiasing, but provides additional options over and above what the standard panel offers..as I'm sure you know. I happen to like the 8XSQ mode, and yes it puts additional strain on my system, but my GTX460 video card can handleit just fine..

Share this post


Link to post
Share on other sites
I recently u/g to a 460 GTX win7-64 i7-860 8GB Fsx/accel Dell WS 24 1900x1200 and used Inspector with Ryan's settings. I still have some shimmering when in motion and always have jagged edges on taxiway and runway lines. Most planes have jagged lines on wings and vertical stabilizer. The PMDG paint has all the large 800 numbers on the edges of the vertical stabilizer glowing with dancing dots. Any suggestions would be greatly appreciated. Ray
Sounds like you have DX10 Preview turned on. DX10 does not work well in all cases in FSX. Best regards,Jim

Share this post


Link to post
Share on other sites
Sounds like you have DX10 Preview turned on. DX10 does not work well in all cases in FSX. Best regards,Jim
Nope. It has to be something other than DX10. The box is not checked. Thanks. Any other suggestions? Ray

Share this post


Link to post
Share on other sites
Nope. It has to be something other than DX10. The box is not checked. Thanks. Any other suggestions? Ray
Look at your Texture filtering - Negative LOD bias in the Inspector settings. In the Nvidia display driver settings, 'Allow' is the default. You want to change that to Clamp. This setting sharpens the stationary images but introduces aliasing when the scene is in motion. If it is already set to Clamp, change it back to Allow. Clamp also reduces some shimmering. Best regards,Jim

Share this post


Link to post
Share on other sites

Is Inspector supported for the 7600 GT. I tried to install it once, but can't get it to work at all. It's been a while, but generally I recall everything on the Inspector interface was grayed out.

Share this post


Link to post
Share on other sites
Look at your Texture filtering - Negative LOD bias in the Inspector settings. In the Nvidia display driver settings, 'Allow' is the default. You want to change that to Clamp. This setting sharpens the stationary images but introduces aliasing when the scene is in motion. If it is already set to Clamp, change it back to Allow. Clamp also reduces some shimmering. Best regards,Jim
Thanks Jim for taking the time to work on these settings with me. I was set on clamp and changed to Allow. Take a look at these screenshots. The red circled areas are alive and dancing.Insp_1.jpgInsp_2.jpgCrawlingyellowlines.jpgCrawlinglines.jpgclamp.jpg

Share this post


Link to post
Share on other sites
Thanks Jim for taking the time to work on these settings with me. I was set on clamp and changed to Allow. Take a look at these screenshots. The red circled areas are alive and dancing.
I think what's going on is the fact you have your settings in Inspector way too high and that is causing FSX to be slow in rendering certain objects, especially objects in the distance and that causes the appearance of shimmering, etc. The more requirements you throw on FSX, the worst it's going to get. I mentioned earlier in this thread that I do not use Inspector but use the default settings in the Nvidia display drivers (I did change LOD to Clamp but that's it). I have not increased AA or AF or any other setting and I get clear shimmer free, blurry free graphics. Ryan over at PMDG came up with a great guide for Inspector but, what works in one system may or may not work in others. Perhaps you should try disabling Inspector and then load the display driver settings programmed by Nvidia for FSX and see if the issues are reduced or gone. In addition, I'm not sure what AF Base you have shown in the pictures but is it the default or is it an addon? That could be the issue too as some addon scenery was developed for FS2K4 and will usually work in FSX but not completely since a new format is used, especially in textures. To me, your pictures look blurry or hazed over and not crisp. Glad to help as much as I can. Best regards,Jim

Share this post


Link to post
Share on other sites

Raymar - Here are my FSX graphics settings as you requested. As I stated, my Nvidia settings are set to the default for FSX (look under the Programs Tab in the Nvidia driver settings) except I clamped the LOD. Best regards,Jim

Share this post


Link to post
Share on other sites
As I stated, my Nvidia settings are set to the default for FSX (look under the Programs Tab in the Nvidia driver settings) except I clamped the LOD.
Correction - my display settings are the default except I do have 8x multisampling and LOD is set at Allow. My apologies.... Best regards,Jim

Share this post


Link to post
Share on other sites
I recently u/g to a 460 GTX win7-64 i7-860 8GB Fsx/accel Dell WS 24 1900x1200 and used Inspector with Ryan's settings. I still have some shimmering when in motion and always have jagged edges on taxiway and runway lines. Most planes have jagged lines on wings and vertical stabilizer. The PMDG paint has all the large 800 numbers on the edges of the vertical stabilizer glowing with dancing dots.Any suggestions would be greatly appreciated.Ray
Hello Ray, I have same problems like you. First of all, I would split shimmering problems between scenery/aircraft textures shimmering, which you would fix by adding mipmaps to those textures and scenery object shimmering (in particular thin objects like fences, apron lamp lights, taxiway light plots...).The problem is quite difficult to fix without losing fps, especially in VC view. I have tried in these last days lots of settings but when I fix the shimmering problem, I get a huge impact on fps.This morning I tried this config, I would suggest to try:- Antialiasing mode: override application etc...- AA setting & transparency: 8xS + 2x sparse grid supersampling- AF: application controlled- Negative LOD: clamp;- Texture filtering: High quality- in FSX set AA unticked and Anisotropic filter.Before that I used 8xS + 4x supersampling but shimmering objects were very annoying and damaging my eyes.Now, with the above config I have a pretty good improvement about shimmering (the best solution is to use 4x sparse grid supersampling, but it costs so much in fps) and performance. There is a fps loss but not so important like previous.
I think what's going on is the fact you have your settings in Inspector way too high and that is causing FSX to be slow in rendering certain objects, especially objects in the distance and that causes the appearance of shimmering, etc. The more requirements you throw on FSX, the worst it's going to get. I mentioned earlier in this thread that I do not use Inspector but use the default settings in the Nvidia display drivers (I did change LOD to Clamp but that's it). I have not increased AA or AF or any other setting and I get clear shimmer free, blurry free graphics. Ryan over at PMDG came up with a great guide for Inspector but, what works in one system may or may not work in others. Perhaps you should try disabling Inspector and then load the display driver settings programmed by Nvidia for FSX and see if the issues are reduced or gone. In addition, I'm not sure what AF Base you have shown in the pictures but is it the default or is it an addon? That could be the issue too as some addon scenery was developed for FS2K4 and will usually work in FSX but not completely since a new format is used, especially in textures. To me, your pictures look blurry or hazed over and not crisp. Glad to help as much as I can.Best regards,Jim
Hey Jim, I will try your settings, aborting Inspector. Anyway, I see you have a very great VGA and autogen only NORMAL, so probably these two factors give you great visual effect and no performance hit, I think.Could you post some screenshots about your configuration in the nVidia control panel?Thanks. bye.

Share this post


Link to post
Share on other sites
Hey Jim, I will try your settings, aborting Inspector. Anyway, I see you have a very great VGA and autogen only NORMAL, so probably these two factors give you great visual effect and no performance hit, I think.Could you post some screenshots about your configuration in the nVidia control panel?Thanks. bye.
My settings are simple in the Nvidia Control Panel. They are set at the default or the settings provided by Nvidia for the FSX program under the program settings tab.Best regards,Jim

Share this post


Link to post
Share on other sites