Jump to content

Archived

This topic is now archived and is closed to further replies.

some1

HQ antialiasing for NVidia cards

Recommended Posts

Thanks Paul (again)!

 

I added the BufferPool entries to my FSX.cfg but left Water at 6. Still saw the black shadows on the water. Went back and changed the Water setting to 5 and that did it and it's difficult to see any difference in the quality of the water. Awesome. You the man!

 

Are you see some jagged shadow edges in the cockpit and I mentioned above? It's not a biggy to me as shadows are shadows and they look good no matter what. But, in my earlier testing with FSX AA/AF turned on in FSX and off in the NI settings, it was a lot smoother, not perfect, but smoother lines.

 

Best regards,

Jim


Jim Young | AVSIM Online! - Simming's Premier Resource!

Member, AVSIM Board of Directors - Serving AVSIM since 2001

Submit News to AVSIM
Important other links: Basic FSX Configuration Guide | AVSIM CTD Guide | AVSIM Prepar3D Guide | Help with AVSIM Site | Signature Rules | Screen Shot Rule | AVSIM Terms of Service (ToS)

I7 8086K  5.0GHz | GTX 1080 TI OC Edition | Dell 34" and 24" Monitors | ASUS Maximus X Hero MB Z370 | Samsung M.2 NVMe 500GB and 1TB | Samsung SSD 500GB x2 | Toshiba HDD 1TB | WDC HDD 1TB | Corsair H115i Pro | 16GB DDR4 3600C17 | Windows 10 

 

Share this post


Link to post

Yup - those are the current settings. I was kinda proud of that BP=0, (ego again) but FSX doesn't flash any more in very heavy weather: doing that hasn't slowed it down - still sits at 30 - actually I set that to 31, and now I see more 30's and less 29.9's. (It's red and in the corner of the first of three 19" monitors, and I have to move my head over to verify it). With my eyes - 29.9 could be 29.6, 29.2, 28.8, and so on, I can see 30.

 

No, no jaggies in the cockpit pillar (c172, etc.,) This was done last week, when using AA and AF ticked and set (Anisotropic) within the sim, and nothing in Inspector.

 

https://www.dropbox....n3x4/9vFI1znpWB

Share this post


Link to post

im now using your BP settings in the above post...and the NVIDIA inspector settings in your dx10 doc, and the sim just SHINES at 30 fps! FSX is a new sim to me now, and i hope others have similar experiences.

Share this post


Link to post

For the life of me I simply can not get the plane shadows on ground to be AA'ed. I've followed all the settings to a T about 5 times now. DX9 AA works properly but in DX10 AA is on but not on plane ground shadows. Do we have to run the beta 304 drivers for it to work? I'm running the official 301.42s.

 

I've done a complete driver uninstall. Booted to safe mode. Use Driver Sweeper two times. Reinstalled 301 and still no ground shadow AA.

Share this post


Link to post

Here's what I did after reading your post, Bumpy. I'm using Mike Krawczyk's Inspector settings, they work very well on my machine. Yes - I'm using the 304.48 beta. Seems ok.

 

Can you give us some screenshots of what you're seeing - same sort of format?

 

https://www.dropbox....kcxo/vqPZjZ3WAm

Share this post


Link to post

[bUFFERPOOLS]

BufferPools=1

PoolSize=8388608

RejectThreshold=786432

[GRAPHICS]

shader_optimize=1

shader_partial_precision=1

MULTISAMPLESPERPIXEL=8

SHADER_CACHE_PRIMED_10=1693458432

SHADER_CACHE_PRIMED=1693458432

D3D10=1

HIGHMEMFIX=1

TEXTURE_MAX_LOAD=1024

NUM_LIGHTS=8

AIRCRAFT_SHADOWS=1

AIRCRAFT_REFLECTIONS=1

COCKPIT_HIGH_LOD=1

LANDING_LIGHTS=1

AC_SELF_SHADOW=1

EFFECTS_QUALITY=2

GROUND_SHADOWS=1

TEXTURE_QUALITY=3

IMAGE_QUALITY=0

See_Self=1

Text_Scroll=1

[sOUND]

AmbientUIMusicVolume=-6.000000

SOUND_FADER1=0.270000

 

 

3 pics are here.

http://minus.com/mXp3NFrvd/3

Share this post


Link to post

The only different setting is - I'm using the 304.48 beta driver, Bumpy, with 1.9.6.6 Inspector, and no cockpit ToolTips... Isn't this a strange one??????

 

We'll have to sleep on it, for now - tomorrow's another day. :Thinking:

 

Cheers,

 

pj

Share this post


Link to post

As Mike explains above Multi Sample Anti Aliasing applies to the geometry (edges) of objects that are drawn. Shadows are not drawn as objects, they are lighting calculations that effect the colour of pixels inside other objects as they are being drawn - in this case the runway. Therefore there is no geometry associated with a shadow to antialias in that way.

 

Whether Super Sampling has some slight smoothing effect I am unsure (way out of what I know) - its not a high definition texture subject to the effect that Mike describes above - if it did the shadowing at a higher resolution and down sampled it would but I don't think thats what occurs.

 

The accuracy of the shadow projection calculations depends on the precision with which the depth calculations of other objects are carried out.

 

I would question

 

shader_optimize=1

shader_partial_precision=1

 

 

OK after some experiments! - those settings seem to have no effect positive or negative.

 

With SSAA off so MSAA then as expected the shadows were slightly jagged in dx9 and dx10 - the view from above at an angle shows this off at its worst, its much less noticble at other angles.

 

Trying SSAA, with DX9 the shadow edge was smoothed whilst with DX10 whilst it was improved over MSAA it was inferior to DX10 and much as you show in the picture.

 

 

 

 

Share this post


Link to post

The only different setting is - I'm using the 304.48 beta driver, Bumpy, with 1.9.6.6 Inspector, and no cockpit ToolTips... Isn't this a strange one??????

 

We'll have to sleep on it, for now - tomorrow's another day. :Thinking:

 

Cheers,

 

pj

 

Well I'd say something has to be messed up on my system but I'm not sure of the easiest way to determine what side it lies on: Windows issue or FSX issue. If SGSSAA works on and off fine in other games I have, I suppose that should rule out my Windows side of things being ok.

Share this post


Link to post

Well I'd say something has to be messed up on my system but I'm not sure of the easiest way to determine what side it lies on: Windows issue or FSX issue. If SGSSAA works on and off fine in other games I have, I suppose that should rule out my Windows side of things being ok.

 

Have you by chance tried disabling cockpit tooltips to see if things behave differently?

Share this post


Link to post

Have you by chance tried disabling cockpit tooltips to see if things behave differently?

 

I had to laugh when you suggested this but watch it'll work now....sadly, no, still no shadow AA.

 

Edit: I just backed up my FSX install, fully uninstalled FSX, deleting all the hidden FSX bits, and did a fresh vanilla FSX install, applied 3.0 shader mod....no joy. Still no AA in shadows. So, I assume something in my drivers/Windows/DX10 is messed up. I'm not AT ALL interested in reformatting and fresh installing Windows.

Share this post


Link to post

Got my shadow AA working. I used the DX10 Bioshock compatibility flag. Only took me about 6 hours to figure this out. <sic> The AA seems very smooth too, may actually be forcing properly but I'm too tired to look into it further at the moment.

 

Now I have to fix my Scenery. Seems my quick vanilla install has messed it up and is missing a bunch, tips to get it back?

Edit: Luckily I found a backup of my scenery.cfg. Simply used my old fully loaded one and now all my scenery is back. :)

 

jYp7I1VKdZpjh.png

 

jbv8U3XSPkVzdD.jpg

 

jMcGXUtTsrbeM.png

Share this post


Link to post

Problem I have is that at some Addon Airports at Dawn or Dusk the ground taxiways colour are all screwed up


Ron Hamilton

 

"95% is half the truth, but most of it is lies, but if you read half of what is written, you'll be okay." __ Honey Boo Boo's Mom

Share this post


Link to post
×
×
  • Create New...