Sign in to follow this  
apollomaker

Video Display Issue - Frame Rates

Recommended Posts

This is a previously posted issue but bears its own thread. It has been reported by others as well.

 

At the start of a flight with the Phenom, frame rates appear normal but after takeoff the FPS number drops heavily to 6-9 FPS.

The sim becomes virtually unflyable at these frame rates. Tests with other aircraft do not show this issue on my test system. It only appears with the Phenom.

 

It appears to be related to the rendering of textures, but I have no way to tell exactly. It is definitely something Carenado should look into. It does not appear on other Carenado planes I have tested.

  • Upvote 1

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

HI

This reminds me of a problem I had with the Feel There Phenom, for some reason my anti-virus Mcafee saw the Phenom as a threat and

kept constantly scanning it, hence giving really poor performance. (This also happened with other addons as well)

The only thing that worked was to uninstall Mcafee and install MSE instead and ive never had a problem since.

This may not be the root of your problem but its worth bearing in mind.

 

Regards.

Share this post


Link to post
Share on other sites

thank you poster for making this issue public, i as well get very strange FPS issues, 0.5-6fps, at times cant figure it out. using p3dv2.1

Share this post


Link to post
Share on other sites

for some reason my anti-virus Mcafee saw the Phenom as a threat and

 

kept constantly scanning it, hence giving really poor performance.

Hello Paul -- as fate would have it, I have McAfee as my anti-virus pgm, and it was running as always.

I tested it by shutting off all scanning but this was not the cause here. Same problem with frame rates dropping to horrible low figures after takeoff.

 

Did you try fixing the problem by just shutting off McAfee before totally uninstalling it ??? Again, the fact that makes me think it is an issue with the add-on, is that only this plane has the issue. Others do not. The FeelThere Phenom does not.

 

Thanks for the input -- was worth a try.

Share this post


Link to post
Share on other sites

I have this problem but only with addon airports, otherwise with the default ones it performs very well.

Share this post


Link to post
Share on other sites

I just finished a short hop.... On the ground at a default airport I was at 15-22 (which was where the TBM was at all the time for me) but as soon as I got near weather or scenery or anything else drops to 6-9.. after landing at a field with addon scenery I pulled off the runway at 4fps!!!!! And I don't have a slow desktop.......#####

 

Something wrong here... Even the TBM never dipped below 12-14...disappointing.

Share this post


Link to post
Share on other sites

Something wrong here... Even the TBM never dipped below 12-14...disappointing.

Something wrong here... Even the TBM never dipped below 12-14...disappointing.

Yes, there is. This one is the game changer since for me, the sim becomes unflyable. It is real important for Carenado to fix this. Another 'gift' from the Carenado beta testers and devs.

Share this post


Link to post
Share on other sites

Hi Bob

Yeah I turned off mcafee before I uninstalled it and it seemed to work for me

but as you said your FeelThere phenom works fine so its probably not your ant-virus.

Hope you get it sorted soon!

 

Regards,

Share this post


Link to post
Share on other sites

Did some more research on this issue. Here is something that may help a bit -- it did for me.

 

In your FSX.cfg file, under [bUFFER_POOLS] set the UsePools variable to 0 (zero).

The size specified for the buffer pool should not matter here.

 

Also, you can experiment with the FIBER_FRAME_TIME_FRACTION value. Default is 0.33 but a smaller value can boost frame rate a bit. Too small and you will start dropping texture redraws.

 

You can surf these two variables on the net if you are interested in finding out what they do in detail.

 

Good Flying --- !!!   :-)

Share this post


Link to post
Share on other sites

Fps rates my &@($*. It's time to upgrade your video cards I get 22 to 45 fps on 1080 six core intel and a gtx590 settings are in high with 80% commercial traffic and 50 private with Rex.

Share this post


Link to post
Share on other sites

Well I have a i7-3770k @ 4.3 GHz with a nvidia GTX660 GPU. After flying some more legs with the phenom the problem seems to be gone, atleast I haven't had any big fps problems anymore.

Share this post


Link to post
Share on other sites

While I notice a large fps hit on my SB 2500K@ 4.2 ghz I don't see any super low fps.

Share this post


Link to post
Share on other sites

I don't experience any of these FPS drops after takeoff.  I'm flying this beauty with ORBX, FSDT, FT, FB Airports, ASN weather and traffic. 

 

Not an issue.  Loving this aircraft.

 

Hirdy

Share this post


Link to post
Share on other sites

Can this be related to glass cockpit? I don't buy any Carenado aircraft with G1000 anymore because of poor performance on my machine. Aircrafts from other developers that have glass cockpit work just fine. I guess I'll pass this one too.

Share this post


Link to post
Share on other sites

I wish the Phenom had the same FPS performance as the TBM850. I don't understand why this AC kills my system as the G1000 displays are the same in both I presume? 

 

Best, Jeff

Share this post


Link to post
Share on other sites

A quick question, does everyone here try the 'load a light aircraft before loading a heavy one' thing?  I always thought it was BS until I followed the doc advise in the F1-B200 always loading an 'easy on the computer' default mission.  It's supposed to save your memory (which I haven't specifically tracked) but does 'appear' to give me a better experience loading an aircraft in and changing scenery that otherwise.

Share this post


Link to post
Share on other sites

Ok I'm just confirming I have the same issue.. As soon as I take off I get a fluctuation of 40-9-40-9fps??

 

Awful to fly with these stutters, not happy! I checked by reloading another aircraft (actually the B200 by CARENADO) and my frames rates were restored to a consistent 60fps.

 

What's going on Carenado??

Share this post


Link to post
Share on other sites

I get the same thing I'll be at my locked 30 FPS in p3dv2 sitting still but once I hit 80 its down to 14-16 then once I get some alt its back up to my locked 30 and the same thing happends on decent just not as severe I go from 30 down to the low 20's and high teens.

Share this post


Link to post
Share on other sites

I thought the glass cockpit (three screens.... does the TBM have three as well?) was a factor, too, but you can turn them off completely with a hidden click-spot in the near-upper-left-hand corner of the black bezel, but will still get such momentary fluctuations. So either they're still running even when not writing displays to the screen, or there's some sort of glitch somewhere that needs to be reported and corrected.

 

It's quite intermittent with me; I've taken off at night with heavy ORBX NCA scenery from KSFO without frames dipping below 24fps, ever, but been in other scenarios where I see the glitch.

 

The middle MFD does keep live, real-time tracking of air traffic. I first discovered this to my delight with the Cirrus SR22 incarnation, it works the same way in all subsequent Carenado G1000s, and it may be a factor. It's a very useful overhead utility to see how dense the traffic is in your FSX airspace, and the vectoring of the planes near you will coincide with the aircraft ATC warns you about and you see passing, and near traffic will set off that annoying voice warning until they're a certain distance away from you, which I believe is configurable in one of the many functioning AUX sub-pages of the MFD. That traffic-tracking may impose a momentary load on the system depending on how heavy it is, until it all settles down. That'd be my best guess.

Share this post


Link to post
Share on other sites

Guess what, I had the same frames issue as u guys, jumping between 40 and 6 fps, I tried the easiest thing and unchecked the high quality 3d cockpit in the Fsx graphics options menu. Now the phenom keeps a stable 30fps and finally I was able to do my first regional flight in IVAO...of course the readability of the gauges is reduced but I don't care so much since I'm using the Saitek FIPs ....cheers

niko

Share this post


Link to post
Share on other sites

Okay so did some tests of frame rates on my system.  First, hw/settings info:

 

hw: i3770K 3.5GHz 16GB 2400XMP RAM ASUS mobo Nvidia 680GTX card

Prepar3Dv2.2 settings: FXAA on, MSAA 2 samples, HDR on, Anisotropic 16, 4096x4096 Texture Resolution; 1920x1080x32 single display; Scenery: lod radius High, Tesellation Factor High, Mesh Resolution 5m, Texture Resolution 7cm, Land Detail Textures on, Scenery Complexity Extremely Dense, Autogen vegetation and building Very Dense;Water Detail High, Reflections Clouds and User Vehicles, Special FX medium; Lighting: Shadow Map Count Ultra, only Object Shadow Cast Distance set, to 6,000m,Internal and External Vehicle Receive only (no Cast).

 

Screenshots with embedded fps in RED, top left, as usual:

 

I4AK3.jpg

ylKWf.jpg

9601G.jpg

TFAXE.jpg

bjPZv.jpg

cLYz.jpg

xqBnS.jpg

usm7Q.jpg

 

I have ORBX FTX Global, Vector 1.1 installed, along with REX4 Texture Direct with P3D DX10 textures as well (in this case REX Weather is not running in the background, so no weather injection).

 

The frame rates under these conditions are as you see them above. I have simply copy/pasted my EMB500 install from my FSX folders to the equivalent P3D folders.

 

Hope that is useful info.

 

Note: if you look carefully you can see the engine gasping to keep up with rendering the vector roads (they're jaggy in some shots; pausing the sim allows them to process and smooth).

 

I wouldn't recommend these as default settings on such a system, but it demonstrates, I think at least, that you can run the Phenom in Prepar3Dv2.2 with awfully intense graphics processing going on (haven't gone to latest Nvidia Beta drivers, btw), and still have something serviceable.

 

I would suspect in heavy traffic, at airports, you will have updating issues on the MFD that may be the thing causing the hiccups you're seeing; I have my air traffic set to 16 in P3D and I get some drops in FPS at, say, YBBN during rush hour. :)

 

Sorry for so many shots just trying to visualize the correlation between different flight and view scenarios (not using EZDok) and changes in FPS. Heaviest hit seems to be in scenes where the clouds are casting shadows on water (Clouds set to 70 in P3D, Maximum Detail, 4096 textures).

 

Totally not paying attention to the instruments or flying right. :) Lighting has been turned on in the cockpit to add some load there, for the test.

 

Steve

Share this post


Link to post
Share on other sites

I've seen the frame rate drop, but I get different results on a separate box. The computer I initially installed on isn't super high powered, but as soon as I got airborne I'd see framerate drop down to 6-7, regardless of location. Stable flight would stabilize frame rates somewhat higher, but maneuvering would drop them again.

 

Installing on my other computer which is much more recent and with an SSD, I see excellent and consistent frame rates. Sometimes I see maybe 2-3 fps drop but otherwise no problems.

Share this post


Link to post
Share on other sites

Carenado really needs to look into this issue, at this point I cant even fly the airplane. I go from 54 fps down to 4, NOT happy

Share this post


Link to post
Share on other sites

I agree!, there's something strange with the aircraft, I do have higher fps, but sometimes it drops to 8 or 10 or even 4...after being on 40+ I had this issue before with the CT182T, C206H G1000 and SR22, but they released a patch that fix that problem, and it works!, so I hope they do something similar with the Phenom...

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this