Sign in to follow this  
yorgosGK

EZdok was working but...Access Violation error

Recommended Posts

I had my EZdok working with P3Dv2.2 just a few days back, then I updated my motherboard and bought a new SSD so I thought it would be a good time to reformat my system...After installing my addons back I am having a hard time getting EZdok to work again (it was working great before)

 

I am getting the access violation error below

 

nKv5NRu.png

 

So far, I have tried several things to do with User Access, Permissions, with and without the migration tool. I have also followed exact guides on Avsim and the Flight1 support page.

 

I did a backup of my old system and I manually also dragged and dropped my old EZCA files and I get the same error. I have Windows 7 ultimate 64bit installed. I have also tried windows defender settings, firewall settings, administrator settings and folder permission and have also installed SimAccess via the migrate tool.

 

Does anyone have any ideas or fixes for this? Keep in mind I am not coming over from an existing FSX running EZDok install I am installing from scratch. Also I have done the updates to 1.17 and the P3D patch found on the boards.

 

Hope this is an easy fix! My rigs specs are in my profile.....

 

Anything?

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

This is an automatic message.

 

This topic has been moved from "P3D Aircraft & Vehicles - Native and Add-Ons" to "The Prepar3d General Forum". This move has been done for a number of possible reasons.

  • The most likely reason is that the post was off topic.
  • The topic could also have contained images or a video that were not appropriate to the original forum it was posted in.
  • The images might not have been "illustrative" or "explanatory" in nature.
  • The topic could have been moved because we deemed it to be more appropriately placed elsewhere.
Please ensure that your posts are "on topic" and contain illustrative images or videos as appropriate. Do not post videos or images just for entertainment purposes anywhere but in the screen shot or video forums. See our image posting rules here.

 

Members who continue to post off topic posts can be denied entry to specific forums in order to reduce and remove the practice. Your cooperation is appreciated.

Share this post


Link to post

There are a lot of threads about this problem when you Google ezdok access violation and I see you probably did some research for a solution via this means. An access violation does not necessarily indicate there is a problem with the ezdok software program or else everyone who owns the program would be complaining about the same problem. Most likely it is something external to ezdok. Another program is competing for that address space and it could be one of your startup programs.

 

Click on the Start button and type msconfig in the search box then look up in the menu and click on msconfig. Once open, look at the Start tab. You can disable all of these programs as they are not required. Restart Windows and see if this fixes the problem.

 

Check for any corrupted system drivers - http://support.microsoft.com/kb/929833 .

 

Scan your system for malware and/or viruses.

 

You indicated that you reformatted your hdd and reinstalled Windows 7 Ultimate then slowly reinstalled your addons. Did you reinstall Windows or did you apply a backup? When you installed ezdok did you move your old settings into the ezdok program files?

 

Make sure you have the required versions of Microsoft Visual C++ 2005 and 2008. Information about checking the versions and a link to download the correct versions is located in the AVSIM CTD Guide located to the right of this forum under Hot Spots. P3D uses the 2010 version but it is not backward compatible with maybe the version used by the ezdok developer (2008). Microsoft Visuals are used by addon developers to make sure their product was installed properly.

 

Make sure you have the required versions of Microsoft.net Framework. Versions 2.0, 3.0, and 3.5 are required. I believe P3D uses the 4.0 version but all of the other versions are required as they were used by other programs to properly run FSX and FSX addons (ezdok is a FSX addon you are migrating to P3d). Microsoft.net Framework versions are not backward compatible. See the AVSIM CTD Guide for information on verifying you have the versions as discussed above. Microsoft.net programs are used by addon developers to make sure you product runs properly once installed. So I'm thinking you might have taken a shortcut somewhere as these program are installed by the developer if they are not found on the system during installation (some programs will specifically state Microsoft.net 3.5 required and you will have to make sure the program is installed).

 

You can try updating your USB ports as they could be conflicting with memory addresses. I usually recommend one download a program that will scan your system and look for out of date programs (like Driver Genius and DriverScanner). These programs are freeware until they find out of date drivers. They will then offer to update the drivers for a small registration fee. Since hardware drivers are constantly updated, I regularly use a driver scanner to keep my system up-to-date. Windows Update will not update drivers for your chipset, USB ports, HDD's, any SSD, etc. So you could have a rogue piece of hardware that is trying to use the same memory address as the ezdok program.

 

Hopefully this will help. I really have no more suggestions but believe one of these recommendations will work.

 

Best regards,

Share this post


Link to post

If none of the above works, it is most likely a DirectX issue. Make sure your video card drivers are not beta drivers and you have WHQL drivers installed. If you have DX10 Preview enabled, disable it and try to run the app again then go back to DX10 Preview.

 

If that does not work, try uninstalling EZDOK and make sure nothing is left of the installation. Now run a registry cleaner like CCleaner. Open up FSX at least once then shutdown. Now, reinstall EZDOK. Do not add anything from a previous installation like a previous .ini or configuration file.

 

Hope this helps.

 

Best regards,

Share this post


Link to post

The simple answer that has been mentioned a million times on the support forum is that you need to download a fresh copy of the EZDok Wrapper from the Flight 1 website and install it from that. Your hardware changes make your PC look like its not the same one that was used to install it the last time you extracted the installer from the wrapper, that is just the way the DRM works with Flight1 wrapper supplied products. Sorry if I am stating the obvious but nothing I read here or at the official forum leads me to believe you know about this DRM caveat.

 

Also if you want to use EZDok with P3D you need to download the P3D aware version of EZCA.exe from the support forum, plus you still need to manually edit the aircraft.cfg files to add the 201 camera definition..

Share this post


Link to post

The simple answer that has been mentioned a million times on the support forum is that you need to download a fresh copy of the EZDok Wrapper from the Flight 1 website and install it from that. Your hardware changes make your PC look like its not the same one that was used to install it the last time you extracted the installer from the wrapper, that is just the way the DRM works with Flight1 wrapper supplied products. Sorry if I am stating the obvious but nothing I read here or at the official forum leads me to believe you know about this DRM caveat.

 

Also if you want to use EZDok with P3D you need to download the P3D aware version of EZCA.exe from the support forum, plus you still need to manually edit the aircraft.cfg files to add the 201 camera definition..

 

Nothing came up about downloading and unwrapping your file freshly from Flight1 when I searched 'Access Violation' so maybe I missed all 1 million of them. Any who, The install I do almost every time is the file freshly out of the wrapper and the wrapper itself has been downloaded again after my hardware upgrades so this is not a DRM issue.

 

For P3D I downloaded that version and I did the 201 camera definition. I think this has to do with the OS...I'm doing what I did a few months back with the same exact software (and everything installed great), the only thing that has changed is I went from Windows 7 Home Premium to Ultimate and I also upgraded my motherboard and SSD. Thank you for your help.

Share this post


Link to post

Did you try under properties to check the box run as an administrator?

Share this post


Link to post

Did you try under properties to check the box run as an administrator?

 

"I have also tried windows defender settings, firewall settings, administrator settings and folder permission and have also installed SimAccess via the migrate tool."

Share this post


Link to post

If none of the above works, it is most likely a DirectX issue. Make sure your video card drivers are not beta drivers and you have WHQL drivers installed. If you have DX10 Preview enabled, disable it and try to run the app again then go back to DX10 Preview.

 

If that does not work, try uninstalling EZDOK and make sure nothing is left of the installation. Now run a registry cleaner like CCleaner. Open up FSX at least once then shutdown. Now, reinstall EZDOK. Do not add anything from a previous installation like a previous .ini or configuration file.

 

Hope this helps.

 

Best regards,

 

Its August 20th now and everyday I spend about an hour trying to resolve this. Yesterday night I gave up and I said I'm spending more time trying to resolve it then just trying to reformat my entire system again.

 

So, I thought it may have been a W7 Ultimate thing. I also have a license for Home premium so I reformatted my system using a pretty new build of W7 64Bit Home Premium and started all over. I had a clean install with only my GPU drivers installed, P3D, FSUIPC, and the EST Migrate tool.

 

I install EZDok, I do what was necessary to get it working with P3D and low and behold I got the SAME Access Violation error as before. I had spare RAM and I tested it with completely new RAM as well.

 

At this point the only thing that stayed the same is my SSD (840 Evo) & my Motherboard (z-97-AR).

 

After it happened again by reformatting my system without installing all drivers (to test if any of them where blocking EZDok) the same error happened. What can this tell me now? What can it possibly be...

Share this post


Link to post

I don't have a magic solution but two things you might want to check:

 

1. You claim to be using version 1.17 but your screenshot confirms that the version you're using is 1.16. You may want to re-download the latest and most feature-rich version (1.17) and reinstall it.

 

2. Ensure that your EXE.XML file, as it pertains to EZdok, reads as follows:

 

<Launch.Addon>

  <Name>EZdok camera addon</Name>

  <Disabled>False</Disabled>

  <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>

</Launch.Addon>

 

 

I consider myself fairly conversant with EZdok but I've never been able to figure out this Access violation 'nightmare'. My suggestions of items to check are therefore simply 'shots in the dark' !

 

All the best,

 

JJ

Share this post


Link to post

When I recently switched hardware I had the same exact access violation error that you are getting and was very frustrated. What worked for me was to make sure both P3D and Ezca were installed outside of the Program Files x86 folder and that full permission was given to both the Lockheed Martin and Ezca folders which it appears you have already done. Then make sure to set both the P3D and Ezca .exe's to run as administrator and make sure your exe.xml has what Jean has mentioned above.  If you run the EzDok configuration using the EMT you should not have to modify the aircraft.cfg files (I didn't have to) and I know from your flightsim.ee post that you have the EMT.  I now don't even have to run P3D in legacy mode for EZDok to fully function properly. However, I do sometimes have to close Ezca and reopen it several times once a plane is loaded to get middle mouse functionality but I believe that is a Windows 8.1 issue.  This only happens maybe 1 out of 5 times which I can deal with.

 

I have P3D v2.3 and Windows 8.1.

 

Ryan

Share this post


Link to post

I don't have a magic solution but two things you might want to check:

 

1. You claim to be using version 1.17 but your screenshot confirms that the version you're using is 1.16. You may want to re-download the latest and most feature-rich version (1.17) and reinstall it.

 

2. Ensure that your EXE.XML file, as it pertains to EZdok, reads as follows:

 

<Launch.Addon>

  <Name>EZdok camera addon</Name>

  <Disabled>False</Disabled>

  <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>

</Launch.Addon>

 

The screenshot just shows 1.16 but I have tried many many times with 1.17 and the P3D beta version. I install with migrate tool and without, I make sure that the exe.xml file is calling up EZCA.exe when i don't use the migrate tool.

 

 

What worked for me was to make sure both P3D and Ezca were installed outside of the Program Files x86 folder and that full permission was given to both the Lockheed Martin and Ezca folders which it appears you have already done

 

I have tried many options and to my knowledge I think I tested everything possible to do with permissions. Maybe some screenshots of permission settings could help me. I could match your settings to see if I am doing the same thing...

 

 

Thanks guys.

Share this post


Link to post

I'll work on those screen shots when I get home from work. Your issue is identical to what I had so I am confident we can get it resolved.

 

Ryan

Share this post


Link to post

With 2.3 I lost the ability to cycle through Views.  I would go from VC to Tower view skipping Spot view.  Sure I could right click and select it but no way could I make it stick.  This was with every AC.

 

I tried everything I could think of but eventually gave up and switched to Opus Cameras.

Share this post


Link to post

I'll work on those screen shots when I get home from work. Your issue is identical to what I had so I am confident we can get it resolved.

 

Ryan

 

Im at work too! So no rush!

 

Thanks a lot for your help, it means a lot. Im glad I found someone else with this issue. You probably remember how frustrating it was...That is me now!  :rolleyes:

 

Again, thanks. Looking forward to possibly nipping this thing in the bud!

Share this post


Link to post

Not sure if you have this working yet but I have been very busy past couple of days...just try exactly what I put in my previous post until I can get those screen shots done.

 

Ryan

Share this post


Link to post

With 2.3 I lost the ability to cycle through Views.  I would go from VC to Tower view skipping Spot view.  Sure I could right click and select it but no way could I make it stick.  This was with every AC.

 

I tried everything I could think of but eventually gave up and switched to Opus Cameras.

 

You Guys do know that outside views do not work properly - there is a key hack I think I read but I  dont bother - I disable ezca if I want to go outside - works great until there is an official version - which I hope they are working on as this is one of my favorite programs

Share this post


Link to post

The outside views work fine if you run the Ezca configuration through the EMT. At least they do for me.

 

Ryan

Share this post


Link to post

The outside views work fine if you run the Ezca configuration through the EMT. At least they do for me.

 

Ryan

Have to try it - gotta luv EMT

Share this post


Link to post

 

 


You Guys do know that outside views do not work properly - there is a key hack I think I read but I dont bother - I disable ezca if I want to go outside - works great until there is an official version - which I hope they are working on as this is one of my favorite programs

 

I don't seem to suffer from that, or at least I don't appear to experience it when using Opus for Cameras only.  I haven't configured any external views though.

Share this post


Link to post
Well I got it working right out of the box - great as this is one of favorite programs

 

What I did was download the latest wrapper from flight1 

- installed it with the latest Estonia tool when the program is installing it mentions fsx path dont worry it still installs into programs86 directory 

 

- when its done I did not run configurator 

 

- I downloaded 1.17 version from forums and installed it I dont think it asked to configure if it if it does close it 

 

- copy over the beta ezca.exe in your main ezca installed folder - its in programs86 - then launch configurator and let it do its thing - bam all working perfectly no adjustments of any kind - I am not using TIR

 

- Make sure you right mouse click exe's and install as administrator for all installs including any other programs you install

 

- Also I shut down Estonia tool before running the configurator and running P3D - EMT does not need to be used in legacy mode - it worked just fine after using it to install program

 

Here is a link to p3d beta exe

 


 

 

Half way down in post you will see a link to download it

 

3. Unrar this archive to  Program Files\EZCA folder

 

Now some have had problems getting it to work but first time I tried method above worked perfectly - if this does not work I would not have the tech savvy to help but worth giving it a try

 

Oh one more thing that might help as I always install it after a new pc build I install takeownership program and use it for my entire c: drive - here is the link to program

 


 

 


=================================================

 

REVISION:

 

Well in 2.3 had to add this to exe.xml

 


  <Launch.Addon>

    <Name>EZdok camera addon</Name>

    <Disabled>False</Disabled>

    <Path>C:\Program Files (x86)\EZCA\EZCA.exe</Path>

  </Launch.Addon>


Share this post


Link to post

Richard.. none of that has to do with the problem portrayed by OP. I have the exact same error. Only thing remaining now is moving it out of the Program Files folder.

 

Oh, and external views work just fine. In order for them to work, you have to use ezca config via EMT or manually copy the camera entry into each aircraft.cfg of your aircraft.

Share this post


Link to post

An update...

 

Removing it out of the PF x86 folder didn't help. Yesterday, I sent Oleg a PM on SF, and received a read receipt today. He's still around. I hope he finally comes clean and surprise us with 2.0 or at least a patched up version of 1.17. We don't deserve this kind of treatment as people who invested hard earned cash in his product.

Share this post


Link to post

Still same error for me...i have tried almost everything...

 

I may just invest in opus and use the cameras...the sim forums and flight1 support has not helped me at all either.

Share this post


Link to post

Still same error for me...i have tried almost everything...

 

I may just invest in opus and use the cameras...the sim forums and flight1 support has not helped me at all either.

 

Same error and what is that again ? if you want I could go into your computer to get it working 

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this