Sign in to follow this  
TomEDDW

My solution against microstutters

Recommended Posts

Hey guys!

 

I just wanted to share what helped me to eliminate all my microstutters in FSX.

 

First of all I'm using FSX SP2, Majestic's Dash 8, FTXG and Active Sky Next.

I have all settings to the right except Autogen which is at sparse.

AA is set to 4xs via Nvidia Inspector

 

On my system FSX runs well at a locked framerate of 60 FPS (external limiter) with no times under that.

 

BUT i was expieriencing those microstutters every few seconds and that annoyed me.

 

Few days ago  i was fiddling with settings and tried to get rid of the stutters...nothing helped.

I don't know why, but at some point i came across my Monitor settings at set its refresh rate from 60Hz down to 59Hz.

 

I started FSX (Still locked at 60FPS) did a testflight of about 60 minutes and didn't have a single stutter all the time.

 

Since that i didn't see anymore stutters in FSX.

 

I'm pretty sure FSX behaves different on every System but maybe this helps someone who has the same problem.

At least it's worth a try.

 

Best regards and happy flying!

 

Tom

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Can't see how or why that would work Tom.

 

The thing that improved the microstutter problem for me was using the correct affinitymask setting.

 

Usepools=0 improved things as well.

 

I keep road traffic down to 10 or 20% as I've noticed this can have a negative impact too if higher.

 

IAN

Share this post


Link to post
Share on other sites

Definitely the AffinityMask and Usepools AND!!!! if you can, give DX10, specially using Steve's Fixer, a try...

Share this post


Link to post
Share on other sites

As i am no Techfreak i don't know why this (technically) works...but it works for me...

 

just wanted to share....

 

P.S.: Those other tweaks are in my .cfg as well...

Share this post


Link to post
Share on other sites

But, Tom, after setting your monitor refresh rate to 59, the next multiplier for FPS would be, if you're running in VSync mode, 30 FPS. Are you sure your FSX is not running at 30 FPS now, which, BTW, is IMO more than sufficient ...

 

And thanks for sharing ! 

Share this post


Link to post
Share on other sites

Yeah i'm pretty sure its running at 60FPS... locking it at 30 is a huge difference in smoothness for me.

Share this post


Link to post
Share on other sites

Soulution for stutters is either BP=0 (if you have a good PC), maybe try the affinity mask tweak or just setting your FPS to unlimited. BP=0 cured all my stutters, and if you're using the DX 10 fixer, try setting your FPS to unlimited - the increase in performance is extraordinary. I've been flying with locked FPS 30 all this time with general lag and the occasional stuttering. Now, smooth as silk.

Share this post


Link to post
Share on other sites

Fi5kuS, thx for the tip regardin FSX 10 Fixer.

 

I'm sure Tom is well aware of the other fixes and using all of them, but, at least in his case what really made the difference was that change in the monitor refresh rate...

 

FSX tweaking is an Art!  Sometimes a rather Occult one :-)

Share this post


Link to post
Share on other sites

To me FSX tweaking is more of a lottery...if i had to reinstall it tomorrow all "my achievements" could be gone with the wind and i had to

start from scratch...

Share this post


Link to post
Share on other sites

Still can't see how a 1 Hz change to the monitors refresh rate makes any difference.

 

My guess is that Tom has either changed something else and that's what has improved his performance or imagination.

 

I've made changes in the past that have convinced me that performance has improved or that stuttering has decreased.  However, there is usually either something else in play or a visual or graphical disadvantage to the performance tweak that I did not notice initially.

 

If it genuinely works for Tom then I'm happy for him - just can't see the logic myself.

 

IAN

Share this post


Link to post
Share on other sites

I stopped thinking about logics in relation to FSX long time ago...

 

But i'm with you...it works for me and i'm happy with that.

Maybe its helpful for someone having the same troubles as i had. Maybe not...

 

But its worth a try anyway. isn't it?


BTW

 

My guess it has something to do with Vsynch / refresh rate.

Share this post


Link to post
Share on other sites

People have been capping their FPS at 59 with allegedly good results in some cases in many games for years. Looks like you're doing the opposite and you have your refresh rate 1 FPS lower than your FPS target, but it may well be the same principle on display, where certain monitors like certain combinations of RR and FPS figures better than others.

So I wouldn't be surprised if it's actually doing something for you Tom.

Share this post


Link to post
Share on other sites

If you have vsync on, and If your framerate is capped at or below your refresh rate (and is stuck solidly there, as in your case), you will get these microstutters as the GPU basically has to "stack up" a frame at the difference between display refresh and GPU draws. By setting the refresh down lower than the framerate cap you have eliminated that problem.

 

This is actually one of the reason's Nvidia created Gsync (and AMD is working on FreeSync) which is a way to sync the monitor directly to the GPU to eliminate stutters and input lag.

Share this post


Link to post
Share on other sites

What are your computer specs, do you use NvidiaInspector? What are your settings there?

Share this post


Link to post
Share on other sites

1/2 refresh rate and FSX locked at 30 stops lags and stutters.

 

What will never stop is micro pauses caused by popping AG, loading addon airports, or AI.

 

Maybe a faster CPU/GPU will reduce micro pauses, but I have a feeling that it's up to scenery developers.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this