Jump to content

Archived

This topic is now archived and is closed to further replies.

spilok

Is there a cure for flickering clouds?

Recommended Posts

Using AS Next and REX4...yet I still get flickering clouds down in the valleys between mountains and in other places.  Is there a weather program that has solved this unrealistic cloud activity?  I thought I read about it once on this forum, but I can't place that conversation.

 

Stan

Share this post


Link to post
Share on other sites

Hi there,

 

These issues are not related to weather engines, it's an FSX thing, here is the fix (worked like a charm for me):

 

This fix is courtesy of Mike (haldir) over at AVSIM. It gets rid of the issue of cloulds popping in and out of scenes...


Here are the instructions from him and my notes below

=================================================
Quote:

The ultimate culprit lies in the material handling of the cloud shader.

Go to this folder:

FSX\ShadersHLSL\misc

There you will find a file called SwarmCloud.fx. Make a backup copy of this file somewhere. (as always no crying if you don't do this step) 

Open the original SwarmCloud.fx in notepad or wordpad and then look down about 20 lines down from the top. You will see this entry:

bool NewMaterialUsage = true;

Change its value from true to false. Make sure to keep the semi-colon. then add the following below the entry


    bool   NewMaterialUsage = false;
> = true;
 
 
The entire section should look like this
 
const bool EffectDeclaration
<
    string Name     = "SwarmCloud";
    string Class    = "Basic";
    bool   NewMaterialUsage = false;
> = true;
 


Save and close the file.

Now, go to C:\documents & settings\<your username>\Local Settings\Application Data\Microsoft\FSX\

(If you can't get to this folder make sure that "show hidden & system files/folders" is turned on in your windows folder options.)

(This is the XP path by the way, Vista users will have to hunt for their equivlalent in the users folder.)

You will see a folder there called: Shaders.

Either move that folder out of there or delete it. Don't worry, FSX will build a new one the next time you run it. It contains a cache of the compiled shaders. This folder must be removed to ensure that the change you made to the cloud shader file above will be compiled and used on FSX's next run.

==============================================


Note: This fix can be undone by simply editing TRUE into the line as noted above. 

Also, I suggest you not delete the entire SHADER folder from 

C:\documents & settings\<your username>\Local Settings\Application Data\Microsoft\FSX\

as suggested and instead simply empty the contents of: 


C:\documents & settings\<your username>\Local Settings\Application Data\Microsoft\FSX\Shaders\Misc


Of course be sure to backup the MISC folder I noted above before trying this so it can be restored -and- backup the original SwarmCloud.fx file in the Flight Simulator X\ShadersHLSL\misc directory.

 

 

 

Dan

Share this post


Link to post
Share on other sites

I think that ASN actually makes the swarmclouds fix (what you just described) automatically, as well as the texture fix. My swarmclouds.fx file has a modification date corresponding to the first time I ran ASN, those fixes are already in there, and in this particular FSX install, I'm sure I didn't make those changes myself. I don't remember, but ASN might have even asked me the first time I ran it if I wanted to allow a fix for flickering clouds.

 

Is Spilok running DX-10, and does the swarmclouds fix work for DX-10?

Share this post


Link to post
Share on other sites

Yea I noticed there is an edit to the swarmclouds shader section from ASN which I know I didn't change anything. One of the files says swarmcloudsbefore ASN or something to that effect. Anyway I am using DX10 now and I am still seeing the flickering clouds on mountains so I am not sure if it's a DX10 issue only or if the problem is not fixed by the ASN edit. 

Share this post


Link to post
Share on other sites

It also has to do with z-order. I'm not versed in it, but a search would bring it up.


Devin Pollock
CYOW

BetaTeamB.png

Share this post


Link to post
Share on other sites

Stan,   do you have "enhanced haze simulation" checked in ASN's visibility options? This can cause the flickering and is turned off by default.  The cloud flickering against terrain surfaces has nothing to do with the swarm cloud fix.

 

For the record, I just flew yvr-yyc the other night, which is an area that previously was ruined by this effect using other wx engines.  With ASN it now looks as it should.  Wished I'd taken a screeny of it because it was stunning with the stratus settling low in the valleys and enveloping the mountains.  Bet it would be a real ripper using P3D


Regards, Kendall

Share this post


Link to post
Share on other sites

It also has to do with z-order. I'm not versed in it, but a search would bring it up.

Correct. What Stan's problem is, is due completely to the z-order issue when a cloud intersects with a mountain. The swarmcloud fix is for a whole other issue and won't fix the problem of a cloud intersecting with a mountain. That's just a problem with the way FSX renders clouds when they are in a valley between mountains or hills.

 

The swarmcloud fix is for clouds popping in and out when you pan around or when they would kind of flicker in the sky. That fix won't fix the problem when a cloud touches or interacts with a hill or mountain.


Avsim Board of Directors | Avsim Forums Moderator

Share this post


Link to post
Share on other sites

Stan ---

 

You can fix this by going to Weather, Custom Weather, then Advanced Weather and changing the cloud *base* to over 14,500ft and the cloud Top(can't remember actually term) to, say, 20,000ft or so. (the very highest mountains in Colorado are about 14,500ft). There will be no more cloud flickering. This has to be done before each flight if your flying over mountains. I don't know if it can be permanently changed in the FSX config.

 

Bruce

Share this post


Link to post
Share on other sites

Are you all sure that this issue of flickering clouds when they intersect terrain not fixed by the Disable Haze Layer function of Active Sky? I thought that was one of the things that this function was meant to deal with. If not, I guess I just stopped noticing the issue, in the same way I stopped being bothered by popping autogen.

Share this post


Link to post
Share on other sites

Zoom into a cloud/terrain interface from afar, and the clouds wobble around because they are sprites computed in a different way to the terrain facets.


Steve Waite: Engineer at codelegend.com

Share this post


Link to post
Share on other sites

Hi,

 

we're talking here about 3 different things:

 

- The "NewMaterialUsage" shader fix. This is autmatically applied by ASN and prevents cloud poping and is not related to terrain intersection. Note, that this is not resolved in 100% of cases. For example if using DX10 fixer "Discard Fogged" option and when visility increases dynamically by ASN, apparent cloud popping may also come up as fsx decides that a cloud sprite previously not shown should now be drawn.

 

- The DisableHazeLayer/EnhanceHazeLayer options. If the first is on and the second is off, can indeed help avoid the well known terrain intersection problems caused by drawing a low cirrus cloud layer to represent haze. The drawback is that this way we get the issue of climbing above hazy conditions only to be able to clearly see terrain below us. Having both of these options set to on, is a good compromise (my personal preference), as we get a subtle localized haze effect applied only to "significant" airports along our flight plan. This way terrain intersection flickering chance is mimimized (but not 100% eliminated) and we still get the nice feeiling of hazy conditions (when surface visibility is reported to be about 4-8SM)

 

- All cloud/terrain intersection flickering. This is a z-order issue (as already discussed by Devin). This is aparrent with any clouds and is the result of a bug in fsx calculating the z-order of cloud sprites only based on the lateral distance to the camera view point. This is the main reason we only notice this when the camera view angle is relatively vertical (and this is also one of the reasons we also notice weird gaps/sprite rotation issues when "looking down" or "up"). The cloud rendering system (at least in fsx) is optimized for relatively horizontal camera view angle values.


Kostas Terzides

 

devteam_bannerA.png

Share this post


Link to post
Share on other sites

Thanks.  Found enhanced haze simulation.  Will try that.

 

Stan

Share this post


Link to post
Share on other sites

I have found that REX Soft Clouds greatly reduces this effect.  Although I still occasionally see the flickering from inside the cockpit, it appears to be completely gone from exterior views.

 

FWIW

Share this post


Link to post
Share on other sites

  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,610.00 of $25,000.00 Donate Now
×
×
  • Create New...