Sign in to follow this  
jcomm

Nvidia Control Panel or Inspector Magic ?...

Recommended Posts

Any suggestions?

 

I didn't even lok at the default settings in NI - X-Plane is listed there.

 

I am not using HDR mode, and I am getting much better frame rates than I got in the past. Version 10.35 looks very smooth overall, but I wonder how you have been dealing with the settings through Nvidia Control panel or Inspector?  

 

Any suggestions welcomed, although I recall from the past that the best advice was not to use it, and simply set the rendering options through the game menu... But! There's a thread talking about gains when threaded optimization is turned OFF ?

 

Hints ?

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

Never needed to touch the NVidia settings for X-Plane, everything works just fine using the rendering settings within.

Share this post


Link to post
Share on other sites

I had horrible stutters with my 970 card which made Xplane 10 unuseable until I found the thread informing me to turn off threaded optimization. I had just about given up. Now, almost no stutters. ^_^

Share this post


Link to post
Share on other sites

I had horrible stutters with my 970 card which made Xplane 10 unuseable until I found the thread informing me to turn off threaded optimization. I had just about given up. Now, almost no stutters. ^_^

Where's that option? I have microstutters with my 970 - but I thought it was my cpu

Share this post


Link to post
Share on other sites

Yes, I turned off threaded optimization and my GTX770 showed huge improvements in smoothness. Not sure about frames but stutters almost completely disappeared.

Share this post


Link to post
Share on other sites

Don't touch NI.  Just shut off Threaded optimization from Nvidia CPL.  I have the Nvidia on the laptop and the desktop is a HD 7750. 

 

Jcomm also try AutoLOD 1.3.

Share this post


Link to post
Share on other sites

Where's that option? I have microstutters with my 970 - but I thought it was my cpu

 

Using Nvidia Inspector 1.9.7.3 I see it under the "Common" section, last option in that group.  I am on 347.52 here

Don't touch NI.  Just shut off Threaded optimization from Nvidia CPL.  I have the Nvidia on the laptop and the desktop is a HD 7750. 

 

Jcomm also try AutoLOD 1.3.

 

Tried it, but it was giving me some strange displays....  Uninstalled - back with plain XP10.35, not even the NOAA plugin, awaiting 10.40 with the Winds aloft :)

 

Anyway, for weather I mostly use PSX injecting it into XP10 :-)

Share this post


Link to post
Share on other sites

Tried it, but it was giving me some strange displays....  Uninstalled - back with plain XP10.35, not even the NOAA plugin, awaiting 10.40 with the Winds aloft :)

 

Anyway, for weather I mostly use PSX injecting it into XP10 :-)

 

 

Yep that causes some artifacts on the gauges and the sky.

 

WHY NO NOAA ? I thought you gave it an A+

Share this post


Link to post
Share on other sites

Ok guys, thanks for all your contributions so far!

 

I'll make sure threaded optimization goes OFF ( my card is a GTX 650 Ti  -  1GB GDDR5 ), and leave all of the remaining options untouched.

Share this post


Link to post
Share on other sites

It may depend on the card, amount of VRAM and driver version.  I just built a new rig and have no framerate issues, but I did disable Threaded Optimization in NI and it seemed to gain a few frames.  Actually it's difficult to tell as I run real weather, so cloud formations differ and change framerates, too.

 

I've also heard that disabling hyperthreading (which is possibly what this setting does in effect with the GPU - I know it doesn't do anything to CPU directly) helps with sims like FSX and XP, but it may also adversely affect AI traffic display if you have that increased.

 

Try it and see what happens.  It's easy enough to reverse.  And only make ONE change at a time.

Share this post


Link to post
Share on other sites

Yes, I turned off threaded optimization and my GTX770 showed huge improvements in smoothness. Not sure about frames but stutters almost completely disappeared.

 

That was the key for me too. It's amazing the difference.

Share this post


Link to post
Share on other sites

Yes, I turned off threaded optimization and my GTX770 showed huge improvements in smoothness. Not sure about frames but stutters almost completely disappeared.

 

Yep same here, with my GTX 970... was getting bad stutters.... that helped...

 

I wonder what it does though?  ie is there a tradeoff?

Share this post


Link to post
Share on other sites

i did the same thing with my 970 as well, i turned off the threaded optimization,i was about to throw the towel in. 

Share this post


Link to post
Share on other sites

Yeah, it sounds counter-intuitive to turn something labelled 'optimization' off and get performance gains but it seems to work for everyone!

Share this post


Link to post
Share on other sites

Same here :-)

 

X-Plane, the only sim that is so optimized, intrinsically, that we must downgrade any optimization options in our hardware / system to better run it :-)

Share this post


Link to post
Share on other sites

I have also tested the threaded optimization off tweak. Man what a difference! I didn't have an extreme problem with performance before, but some aircraft suffered from stutters. Most of all the LES SAAB 340 and Peters A380 (even though that VC is quite.. substandard..). However after this tweak it's smooth as butter. 

 

It's funny that such an option can make such a big difference. 

 

 

Share this post


Link to post
Share on other sites

Maybe we should tell Austin and Spunik about it

Share this post


Link to post
Share on other sites

Same here :-)

 

X-Plane, the only sim that is so optimized, intrinsically, that we must downgrade any optimization options in our hardware / system to better run it :-)

 

LMAO!!!!   :lol:

Share this post


Link to post
Share on other sites

I remember that button on the old processors to work at half the clock speed because some optimized games would then run just too fast :-)

Share this post


Link to post
Share on other sites

@Jcomm

 

 I remember that LOL that turbo switch. 

 

 Oh crap those XT-AT days wow. My first programming was Basic / Dbase superb all green displays. 

Share this post


Link to post
Share on other sites

Yes, I remember trying to run Windows 2 on a PC-AT typing on a word processor with scaled fonts and I could type faster than the CPU/GPU could display them on-screen.  But I digress...

 

The only thing I've done on my system is to turn threaded optimization OFF for X-Plane only (not General) in the regular nVidia control panel.  I've played a bit with it and still don't know if it matters on my system, which is very fast anyway.  What I have noticed that I find a bit strange, is that when completing a flight and then switching aircraft to begin another, sometimes the VRAM loads up and pulls framerates way down as it (apparently) caches back to RAM.  It's as if the previous aircraft data isn't purged properly, or perhaps there is an overlap conflict with plug-ins used by the aircraft.  Strange.  My GPU is a superclocked GTX970 with 4GB VRAM.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this