Jump to content

Archived

This topic is now archived and is closed to further replies.

shaddyy

Jaggied shadows in the VC

Recommended Posts

hey guys i have a question and hopefully someone can help me out.. I've searched the forums and only found one post about it and no answer.. but i am running V2.5 and im getting jaggied shadows in my cockpit of my NGX or any aircraft, as shown here http://prntscr.com/6j8q7e, also here is a picture of my NI http://prntscr.com/6j8rhr, and if i try and change the shadow quality in P3D it really doesn't do anything. the picture i showed of my VC shadows is on the setting of Ultra under shadow quality. Also i am running a 980GTX and 16x anisotropic and 8x MSAA filterings.

 

 

any thoughts?

 

shane.

Share this post


Link to post

Heya Shane, 

 

I too have that problem, and have yet to figure out to resolve it. I am running 2.4, and like you, all shadows are jagged or saw-tooth.


John Howell

Prepar3D V5, Windows 10 Pro, I7-9700K @ 4.6Ghz, EVGA GTX1080, 32GB Corsair Dominator 3200GHz, SanDisk Ultimate Pro 480GB SSD (OS), 2x Samsung 1TB 970 EVO M.2 (P3D), Corsair H80i V2 AIO Cooler 

Share this post


Link to post

I confirm that the problem is here as well. My opinion on it is that probably since P3D uses Dynamic lighting instead of burning the shadows to the image the issue will continue no matter what is done. It seems like the shadows are not rendered by the graphics engine to smooth the edges out. So perhaps if it does render them than it would cost a great deal of performance. So for me I prefer the shadows with jaggy edges and better performance.


Signature.png

Follow me on : Instagram

See my Trailer: A Year Of Flight

Share this post


Link to post

after a lot of tinkering and messing with CFG settings i found why this is happening, GROUND_SHADOW_TEXTURE_SIZE=512 is the default value in your P3d CFG theres also CLOUD_SHADOW_TEXTURE_SIZE=512 you dont need to change the cloud shadow texture size unless you want better cloud shadows, if you change these values to 1024, 2048, 4096 you will get the crisp shadows you are looking for, BUT BE WARNED it will impact performance if you just crank it up to 4096 and jump in a T7 or NGX. i set mine to 1024 and it looks much better, also i saw rob post a more detailed explanation in another thread here http://forum.avsim.net/topic/465106-p3d-v25-in-4k-on-a-titan-x/page-3

 

new shadows after changing that in the cfg: http://prntscr.com/6jkgpv

 

 

shane.

Share this post


Link to post

Heya Shane, 

 

Yes, I had been down that route before. 

 

Just did a fresh install of P3D V2.5, and still have jagged shadows. And the default setting on a bog-standard PREPAR3D.cfg file is GROUND_SHADOW_TEXTURE=2048.

 

There is some other gremlin in there, somewhere...   :mad:


John Howell

Prepar3D V5, Windows 10 Pro, I7-9700K @ 4.6Ghz, EVGA GTX1080, 32GB Corsair Dominator 3200GHz, SanDisk Ultimate Pro 480GB SSD (OS), 2x Samsung 1TB 970 EVO M.2 (P3D), Corsair H80i V2 AIO Cooler 

Share this post


Link to post

You dont have to manually change it cfg file you just turn up the slider in P3D - I checked and it was at 2048


Rich Sennett

               

Share this post


Link to post

Must say the cockpit shadows are disappointing, at least whatever I set them at, and they give me a huge performance hit. By contrast Steve's DX10 fixer in FSX provides for HD internal shadows and they are with this setting extremely good. The vertical component is sharp as a pin with only the horizontal aspect showing a slight sawtooth, but with virtually no frame rate hit at all.

 

I hope LM can sort out the internal shadows. They are nowhere near the quality the rest of the sim delivers.


Robert Young - retired full time developer - see my nexus mod page and my GitHub Mod page

Share this post


Link to post

Heya Shane, 

 

Yes, I had been down that route before. 

 

Just did a fresh install of P3D V2.5, and still have jagged shadows. And the default setting on a bog-standard PREPAR3D.cfg file is GROUND_SHADOW_TEXTURE=2048.

 

There is some other gremlin in there, somewhere...   :mad:

 

hm..I dont know then howell..did you try it with Nvidia inspector?

 

You dont have to manually change it cfg file you just turn up the slider in P3D - I checked and it was at 2048

 

well..i tried that before and it didn't make a difference unless you have to restart the sim for it to take effect, i just know once i changed the texture size i saw an immediate difference in shadow quality.  :wacko:

 

 

shane.

 

Share this post


Link to post

hm..I dont know then howell..did you try it with Nvidia inspector?

 

Hi yah I here yah but it must be changing that value or why would it even be there - answer: to change that value so it is changing that value - easy enough go into P3D change it to low and check cfg file - then crank it to the right in P3D and check again - bet it changed 


Rich Sennett

               

Share this post


Link to post

 

 


hm..I dont know then howell..did you try it with Nvidia inspector?

 

Yup, used Rob's Nvidia settings and nothing changed. Everything else looks great, but the shadows, they are the suck.


John Howell

Prepar3D V5, Windows 10 Pro, I7-9700K @ 4.6Ghz, EVGA GTX1080, 32GB Corsair Dominator 3200GHz, SanDisk Ultimate Pro 480GB SSD (OS), 2x Samsung 1TB 970 EVO M.2 (P3D), Corsair H80i V2 AIO Cooler 

Share this post


Link to post

Deleted prepar3d.cfg, started P3D new Prepar3d.cfg has GROUND_SHADOW_TEXTURE_SIZE=2048

 

P3d 2.5 +44

 

Jorge

Share this post


Link to post

Even with GROUND_SHADOW_TEXTURE_SIZE=4096 the shadows will usually still have problems.

I note that horizontal shadow edges usually look far less jagged than vertical shadow edges.

 

Anyone know if the shadow quality is dependent on the aircraft model itself or the textures the model is using.?

 

gb.


YSSY. Win 10, 6700K@4.8, Corsair H115i Cooler, GTX980Ti, 16GB G.Skill Trident Z F4-3200, Samsung 960 EVO M.2 256GB, ASUS Maximus VIII Ranger, Corsair HX850i 850W, Thermaltake Core X31 Case, Samsung 4K 65" TV.

Share this post


Link to post

Interesting... Same 'issue' - will follow this


Best regards,
--Anders Bermann--
____________________
Scandinavian VA

Pilot-ID: SAS2471

Share this post


Link to post
  • Tom Allensworth,
    Founder of AVSIM Online


  • Flight Simulation's Premier Resource!

    AVSIM is a free service to the flight simulation community. AVSIM is staffed completely by volunteers and all funds donated to AVSIM go directly back to supporting the community. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. Thank you for your support!

    Click here for more information and to see all donations year to date.
  • Donation Goals

    AVSIM's 2020 Fundraising Goal

    Donate to our annual general fundraising goal. This donation keeps our doors open and providing you service 24 x 7 x 365. Your donation here helps to pay our bandwidth costs, emergency funding, and other general costs that crop up from time to time. We reset this goal every new year for the following year's goal.


    34%
    $8,560.00 of $25,000.00 Donate Now
×
×
  • Create New...