Sign in to follow this  
hangar

Joe, a few issues I need help with

Recommended Posts

I just purchased the plane late last night so I've only had a chance so far to do a couple of touch & goes in the pattern. Since I have no experience with this plane I'm assuming either I'm doing something wrong or my issues may be intended by design so I thought I'd ask to find out. By the way, love the attention to all the little details on this plane...nice job, you can really feel the "love" that was put into her.

 

Here are the few issues I'm having, Joe:

1. plane wobbles & dips side to side during taxi and landings.

2. If you forget to lock the start locks during engine shut down and wish to restart engines for a second flight, the start locks can't be relocked for startup without rebooting the sim (after relocking them manually they just unlock themselves after you take the throttles out of reverse).

3. rotating beacons don't rotate.

 

...oh, one question I'm just curious about regarding the RW plane...it may be just my imagination but it feels as if this plane has an awful lot of inertia going on...more than you'd really expect to see in a plane of this size. It may be just that I'm not yet used to the spoilerons thing, but it seems that I'm often over-correcting roll rates and such because the plane has a tendency to keep rolling in the direction you roll her until you give some opposite input.

 

By the way...I did not realize until last night that I had a $6 credit coming to me from when I bought the C441...and on top of that I got another $8 credit for buying the MU2, these credit were something I didn't know you offered and they really sparked my decision to purchase. Another really smart idea, Joe...and a nice way to do business!

 

Thanks again.

 

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I just purchased the plane late last night so I've only had a chance so far to do a couple of touch & goes in the pattern. Since I have no experience with this plane I'm assuming either I'm doing something wrong or my issues may be intended by design so I thought I'd ask to find out. By the way, love the attention to all the little details on this plane...nice job, you can really feel the "love" that was put into her.

 

Here are the few issues I'm having, Joe:

 

1. plane wobbles & dips side to side during taxi and landings.

2. If you forget to lock the start locks during engine shut down and wish to restart engines for a second flight, the start locks can't be relocked for startup without rebooting the sim (after relocking them manually they just unlock themselves after you take the throttles out of reverse).

3. rotating beacons don't rotate.

 

...oh, one question I'm just curious about regarding the RW plane...it may be just my imagination but it feels as if this plane has an awful lot of inertia going on...more than you'd really expect to see in a plane of this size. It may be just that I'm not yet used to the spoilerons thing, but it seems that I'm often over-correcting roll rates and such because the plane has a tendency to keep rolling in the direction you roll her until you give some opposite input.

 

By the way...I did not realize until last night that I had a $6 credit coming to me from when I bought the C441...and on top of that I got another $8 credit for buying the MU2, these credit were something I didn't know you offered and they really sparked my decision to purchase. Another really smart idea, Joe...and a nice way to do business!

 

Thanks again.

 

Thanks Dave!

 

1.

The plane wobbling side to side on taxi may just be that youre taking turns a bit fast. The MU-2 has a very narrow track, and with the added inertia from the tip tanks, FSX tends to exaggerate the inertial results.

 

On landing, it is very important in a Mits to ensure that both engines come into reverse at the same time, and at the same rate. Again, a result of the narrow track gear.

 

2.

The most likely culprit here is that your condition levers are in the emergency stop position while trying to reset the start locks. Make sure they're in the taxi range. Otherwise, the propellers will try to feather when the power levers are brought back out of reverse.

 

3.

The MU-2 actually has oscillating beacons. We too agree that they could use some improvement, so expect to see that in an upcoming service release.

 

 

Joe

Share this post


Link to post
Share on other sites

Ok Joe, later today I will try the start locks again using the condition levers as you suggested when I do an engine restart.

 

Understood about the beacon needing repair (on my end here I havent really noticed any movement at all).

 

Regarding the sway/dipping...taxi speeds are quite low but you can still notice it gently swaying from side to side if you look carefully while taxiing straight (no turns)...but the bigger issue is really on landings. The issue isn't with the reversers,.. it's an excessive wing dip that occurs upon touch down...now my wings may not be a perfect 90 degrees level when I kiss the pavement as I am not yet used to the roll inputs as I mentioned earlier, BUT they are close enough to level (maybe 88 degrees?) so that you shouldn't see such an exaggerated dip...almost to the point of being wreck-less really. It's so bad that I don't think I'd fly on windy days. There's definitely something wrong...just not certain if it's just me or not.

Share this post


Link to post
Share on other sites

Joe,

 

the condition lever was indeed my start lock issue on resetting things, so that's solved...thank you.

 

The FDE needs some more work though, either that or you've uploaded the wrong version. She's way too unstable on touchdown, to the point where the plane is a deathtrap, especially on  short fields. Dunno if it's just the way you set the contact points or if it's more serious than that but you should really check into it because something really seems to be amiss.

 

Also, I was only able to get the flight director to work in manual mode one time only (on my first flight actually). I've tried a few times since then to get the f/d modes to work without the a/p but it doesnt seem capture anymore. test it out. Also, some of the mode lights don't come on such as approach mode light.

Share this post


Link to post
Share on other sites

Hi -

 

It does feel a bit wobbly on the ground but it hasn't kept me from flying it, and may be real-world behaviour. I also agree with the comments on the beacons - I kinda see how they are supposed to oscillate rather than rotate but they are mostly steady bright red lights.

 

I don't think the AP/FD is quite right. When I set the FD/AP for HDG and a reasonable pitch up on the command bars for take off and then engage the AP in a stabilized attitude and heading (flying the command bars) the airplane makes a couple of sloppy oscillations in pitch and roll before settling down. Like others have reported I have been unable to perform a precision approach - the annuciators on the AP panel for APR ARM or CAP never light up.

 

I can't figure out the RMI at all. No matter what NDB or VOR frequency is tuned, both RMI needles point directly at the nose when ADF is selected and directly at the tail when VOR is selected.

 

The DME display in the HSI does not show distance information from any waypoint in the GTN 750. It appears to display the DME reading from VOR2. The separate DME readout panel also seems to show DME from NAV2 regardless of which VOR is selected.

 

I'm by no means an expert and have no time in a MU-2, but I am a RW pilot and have flown aircraft with a pretty sophisticated AP/FD (and RMI); this isn't how it is supposed to work. I've read the manual but if anyone can point out anything I've overlooked or offer any other suggestions I would appreciate it.

 

Great airplane to model, and this version has a lot of potential. Based on my experience with your 402 and 441 models I have no doubt that these issues will be fixed.

 

Many thanks,

 

Marc Musgrove

Share this post


Link to post
Share on other sites

Hi if you have ACUFEEL installed from A2A than you will have to reduce the LAND side forces slider and possibly mess around with the LAND Shock Absorbers they may be too soft. Came across this on another forum fixed a few planes that has similar issues.

Share this post


Link to post
Share on other sites

Could the amount of the tip tank fuel be a a factor? I noticed the max fuel imbalance between tips and outers is 150 pounds. After listening to the fuel distribution sequence in the videos, I loaded tips with - 100%, the outers and mains with 50%. This easily exceeded the fuel imbalance in the POH Limitation section. Moreover, I loaded the fuel incorrectly according to the POH, which calls for: mains - outers - tips; in that order. In my case, I think it may explain the substantial roll experienced immediately after rotation. It probably would have been lights out had I lost an engine. 

Share this post


Link to post
Share on other sites

Hi if you have ACUFEEL installed from A2A than you will have to reduce the LAND side forces slider and possibly mess around with the LAND Shock Absorbers they may be too soft. Came across this on another forum fixed a few planes that has similar issues.

 Yea I have some A2A stuff...I'll check into it.

Share this post


Link to post
Share on other sites

I'm not having any stability issues on my end, just FYI. No wobbling whatsoever. Not doubting your experience, just reporting. I do not have Acufeel installed, FYI.

 

I do agree something is amiss with the RMI and Flight Director.  I actually have a had a few issues with altitude capture as well. Sometimes the AP will blow right through the selected altitude or after being stable it will begin a descent for no reason. Other than that,it's a joy to fly.

Share this post


Link to post
Share on other sites

Confirmed... the cause of my excessive wing dips upon touchdown appears to indeed have been caused by accufeel adding extra side forces...a big thanks goes out to Mjrhealth for the heads-up on this one!

 

@Todd - yes I am also finding those same issues with the a/p itself (blowing thru alts and beginning descents for no apparent reason).

Share this post


Link to post
Share on other sites

I don't have any Stability issues either , the Mu-2 does  lean more than any other plane I have ever been in . The only thing harder than flying the  RW plane is 

fueling it. 

 

The Problems I'm having.

 

If i select the GTN  model I get a black screen CTD , I can select a different plane and set up my GTN and then select the MU-2 and it will work. Not sure if its a simconnect 

issue or what  but so far i haven't been able to figure it out.

 

The Plane will not fly the Nav heading, once it Captures the heading it flies in a circle and then heads north, the heading works ok but something is wrong. The Altitude capture

only works in small increments  and is not reliable at all.

 

I was real Hesitant to spend the money on this Plane but I had a Boss that flew " The 2" and the time I was able to spend in it was a Blast, the flight model is pretty 

close and the panel is good enough to keep your attention focused.  The model is Ok but looks kinda Cartoonish in a way but Flyable. 

 

Hope to see some  updates, I think this project has Potential.

mb

Share this post


Link to post
Share on other sites

Any realistic ETA for the stores?  Silly network issues so I have to wait for a store to get it live.

 

Edit:  Disregard...finally got the right tech for troubleshooting and got the network connection up...now to install this baby

Share this post


Link to post
Share on other sites

I am having similar problems.

 

1. Sometime ALTSEL works and sometimes it doesn't.

2. During climb under AP or even at ALT, large heading adjustment cause the plane to dive.

3. It does not seem to hold the glide slope well. Throttle adjustment have little effect.

4. A bit wobbly on T/O and approach.

5. I note in the videos that Joe taxis with torque at 15. I have to go to at least 40 just to get it moving. Then have to back off quickly to avoid overspeed.

 

I really like the airplane and hope some of these anomalies can be fixed

Share this post


Link to post
Share on other sites

Flew the Non GTN  model and it seemed to capture the Nav a little better but the ALT capture was bucking up and down . The more i 

fly the MU-2  the more i hope I didn't waste my money.  Hopefully we will get a layered paint kit and a few updates real soon. 

Share this post


Link to post
Share on other sites

So here's an update. I disabled Accusim effects on my system and found that the ground wobbles went away completely. One could probably fine-tune the Accusim settings to eliminate the ground wobbles and keep the other features, but at this point I have not done so. I do have the FSUIPC surface friction lua script running and have found it easy to control taxi speed and to get it stopped on the runway.

 

I have been very satisfied with the in-flight stability and have not had the landing difficulties that others have reported.

 

The avionics issues are the biggest concern to me. I'd like the AP/FD to work a bit more realistically (or what I imagine to be more realistically - smoother I guess). I'd like to be able to perform a precision approach with the AP/FD, both ILS and LPV. I'd like the RMI ADF and VOR needles to work. I'd like the HSI DME and the other DME indicator to work in a way that I can understand. 

 

Minor stuff - fix the beacons - it is such a pretty airplane it would really shine with the beacons displayed correctly. Really minor stuff - the OAT guage does not work; it stays pegged at the lower end of the scale.

 

Having said all that I want to be clear that I do not regret my purchase at all. Hand-flying the model is a lot of fun and feels "right" to me (realistic or not I can't say - never been in a MU-2 much less flown one). The basic AP/FD functions work and the GTN 750 integration is fine. I also have faith that Flysimware, unlike some vendors (C******o - you know who you are), will fix these problems.

 

I am a bit surprised that the developers haven't been more active in the forums since the release, but I know that they have real jobs too.

 

Marc Musgrove

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this