Sign in to follow this  
N405GJ

Extremely long load times on launch

Recommended Posts

Good morning all. So a couple weeks ago, for some reason I cannot find, P3D started to take forever to load. I have been timing it and it usually takes 3-4 minutes from clicking the icon (with admin rights), to the scenario setup screen. I have gone over every thing I can think of, but can not seem to find the culprit. The only notable item is a quick flash of the "Generating Scenery Indexes" bar with every launch. Anyone have any suggestions? Thanks for the assistance.

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

Hey Matt,

 

What add-ons are you using?  It is possible that an add-on may be causing the long load time.  What version of P3D are you using?

 

-Jim

Share this post


Link to post

Me too, v2.5 and started one day months ago. What I find odd is that it only first launch of P3D of the day.  If I exit and re-launch it loads twice as fast.  I've not ruled out a scenery issue yet so I am watching this with interest.

Share this post


Link to post

If a conventional hard drive, time for a defrag

 

If an SSD, time to move/remove some of the latency-inducing aircraft or scenery

 

Those are usually the delay-makers, unless there is a problem loading autogen or some textures.

Share this post


Link to post

In my case, AI traffic is the culprit. I recently reinstalled P3D from scratch, starting it every 2 or 3 addons installed. After installing 3rd party AI traffic I went from 15s (from double click to scenario window) to ~1mn.

 

I tried to move the ai planes to a new simobjects subfolder, adding the entry to simobjects.cfg. But to no avail, starting time is still massively longer.

Share this post


Link to post

The biggest causes of slow load times for me are MyTraffic and FS Global Ultimate Mesh. If I remove both of those items, P3D opens and loads fast.

Share this post


Link to post

The biggest causes of slow load times for me are MyTraffic and FS Global Ultimate Mesh. If I remove both of those items, P3D opens and loads fast.

I have a similar experience for those same two add-ons.

 

I have noted in both FSX and P3D that the extremely long load times only happen the first time that I launch the sim.

 

Global Ultimate mesh will cause the sim to pause at the 6 percent point of loading textures for about 2 minutes - but only the first time I run it. If I exit the sim and restart without rebooting the computer, it breezes right past the 6 percent point and loads much faster - and will continue to do so for subsequent sim restarts within the same session

 

Even though I have Windows file indexing turned off, I assume that the OS must be maintaining a memory cache of file locations on the HD that persists after exiting the sim. Rebooting the computer erases the cache and it goes back to the initial long pause at 6 percent on first load of the sim.

Share this post


Link to post

I'll be darned, FS Global mesh seems to be the common denominator for me too.  This is very helpful.  I do not use any traffic add-on, tried em and like parts of em but not enough to keep em.

Share this post


Link to post

Wow, that triggered my memory. I did recently switch AI traffic programs. I bet that's it. Thanks guys. I'll test it out and confirm.

Share this post


Link to post

 

 


In my case, AI traffic is the culprit. I recently reinstalled P3D from scratch, starting it every 2 or 3 addons installed. After installing 3rd party AI traffic I went from 15s (from double click to scenario window) to ~1mn.

 

Same here.  

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this