Sign in to follow this  
turner112

Really slow between screens

Recommended Posts

Hi all,

 

Seems FSX is getting slower and slower between loading screens; for example, if I simply want to change aircraft, sometimes the screen is blank for almost a minute.

 

Same thing if I'm changing locations, or weather.

 

Sometimes it takes quite a while to start up; sometimes (often) it hangs when quitting.

 

However, the sim itself is running fine.

 

I have no idea what could be causing this...

 

Any thoughts?

 

thanks,

Andrew

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

The more add-ons and planes you add to FSX, the slower it responds.

Share this post


Link to post
Share on other sites

Yep, spot on.

 

I'm the same. She's full of payware and takes a while to get going.

 

Runs fine though.

 

Hirdy

Share this post


Link to post
Share on other sites

Do you have at least 8GB of physical RAM?  Sometimes a shortage of RAM will exhibit the symptoms you're seeing.

 

Doug

Share this post


Link to post
Share on other sites

Hi guys - 

 

16gb ram.... I don't really have too many add-ons; mostly just a few planes and RealityXP stuff.

 

I have Active Sky Next, too.

 

cheers

Andrew

Share this post


Link to post
Share on other sites

Which OS are you running, Andrew?   If Win10, there are some of us that have been having similar issues to what you have described.

 

Chris

Share this post


Link to post
Share on other sites

Which OS are you running, Andrew?   If Win10, there are some of us that have been having similar issues to what you have described.

 

Chris

I am on Win 10 and have similiar issues. It seems to have started with Win 10 a couple of weeks ago.

Share this post


Link to post
Share on other sites

Put this in your fsx cfg under "Main" DisablePreload=1 this should help with the window screens.  Josh

Share this post


Link to post
Share on other sites

1. Make sure you are using official Win 10 video drivers. Also AMD drivers are having a hard time with Win 10.

 

2. Disabling Preload will actually slow things down. Please do not do anything with that option. People don't understand what that option is for.

Share this post


Link to post
Share on other sites

Its always worked for me with the slow screens in the menu. And it doesn't slow things down or cause other problems .  Do what you want there is no harm in trying and see if it works for you. I don't want to get in a pissing match here so this is all I have to say on this matter. Josh

Share this post


Link to post
Share on other sites

1. Make sure you are using official Win 10 video drivers. Also AMD drivers are having a hard time with Win 10.

 

2. Disabling Preload will actually slow things down. Please do not do anything with that option. People don't understand what that option is for.

Jim,

 

Thanks for that input. I am "slowly" monitoring Win 10 and making single changes and testing closely. I am sure I will figure out what (maybe the latest AMD driver?) is causing the problem.

 

Bob

Share this post


Link to post
Share on other sites

Start with a fresh FSX install with no add-ons and you'll see how fast FSX is.

 

Once you start adding things to FSX, then it will start to slow down.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this