Sign in to follow this  
Joseph29

Help! FS9 is not starting

Recommended Posts

Tonight I am trying to run FS9 and instead of starting I am getting a message saying "Please login with administrator privileges and try again"

 

Now I was just using FS last night and I didn't change anything from last night. So why isn't my FS9 starting??

 

(I am using Windows 7)

Share this post


Link to post
Share on other sites
Help AVSIM continue to serve you!
Please donate today!

I restarted the computer and tried again. FS9 still will not start and now I am not even getting that message I was before.

Share this post


Link to post
Share on other sites

Perfect. Look for it and remove it. Some crazy updates do crazy things sometimes. I haven't updated in months since I had something similar. Good or bad, right or wrong, that's what I've done.

Ditto - same here. I have Windows 7 and don't see any benefit from Microsoft updates. The last one I tried the computer would not work properly - login to a black screen. Thanks Microsoft!

Share this post


Link to post
Share on other sites

Hi,

if somebody has found out, could you please post the KB... number of this update?

Thanks!

Share this post


Link to post
Share on other sites

Hi,

if somebody has found out, could you please post the KB... number of this update?

Thanks!

 

kb3086255

 

Joseph29 linked to it in one of his posts

Share this post


Link to post
Share on other sites

A wanring on this ....  I didn't find out about this issue until I had tried multiple other "fixes" on my system, such a virus scans .etc.  Every time I subsequently tried to run FS, apparently Windows ate away portions of the FS installation.  scenery.cfg, teraain.cfg, and worst of all my entire Modules folder. 

 

I now am doing a total reinstall of FS9, and of course there are payware issues that I'm sure will be a big problem.  What the H*** was MS thinking?  At least warn people of what an update does before resleasing it.

Share this post


Link to post
Share on other sites

Hi, i think i found a fix for this issue. Just download the old No-CD crack and replace the fs9.exe with the one in the crack. And then apply the 9.1 update. Hope it works.

 

Cheers,

Swapnil

Share this post


Link to post
Share on other sites

"Eating away the sim? That sounds permanent. Eating away from the disc, or eating what's already installed?"

 

No I didn't lose any files from the disk, only from the FS9 installation on the hard drive.  But I lost enough to have to do a complete reinstall and rebuild  :mad:

Share this post


Link to post
Share on other sites

"Eating away the sim? That sounds permanent. Eating away from the disc, or eating what's already installed?"

 

No I didn't lose any files from the disk, only from the FS9 installation on the hard drive. But I lost enough to have to do a complete reinstall and rebuild :mad:

How did you notice your sim was losing things?

 

I restored to before the update happened. The sim starts slowly. If I exit the sim and try to go back in, I get the same error message. I restored again (somehow to the same point), and it did the same thing (started slowly). (I haven't exited yet, but I suspect I'll just get the same results). I'll update once I'm done simming.

Share this post


Link to post
Share on other sites

How did you notice your sim was losing things?

 

I restored to before the update happened. The sim starts slowly. If I exit the sim and try to go back in, I get the same error message. I restored again (somehow to the same point), and it did the same thing (started slowly). (I haven't exited yet, but I suspect I'll just get the same results). I'll update once I'm done simming.

I can't edit the post for some reason. I do confirm I cannot use the similator again if I exit; I have to restore again to be able to use the sim.

Share this post


Link to post
Share on other sites

I too have experienced horrible results with FS9 x Win7 updates. If my memory serves me correctly, sometime in late 2014 (Nov I believe), a very large group of updates installed and virtually rendered our motion sim (FS9 based) useless. Searching the web led me to fellow simmers who warned and advised of the updates - basically what you guys are doing now. Once uninstalled, (and I mean there were over 30), everything worked again.

 

Auto update was exploded after that. LOL

 

Mitch

Share this post


Link to post
Share on other sites

Same thing happened me. Latest W7 updates stopped FS9 from starting. Grrr!!!

 

Did a system restore and everything working fine.

 

I only install what MS calls 'important' updates on a prompt. A lesson learned, no more updates.

 

*Just a word of warning about FS91upd.exe: it may not install properly over FS2004 addon files. The installer suggests you remove these before executing the application.

 

John

Share this post


Link to post
Share on other sites

Windows XP Forever!

Nice!

 

I am running Windows 7 Ultimate. 

 

In the technical data for the KB3086255 it says all its doing is stopping a service.

 

To start the service and use the "original" FS9.exe -open the command prompt and type:  sc start secdrv

 

I just tested it on my machine.

Share this post


Link to post
Share on other sites

We have had several individuals in this topic banned or warned about telling others or indicating use of a patch to get around use of fs9 w/o the cd's.  This is why the topic is now being monitored. 

Share this post


Link to post
Share on other sites

I use WIN XP SP2 with no updates applied and as frequently stated, it's the best way to run FS9.

 

But for other Windows users there is a mature discussion of how to deal with Microsoft's update KB3086255, over at flightsim.com:

 

http://www.flightsim.com/vbfs/showthread.php?293089-Sim-won-t-load!

 

For some, this will provide the only path to keeping our favourite sim operational.

Share this post


Link to post
Share on other sites

Further to FormerSF3's post above, here's Microsoft's advice on KB3086255:

 

Known issues in this security update
  • After you install this security update, some programs may not run. (For example, some video games may not run.) To work around this issue, you can temporarily turn on the service for the secdrv.sys driver by running certain commands, or by editing the registry.

    Note When you no longer require the service to be running, we recommend that you turn off the service again.

    Warning This workaround may make a computer or a network more vulnerable to attack by malicious users or by malicious software such as viruses. We do not recommend this workaround but are providing this information so that you can implement this workaround at your own discretion. Use this workaround at your own risk.

    To do this, type the following commands at an elevated command prompt. You should press Enter after you type each command.
    • To disable the driver's service, type the following command: sc config secdrv start= disabled
    • To set the driver's service to manual, type the following command: sc config secdrv start= demand
    • To enable the driver's service (and to set it to automatic), type the following command: sc config secdrv start=auto
    • To manually start the driver's service, type the following command: sc start secdrv
    • To manually stop the driver's service, type the following command: sc stop secdrv

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this