Sign in to follow this  
newtie

Orbx KPSP in P3D V3?

Recommended Posts

Hi all-

 

Does anyone have Palm Springs working in V3/ I went thru the install routine, it found my P3Dv3 installation but no airport appears.

 

Thanks,

Share this post


Link to post
Help AVSIM continue to serve you!
Please donate today!

You may benefit more by asking this question directly to the ORBX team, but if it helps, run FTX Central and make sure the area you are flying in is active.

 

-Jim

Share this post


Link to post

ORBX has not released the version with the P3Dv3 installer yet. They also do not recommend either to trick the current installer or doing things by hand, so let's wait.

Edward

Share this post


Link to post

What probably happened is that, since the airport was not made compatible with P3Dv3 yet, the installer couldn't add it to the scenery file. Try adding it manually inside P3D, it should work ;).

 

Cheers!

Share this post


Link to post

I have it running fine, just install as usual and point it to your v3 directory.

Jim

Share this post


Link to post

I have it running fine, just install as usual and point it to your v3 directory.

Jim

As I mentioned, it found my V3 location fine upon install (I saw the path), but no scenery. I'm wondering if a scenery cfg entry is needed.

Share this post


Link to post

As I mentioned, it found my V3 location fine upon install (I saw the path), but no scenery. I'm wondering if a scenery cfg entry is needed.

 

That's exactly what I said. It installed fine, but it probably couldn't add the entry to the scenery.cfg file. You need to do that manually.

Share this post


Link to post

That's exactly what I said. It installed fine, but it probably couldn't add the entry to the scenery.cfg file. You need to do that manually.

 

Was forced to do so to make it works on my P3Dv3... until Orbx update the installer ;-)

 

22257053573_46cb057b82_b_d.jpg

Share this post


Link to post

That's exactly what I said. It installed fine, but it probably couldn't add the entry to the scenery.cfg file. You need to do that manually.

Sorry.

 

Would you happen to know what that looks like, that is, general syntax? I know my path will be different. 

 

Could you post it or PM me? I'll giver a try when I get home from work.

 

Thanks,

Mark

Share this post


Link to post

Sorry.

 

Would you happen to know what that looks like, that is, general syntax? I know my path will be different. 

 

Could you post it or PM me? I'll giver a try when I get home from work.

 

Thanks,

Mark

 

There's no need to edit the file itself. Just open P3D, go to Scenery Library and add the folders. It's easier that way.

Share this post


Link to post

Is your P3Dv3 also popping a warning window upon start, telling you that the "objectflow.dll" of KPSP is not compatible? Or did you find a way around this issue? Some of the ORBX airports I installed into P3Dv3 using the EMT show this little error, I then simply deactivate the .dll, but it is a little bit boring that for each start of P3Dv3, this message keeps popping up. That's why I think it is still the better option to just wait until there is an update for the scenery...

Share this post


Link to post

Is your P3Dv3 also popping a warning window upon start, telling you that the "objectflow.dll" of KPSP is not compatible? Or did you find a way around this issue? Some of the ORBX airports I installed into P3Dv3 using the EMT show this little error, I then simply deactivate the .dll, but it is a little bit boring that for each start of P3Dv3, this message keeps popping up. That's why I think it is still the better option to just wait until there is an update for the scenery...

I don`t get the warning now since the Library's were updated for v3 the other day, same as KWYS buildings now show up in v3

Share this post


Link to post

Well I DID update the libraries as well, FTX central v2 is not showing me anymore that my ORBXLIBs are out of date. Still I get this error message for about 4 or 5 of my about 10 installed ORBX airports. Strange...

Share this post


Link to post

There's no need to edit the file itself. Just open P3D, go to Scenery Library and add the folders. It's easier that way.

Completed this last night. Works perfect.

 

Thanks,

Mark

Share this post


Link to post

I have the latest PSP installer and installing it to a different directory isn't possible.  How are you guys doing this?  When the installer pops up there are three radio buttons, FSX, P3D1 and P3D2.  If I press P3D2 it goes to my P3D2 directory location - no way to change it.

 

Bah I just used the scenery library location from P3D2 to install it to v3.  It looks fine.  There are no night lighting effects though. I did MRY as well but there's a huge elevation issue.  Oh well I can live with that until they release NCA and MRY in v3.

 

pspv3.jpg

Share this post


Link to post

KPSP (as most other Orbx airports) install without problems either by setting some smart symbolic links to trick the installer (replacing all relevant P3Dv2 directories with symbolic links to the their counterparts in P3Dv3) or by using the Estonia Migration Tool (I don't own it but heard it works fine). Do not try the first procedure if you don't understand the inner workings of P3D, because it has some potential to screw up your P3D if you do it wrong.

Share this post


Link to post

Well I DID update the libraries as well, FTX central v2 is not showing me anymore that my ORBXLIBs are out of date. Still I get this error message for about 4 or 5 of my about 10 installed ORBX airports. Strange...

 

Well, my bad. I really have those error messages for four of my ORBX airports, but KPSP is not amongst them.

Share this post


Link to post

When will an update to KPSP be released  to allow it to be installed in P3DV3?

percy

Share this post


Link to post

 

 


When will an update to KPSP be released to allow it to be installed in P3DV3?

Jarrad posted on the Orbx forums yesterday about KPSP, he was waiting to release KTEX(which came out today) and he will finish the installer and a patch for v3.2 and FTX SOCAL, apparently it`s a lot of work and will need time.

  • Upvote 1

Share this post


Link to post

I was able to install KPSP and KSEZ in P3D V3 by editing the registry and changing

 

P3Dv3: [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Lockheed Martin\Prepar3D v3]

to   [HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Lockheed Martin\Prepar3D v2]

 

Perform both installations and then changing the registry back to the original

 

[HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Lockheed Martin\Prepar3D v3]

 

Everything seems to be working fine.

Share this post


Link to post

I noticed that this thread started 17 November 2015 and still no KPSP installer. While applauding ORBX's stellar performance with the v3 installers it strikes me as odd that one of the jewel APTS  in the FTX crown remains an orphan.

Ah well, patience, like hope, springs eternal in the human breast. No pun intended.

 

Gareth

Share this post


Link to post

I noticed that this thread started 17 November 2015 and still no KPSP installer. While applauding ORBX's stellar performance with the v3 installers it strikes me as odd that one of the jewel APTS  in the FTX crown remains an orphan.

Ah well, patience, like hope, springs eternal in the human breast. No pun intended.

 

Gareth

JV said they had to do some more tweaking to get it to go along with new openlc, hopefully it won't be much longer.

Share this post


Link to post

Ah, that's good news. Thanks very much Jason.

  • Upvote 1

Share this post


Link to post

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now
Sign in to follow this